VideoHelp Forum

Try DVDFab and copy Ultra HD Blu-rays and DVDs! Or rip iTunes movies and music! Download free trial !
+ Reply to Thread
Results 1 to 18 of 18
  1. anyone that has got their computer connected to an a/v reciever which is then connected to their tv, can you please share what video player/filters/splitters etc you use?

    I am beyond fed up of mine,
    I have a pc with ryzen 1700x cpu
    running windows 7 ultiamte x64
    1080ti gpu which is connected to my surround sound and for the life of me I cannot get it to work.

    After countless hours of doing the same things, uninstalling players, namely potplayer, uninstalling and reinstalling filters ac3filter, lav and ffdshow and trying every possible combination of settings I seemed to have finally got it working, but it worked for a grand total of one episode of a show.

    Last night it seemed ok, I sat down to start a new series and all was perfect.
    yet today, i sat down to start episode 2 and there was no sound.
    The exact same hardware, running the exact same software, playing a video file with the exact same format, bitrate and channel audio, for some reason decided to once again stop working.
    No lav filter icon in tray, no matter that lav was the only active filter and was set in both its own settings and potplayers to accept aac and ac3, none of that mattered, today it all decided that one succesful hour from my pos system was enough to warrant the price.

    Sorry for the frustration in this post, but I have spent honest to god countless hours and so far I have spent 100 times more hours figuring out a never ending stream of problems instead of getting to actually use it.

    Also sorry for not providing that much information here, i have had so many problems that i've uninstalled everything and im hoping I can just try copying someone else's setup, even if that can serve as a start point. Because if I provide screenshots to try and trouble shoot I will need to include upwards 30 screenshots to show the amount of things that have gone wrong and since there is no evident reason for things stopping working at random it would also be a lot to ask for help fixing it, so I think starting fresh, hopefully with some help I can finally just get some audio going.

    today for example, the same video file that worked flawlessly less than 20 hours ago, wont work today
    The lav filters that ran flawlessly last night, simply will not start today
    AC3filter technically loads and the icon is in the tray, but it says there are no input channels for the audio and the video will not play.

    It is frustrating because it has worked in the past on this exact set up, the only difference between this unusable disaster and what use to be a semi functioning surround sound system is that my OS now is on an m.2 drive instead of a hdd
    Last edited by HelpPlease; 25th May 2020 at 16:02.
    Quote Quote  
  2. Member
    Join Date
    Mar 2020
    Rome, Italy, Europe
    Search Comp PM
    Hello, try using MPC-HC. I use it with my Onkyo SR705 and TV. You will not need anything else.
    Quote Quote  
  3. Thanks, but how do you get AAC to work though? Unless I am mistaken the built filter doesnt have an encode AC3 option, so my reciever sees it as "multichannel" which is not bad I suppose, but it means none of the recievers own options work- dynamic volume, late night mode, audyssey balance, room correction,cinema filter all that kind of stuff is greyed out because it is not recognized as a compatible surround format its treated more like an upmixed stereo audio,so im not getting the most out of my system
    Last edited by HelpPlease; 25th May 2020 at 16:55.
    Quote Quote  
  4. Member
    Join Date
    Mar 2020
    Rome, Italy, Europe
    Search Comp PM
    I never used AAC multichannel audio. MPC-HC can use external filter and you can use ffdshow to recode in real time the aac sound to DTS or ac3 i think, I never tried, just theory. Sorry with AAC i'm not so skilled.
    I don't know if I can post other forum pages link here but i found something about make aac multichannel work as PCM 5.1 which is better than convert to other lossy formats. You can reach it by searching aac multichnnel and MPC-HC.
    Quote Quote  
  5. Jriver
    Works with different receivers (onkyo--denon--yamaha) and have had different TVs on this system
    Never an issue
    Last edited by Iamback; 25th May 2020 at 19:53.
    Quote Quote  
  6. Originally Posted by johnjonh View Post
    I never used AAC multichannel audio. MPC-HC can use external filter and you can use ffdshow to recode in real time the aac sound to DTS or ac3 i think, I never tried, just theory. Sorry with AAC i'm not so skilled.
    I don't know if I can post other forum pages link here but i found something about make aac multichannel work as PCM 5.1 which is better than convert to other lossy formats. You can reach it by searching aac multichnnel and MPC-HC.
    unfortunately does not work, same issue I was having with potplayer and ffdshow, the filters for some reason no longer work.
    2 nights ago fine.
    but now everything is broken.

    LAV and ffdshow have the same problem when i try them. I set for the majority of formats, set in both potplayer/mpc-hc and its own settings to accept DTS, DD, True hd etc and I have chcked and double checked that the right filter is set from drop down menus, and has codec/format enabled and is set as priority, so i dont think im overlooking something simple like the wrong filter having priority. But when I open any videos with any of those formats I get no sound, there is no lav/ffdshow icon in tray, for some reason the filters simply will not run.

    AC3filter is a different kind of shitshow, i set it to be used for aac and ac3, yet when I open any video with those formats i get neither video nor audio.
    The ac3filter panel says spdif status no data, it shows that there are no input audio channels
    and the video will not play, if I click anywhere on the seek bar it just stays on that frame as though it were paused, and no matter what I try it will not play.
    Quote Quote  
  7. Try MPC-BE, in its internal filters which are evolved filters of original filters of MPC-HC before the switch over to LAV Filters.
    options -> internal filters -> audio decoder -> audio decoder settings button -> encode to ac3

    What do you want exactly, I read it, but I must admit I am not 100% sure I got it. The above will encode it to ac3, does that help you?
    Quote Quote  
  8. I want to bitstream compatible audios.
    and I want to be able to encode aac to ac3 so I can make the most out of my reciever's customisation options.

    I want to figure out a way to get the filters and player configured to do this so I can watch more than one hour without the audio mysteriously breaking again. It just isnt acceptable that epsiode 1 of a series can bitstream flawlessly, but episode 2 with the exact same format cant even play audio, that at 8pm lav filters work exactly as intended but then at 9pm with no evident reason lav filters wont even run

    I will give MPC-BE a try and update here, thank you

    Update: so this is wierd but mpc-be works, it is awkard because it means when switching from my monitor to my tv I have to manually go into the filters and disable the ac3 encoding if I want to get sound from my monitor, but it does work it does allow the audio to be sent to my reciever and recognized properly, for some reason the built in audio decoders in mpc-be can handle and ouput aac files that neither LAV, ffdshow or ac3filter can handle.
    Last edited by HelpPlease; 27th May 2020 at 11:07. Reason: adding update
    Quote Quote  
  9. Internal Filters of MPC-BE are very good. I think the problem is that the monitor is receiving ac3 but expects only PCM. If you have a dedicated pc speaker set with optical toslink input like z906, which supports AC3 bitstreaming it should work, but maybe not all sampling rates and bit depths like an avr.

    MPC-BE has also dual audio output, which is very rare, take a look at it perhaps you can set it up to match the existing hardware.

    If you need any further assistance let me know
    Quote Quote  
  10. Sorry, but another update, everything is ****ed to high heavens already.

    MPC-BE seemed to work, aac was encoded to ac3
    DTS, true hd were bitstreamed perfectly.

    So I used ccleaner to remove any traces left of my potplayer attempts, restarted my computer to finish the cleaning process and now back to square one.
    Every single video, with every single format shows as multichannel pcm, doesnt matter if has a aac 2.0 audio or if it had truehd 5.1
    DTS, TrueHD will not bitstream
    AAC will not encode to ac3 .

    So I have a different player installed but am right back to where I was, I had working audio for a few brief glorious moments, and now the most I can get out of any my videos is a horribly balance, all music/no audible speech, poor attempt at pseudo surround sound because for some reason the audio is yet either not being sent properly from my computer or not being properly detected by my reciever. I mean on what planet does that make sense? everything working, 1 restart later, with zero changes made to the system and everything is broken again

    I do not understand how it keeps breaking itself with literally no changes happening
    Last edited by HelpPlease; 27th May 2020 at 13:04.
    Quote Quote  
  11. If I understand you correctly, there was not only the restart but also ccleaner was used. -> All so called "cleaners" are IMHO more bad than good. I am pretty sure some registry entries were deleted or altered, which were not "crap" like the cleaner thought.
    I personally used that kind of software also, but only on my xp time and even after a few month I ditched it. After I knew what program to use and leaving the system as it is, I never had any issues, but you must find your reference apps, one of them is MPC-BE on my list.

    Since Micro$oft released the 2004 Update some minutes ago, my advice, backup all your data and start a new clean install and start from scratch, but be sure to backup your important data and also the hidden folder in user files, many programs store settings there and can be retored later.

    An easier method is turn off pc, remove the ssd/hdd and place another one, install windows (it is easy) and store the old one at a safe place, it can be put back if you really want go back for some reason and copy some files/settings or whatever.
    Quote Quote  
  12. sorry, I dont mean to sound dismissive, but thats not the case here, i have ccleaner set to wipe temp files and stuff in recycle bin older than 24 hours, I had problems with installing custom themes on my OS and learnt my lesson from that about disabling ccleaners windows and registry "cleaning" options.

    Also i am afraid I dont think a fresh os install is on the cards, it was a pain in the ass to get windows 7 installed on a m.2 drive since microsoft sabotaged it and removed native compatibility.

    I give up, problems with technology are fine, and im usually very good at bashing my face on that wall until through sheer stubborness I find a solution, but this is different. I am having problems that have no explanation, that should not exist, that give no errors.:

    1: a media player playing one file flawlessly, but the next file with the exact same format nothing works.
    2: how a fresh install of mpc-be can work for roughly 10 minutes and then stop with no evident reason
    3: how lav filters can allow me to bitstream audio for an hour, but pausing the vide for 30 seconds to go pee and when I come down lav filters is no longer able to recognize that or indeed any audio anymore
    4: how lav/ffdshow/ac3 whatever filter is currently being used can play faultlessly for brief periods of time and then one second stop opening, regardless of settings, regardless of filter priority, regardless of media being played, the filters out right refuse to even open.
    5: how all formats, with any number of channels are all recognized and treated as though they were the same
    6: how I can have a media player, with just one external filter installed, have it set to control aac/ac3, hve the internal filters disabled, yet external filters *will not* run and the only active filter shown during playback is "built in audio codec transform low merit"
    7:how mpc-be built in filters (albeit briefly) can handle formats and encode aac to ac3 and send the correct audio to my reciever, yet those same exact files cause lav to stop even opening, and in ac3 show "no data"

    If anyone can explain any of this utter shit^ I would truly be grateful, because from my perspective it makes no sense whatsoever

    It is just bullshit. I am sorry for the anger throughout most of my messages, but all I want is to sit down and listen to some good quality audio, but hundreds of hours of effort and still all I have is a very expensive paper weight, even if these never ending unfounded problems somehow dissapeared right now, a surround sound system is still by a country mile the most finnicky, fickle, obtuse,convoluted, needlessly awkward piece of technology I have ever encountered. I have a good computer, I have any one of the most common and recommended media players, I have the internal or external filters setup to bitstream audio, there is absolutely no reason for it to be this complicated just to get audio
    Last edited by HelpPlease; 28th May 2020 at 03:49. Reason: grammar
    Quote Quote  
  13. yeah seems like the only thing left to try, I wasnt to keen on the idea, firstly because its a paid product, and one ive never heard of, but also it is apparently a media centre sofware, I already use kodi to organize and browse my library, so the only things I had read about jriver where that it isnt a good call to run it in conjuction with kodi, but at this point I guess its try this and if not its time to go office space on my equipment
    Quote Quote  
  14. Pay once, when upgrade comes if you don't need new features, don't upgrade/pay
    As far as Kodi>>> JRiver is better overall than Kodi
    They have a free trial, 30 days
    Quote Quote  
  15. One last question if I may

    [Attachment 53556 - Click to enlarge]

    [Attachment 53557 - Click to enlarge]

    [Attachment 53558 - Click to enlarge]

    As you can see the current player ONLY has lav filters added as external filters and ONLY has lav in the drop down menu for audio formats, yet for some reason, somehow is using ffdshow filter and at the time of typing this message atleast is actually working, all formats are being sent correctly, I am expecting them to break any second. FFDshow isnt even supposed to be installed on my system anymore it was all uninstalled with revo yesterday, just downloaded an older version of potplayer whilst downloading jriver to have one last crack at getting things back to how they use to be.

    But does anybody have any idea what the hell is going on with my system?
    Last edited by HelpPlease; 28th May 2020 at 10:26.
    Quote Quote  
  16. Maybe potplayer uses it, JRiver doesn't
    Quote Quote  
  17. Any mod that sees this you can go ahead and lock and/or delete this thread now.

    I am grateful for all the replies but unfortunatly it has been a waste of time.

    in the over 200 hours ive been trying to figure out the most needlessly picky piece of technologic shit I have ever had the misfortunate of dealing with it worked for maybe 3 hours in total. and still no closer to understanding why as literally none of the bs it is throwing my way makes a lick of sense. I would genuinelly pay if someone could explain the nonsense that my system does

    I have no idea why bitstreaming could work for 1 hour then stop
    I have no idea why mpc-be could encode for less than 10 minutes total then never worked again
    I have no idea why on tuesday night a video played perfectly but on wednesday the exact video with the exact setup had no sound no matter what I did.

    Between my previous post and this one things worked. Not in a manner that had even an iota of logic, as my last post shows, i was using potplayer, with lav audio decoder,. i had jriver installed but after testing some files I was having similar issues to all the other media players I have tried, and since potplayer seemed to be broken in a way that actually made it work, I uninstalled jriver. So for 2 days potplayer and lav where the ONLY video playback related things installed on my entire system.
    Everything else was uninstalled with revo uninstaller pro, recycle bin and temp files wiped with ccleaner and search everything could find no missed traces of any of it.

    Yet despite that somehow for 2 measly days my potplayer used ffdshow which doesnt even exist on my system yet things worked, video played smooth and ffdshow was miraculously bitstreaming and encoding aac to ac3 without skipping a beat.

    Yet in typical fashion it is all ****ed....again.
    Turned it on this morning, sat down to relax a little after some chores and I noticed the sound was off compared to the past 2 days, and sure enough no more ffdshow icon, lav wont open regardless of the settings or audio format, every single audio codec that has ever existed are all detected as stero "multichannel" output.

    to the guy talking about jriver, I tried it and not identical issues, but the same type of issues unfortunately.
    One episode of a show - perfect. no faults.
    episode 2, with identical video and audio format/bitrate/channels - no sound
    episode 3 again, identical media formats - sound, but its 5.1 channels yet my reciever is only detecting 2.

    I'm calling it, surround sound was a mistake, useless piece of shit is hands down the worst piece of technology I have encountered in my 30 years and yes it was expensive but it clearly isnt capable of doing its only reason for existing so I am just going to bin the ******* thing. At this point I am out of pocket a few hundred quid and the only thing that money has bought me is stress and frustration
    Last edited by HelpPlease; 30th May 2020 at 05:46.
    Quote Quote  

Similar Threads