VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 11 of 11
Thread
  1. Member
    Join Date
    Mar 2020
    Location
    america
    Search Comp PM
    Using the latest drivers and application versions.
    Capturing using MediaExpress software, have tried all uncompressed video formats available in the program.
    Usually my selected format is uncompressed 4:2:2 10-bit AVI.

    This card is supposed to capture the incoming stream in its native format but when I record from a 1080i59.94 source through HDMI (24p film in broadcast transport format) although I get good image quality and no dropped frames, it doesn't seem to actually produce an interlaced video file?

    Instead what I get is one of two unusual results:

    1: Frame advance of MediaExpress recording shows all frames of original video presented progressive but the fourth repeats on the fifth frame, so:
    1,2,3,4,4,1b,2b,3b,4b,4b,1c,2c,3c,4c,4c,1d, etc
    Watching playback I'm not sure if this causes any visible issues, but it still isn't what I expected to get (which would be a normal interlaced video).

    2: Frame advance of MediaExpress recording displays three progressive frames but the fourth and fifth frames display interlaced "between" type frames, like this:
    1,2,3,3.5,4.5,1b,2b,3b,3.5b,4.5b,1c, etc
    When viewing playback there are obvious distracting artifacts. The first result mentioned above is at least acceptable but when the recording is like this second result I can't use it.
    What's really strange about this one is that when played in the MediaExpress software, motion has no or minimal artifacts and frame advance is identical to the first result. But as soon as I try to open the recorded video in any other video program, it gets this strange interlaced result instead.

    Why would it look like the first result in MediaExpress but not in anything else? If the data for progressive frames is viewable in MediaExpress, what's happening to it in other programs? There's no conversion in-between. It's the same video data.

    So my questions/problems are this:

    Is there a way to record the input in its native interlaced format?

    If not, how can I at least get the first result from my recorded video instead of the second? (And why does the second result look identical the first in MediaExpress but in no other video editing or media playback software?)

    Is the presence of a repeated frame in the first result going to have a negative impact on motion quality or on final compressed video filesize? Am I going to need to do some kind of frame-drop/timestretch editing procedure or is it an acceptable result for a non-professional backup?

    The ideal solution if anybody can help find it would be to just record it interlaced like it's supposed to be, then playback will be fine on just about any device.
    Quote Quote  
  2. You have a film source. 24p becomes 30i by duplicating frames for 2 or 3 fields, ie, 3:2 pulldown. In case number 1 the display has been deinterlaced, you're only seeing one field of the source. In case number 2 you are seeing the two interlaced frames out of every 5 -- the normal appearance of 3:2 pulldown when not deinteralced. My guess is some codecs are flagging that the video is interlaced (case 1) and some are not (case 2). So in the first case the editor is deinterlacing the preview window, in the second case not. Upload a short sample if you want verification.
    Quote Quote  
  3. Member
    Join Date
    Mar 2020
    Location
    america
    Search Comp PM
    That sounds reasonable, thanks. If I understand correctly then the first result is no real problem because despite the duplicate frame it will still playback at the correct rate? The duplicate frame does not mean that any fields were lost or improperly combined?
    As for the second result, it is because of different types of 3:2 pulldown being used in different sources transmit by 1080i? Or is the problem with my video capture? Since the transport is interlaced I am trying to just capture it exactly as it is, then watch or view it with identical appearance to the source.

    If I frame advance the source video for either result, using the standalone device storing the video, I don't see any 3:2 artifacts at all, neither interlacing artifacts nor repeated frames. Both results' sources get what looks like either perfectly combined interlaced frames or progressive frames, on any display I have (HDTV and PC LCD monitor), whether direct from the source storage or routed through the capture card's input monitor. Up until that point everything looks 1:1 with no problems. Frame progression is 1,2,3,4,5,6,7,8,9,10, etc.
    That changes when I actually capture and save the uncompressed AVI, to either the first or second result. But the second result appears identical to the first when viewed with the capture software. So it does seem like at first it's processing it acceptably and saving usable data, identical to the first result (if that result is actually fine?) But in this case how/where would the codec flags be changing? It might make no difference but I wonder why the storage device can advance 1:1 frame by frame but my AVI capture is different.

    Is the best option for correcting the second result (and make it again like it is shown in MediaExpress which is identical with the first result) to just run the uncompressed avi through an AviSynth deinterlace/3:2 removal? If left unprocessed will the backup with the visibly interlaced frames actually play without any apparent problem on a display device with native interlaced resolution support (or on PC using a media player with de-interlacing/3:2 fixes enabled)? I guess this would be acceptable but it would be much better to have clear pictures when frame advancing.

    I'm just not clear on what to do in this situation to get the closest to an exact backup of the source.

    I can upload if that would be especially helpful, sure.

    Thanks
    Last edited by videobackup; 30th Mar 2020 at 13:08.
    Quote Quote  
  4. Originally Posted by videobackup View Post
    That sounds reasonable, thanks. If I understand correctly then the first result is no real problem because despite the duplicate frame it will still playback at the correct rate?
    As for the second result, it is because of different types of 3:2 pulldown being used in different sources transmit by 1080i? Or is the problem with my video capture?
    Both are probably correct. They are two manifestations of the same thing. It's probably just a matter of how they're flagged and how you're viewing them.

    24 fps film become 59.94 field per second interlaced video by duplicating each frame for the duration of 2 or 3 fields, alternating between the two. So 4 film frames:

    Code:
    1 2 3 4
    are broadcast as a series of 10 fields:

    Code:
    1t 1b 2t 2b 2t 3b 3t 4b 4t 4b
    Note how the first film frame is repeated for 2 fields, the second film frame is repeated for 3 fields, etc. When those are digitized, pairs of consecutive fields are woven together to produce 5 video frames:

    Code:
    1t+1b 2t+2b 2t+3b 3t+4b 4t+4b
    Notice how all the fields are still there and in the same order. Three of those frames (1t+1b 2t+2b 4t+4b) look progressive because they contain fields from the same film frame. Two look interlaced (2t+3b 3t+4b) because they contain fields from different film frames. That is what you are seeing in your second case because you are seeing both fields at the same time. But if your viewer is deinterlacing the frames you see (I'll use the simplest deinterlacing method here, just discard every other field):

    Code:
    1t    2t    2t    3t    4t
    That is what you are describing in your first case. So I'm speculating that both those captures are correct. It's just a matter of whether they are being deinterlaced or not when you view them. Some containers and codecs have specific flags indicating the video is interlaced, some don't. So a player may deinterlace some videos (because they are flagged as interalced) but not others (because there are no flags).

    Originally Posted by videobackup View Post
    I can upload if that would be especially helpful, sure.
    I recommend you do that. A few seconds with continuous motion -- a medium speed panning shot, for example.
    Quote Quote  
  5. Member
    Join Date
    Mar 2020
    Location
    america
    Search Comp PM
    Thanks, if the captures are fine then I'll try to find playback options that fix the video appearance, if that doesn't work I'll upload then. I don't understand the problem but it sounds like if the captured videos that display wrong frame by frame on the computer with the capture card actually look fine during playback on an interlaced display, then the difference between the first result and the second is in terms of fields and not frames, and if viewed field by field would actually be the same result?
    Last edited by videobackup; 30th Mar 2020 at 14:00.
    Quote Quote  
  6. Member
    Join Date
    Mar 2020
    Location
    america
    Search Comp PM
    Playback on interlaced resolution still looks wrong. Thanks for your help but isn't there anything I can try without having to specially edit and upload video samples?
    Quote Quote  
  7. Try opening your files in VirtualDub2. Use Video -> Filters -> Add to add the Bob Doubler Filter. In the dialog for that filter set the field order (TFF, BFF) and set the Deinterlacing Method to Bob. Close the dialogs with the OK buttons. Back to the main interface step through your video with the left and right arrow keys. Watch the output pane as you step through the video field by field . You should see (ignore the aliasing artifacts from the simple bob) the 3:2 repeat pattern of the original film frames.
    Quote Quote  
  8. Member
    Join Date
    Mar 2020
    Location
    america
    Search Comp PM
    Thanks, that works in VDub2.
    You mentioned the video codec flags so is there some way to change that directly and fix the playback problem?
    Quote Quote  
  9. What container and video codec are you using?
    Quote Quote  
  10. Member
    Join Date
    Mar 2020
    Location
    america
    Search Comp PM
    AVI/OpenDML, YUV 4:2:2 10-bit, v210 AJA Video Systems Xena.
    Hopefully it is possible for you to offer some options to fix the problem I'm having? This approach with one question or explanation at a time doesn't yet have any actionable information.
    Last edited by videobackup; 30th Mar 2020 at 21:48.
    Quote Quote  
  11. The AVI container doesn't usually have a flag for interlacing. The ODML 2 extensions added such a flag but few programs use it. I don't know if the AJA software adds such flags. If you know how to use a hex editor (VirtualDub2 has one built in, Tools -> Hex Editor) look for the vprp chunk (just search for the letters vprp) -- that's the ODML extension that can include interlace flags. (Careful, those letters can appear as data within the video or audio data -- if they appear withing a few thousand bytes it's probably a vprp chunk). If the files don't include the vprp chunk you can add it with a quick remux with ffmpeg:

    Code:
    ffmpeg -i input.avi -codec copy -field_order XX output.avi
    where XX will be tt or bb. See field_order here: https://www.ffmpeg.org/ffmpeg-all.html#Codec-Options

    From what I've read the v210 format supports interlaced video and an interlaced flag but I don't know what players respond to it.
    Quote Quote  



Similar Threads