VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 6 of 6
Thread

Threaded View

  1. My camcorder won't power on, according to one of the 12voltvids videos, the fuse is blown. https://youtu.be/C5DNd54ksgE
    The service manual shows 6 fuses, are they the ones circled in red? They don't make a beep sound when I test them for continuity on the multimeter. They give me a value of 0.65V instead
    Image Attached Thumbnails Click image for larger version

Name:	IMG_3542.JPG
Views:	35
Size:	2.91 MB
ID:	52304  

    CCD-TRV15_X.pdf  

    Last edited by digicube; 10th Mar 2020 at 17:13.
    Quote Quote  
  2. Member dellsam34's Avatar
    Join Date
    Jan 2016
    Location
    Paris Ca, 92345 Mexico
    Search PM
    More of resistors, could be diodes.
    Quote Quote  
  3. Most likely those are resistors and measuring 0.65V across them means nothing.
    All the fuses are on the DD105 board, shown at the top of the schematic on page 4-122.

    * WITH THE POWER OFF AND BATTERY REMOVED * a fuse should be checked on the resistance (Ohms) range and for their 1.4A rating should measure less than 1 Ohm. Note that using the continuity range or worse still a dedicated continuity tester can permanently damage the surrounding circuity.

    Brian.
    Quote Quote  
  4. Bummer I can't find a 3mm 1.4A smd fuse on digikey or mouser. I guess I have to use a smaller one with wires? https://www.digikey.com/product-detail/en/ERB-RE1R40V/P121392CT-ND/6564397/?itemSeq=320431505

    going to 1.5A gives a lot more options. https://www.digikey.com/products/en/circuit-protection/fuses/139?k=&pkeyword=&sv=0&pv1...=1&pageSize=25
    Last edited by digicube; 11th Mar 2020 at 13:40.
    Quote Quote  
  5. Thanks. I found the fuses on the other side of the board. PS803 is blown.
    Image Attached Thumbnails Click image for larger version

Name:	IMG_3544.JPG
Views:	27
Size:	4.06 MB
ID:	52310  

    Click image for larger version

Name:	IMG_3543.JPG
Views:	35
Size:	3.97 MB
ID:	52311  

    Quote Quote  
  6. You should be fine to use 1.5A, fuse ratings are not very precise in manufacture and in any case have a time element to how long it takes to operate under different overload conditions. They don't live forever at 1.4A and pop instantly at 1.41A !

    Unfortunately, PS803 is the main fuse to the 3.3V supply line regulator so it feeds many parts of the camera. If a new fuse pops it could be difficult to isolate the fault.

    Brian.
    Quote Quote  



Similar Threads