VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 6 of 6
Thread
  1. The hardware:
    - I have Windows 10 PC running on i5-9600k with 16GB DDR 4 and 500 GB m.2 drive for system that I also use for capture and 2xWD Red in Raid for storage.
    - WinFast PxDVR3200 H that I used before to capture video
    - Terratec Grabster AV300 MX - i also tried to grab video with
    - JVC HR-S9500 with TBC


    Before had computer running on Windows 7 and I did VHS capture with WinFast PxDVR32000 with decent results. I remember using VirtualDub with huffy lossless codec and later would de-interlace the video and encode it in AviDemux to x264.

    Capturing with WinFast PxDVR3200 H
    Now I'm trying to to the same thing again as I have found a bunch of VHS cassettes (PAL_B) and when capturing in VirtualDub my audio goes out of sync. Here are my current timing settings -> https://prnt.sc/r4pexl. I have also tried playing with these settings but nothing seems to really work. Video codec: huffy or uncompressed, audio codec: uncompressed, audio playback is disabled during the recording. Tried video in overlay or preview. After I start the capture, instantly the frames inserted goes to 8 or 9 -> https://prnt.sc/r4pkme and later it can add up (sometimes in 30 minutes I have 10-15 sometimes I have 50). I never have the dropped frames. I don't have anti-virus program running or any other app I can think off that would cause these problems (I usually close Skype, Dropbox, Malwarebytes, Chrome...) before I start the capture.

    Capturing with Terratec Grabster AV300 MX
    I have also tried the Terratec Grabster AV300 MX but it's software MAGIX Video easy TerraTec Edition is sh*t. In VirtualDub this capture device frame rate that it sends constantly changes from 15 up to 40 -> https://prnt.sc/r4pg89 resulting in lot of dropped frames and heavy sync problems.

    In both cases S-Video cable was used for the video.

    What am I doing wrong here?
    Any help is welcome.

    Thank you in advance.
    Last edited by videocapn00b; 19th Feb 2020 at 10:50.
    Quote Quote  
  2. It's been a long time since I've used VirtualDub for capturing. But... Don't let VirtualDub play the audio while it's capturing. I always had the best luck with "Do not resync between audio and video streams"
    Quote Quote  
  3. I have just been playing a bit with capturing using iuVCR and WinFast PxDVR3200 H and it seems to perform much better than VirtualDub as it keeps the video and audio in sync. I have just recorded 15 minute clip and looks good. Doing a test on a longer video...
    Quote Quote  
  4. Member
    Join Date
    Feb 2018
    Location
    College Station, TX, USA
    Search Comp PM
    You may also have multiple device drivers (filters) hooking the video feed unintentionally.

    I see this a lot because I test with a lot of different video capture devices.

    I have to be very diligent to "scrub" my system of old or currently (unused) device drivers "especially" when those other hardware video capture devices are not installed or connected. Their device driver (filters) [still] enable and occupy memory space and eat CPU cycles.

    I have made this mistake over-and-over and-over.

    I get lazy or complacent and forget I just had a different USB capture device plugged in, then install a video capture card or swap USB video capture dongles.. and [bang] the frame drops and audio sync go crazy.. even when audio playback is not enabled.

    I manually go into windows unistall, find the device driver or capture software for that old device and remove it.. and [bingo] the problem goes away.

    I think it has something to do with the [Merrit] system Directshow assigns to "filters" and the Graphbuilder library call Third Party developers always use in their code to summon the video capture graph for the current video capture device.

    The Merrit system allows mega codec libraries like Media Composer to "override" the "filters" that might come with the actual hardware device, or layer on top of them and that adds delay to video capture flow.

    Or worse..

    Some "filters" will refuse to process the stream and drop all frames unless the actual hardware they support is detected as being connected.. then I get a totally Black screen. Again.. remove the old hardware drivers and application software and everything works.. even without a reboot.

    But some Ultra Cheap poorly written capture software may install drivers and filters that cannot be uninstalled by simply running the uninstaller.. then I have to wipe the machine and reinstall the operating system and install [only] the currently used video capture hardware device drivers and software and everything works.. what a pain.

    As a [half-way] solution.. I make a [System-Restore] backup deliberately before installing device drivers and capture software, then restore from that backup when I want to switch to different hardware.. its messy.. and takes forever restoring that partial backup.. but so far it seems to work everytime.

    The real problem with [System-Restore] is it "consumes" the previous backup every time, once you've used it restore once.. you have to take another.. if you forget to take another.. you won't have one to restore from.. and its back to reinstalling the operating system to get it back to a "clean" state.

    This system does not allow you the convenience of leaving multiple video capture device drivers, filters and capture application software installed at one time.. because "predictably".. they interfere with one another.

    According to Microsoft at the time.. this was by-design.. only later versions of windows that were called "Media Center" would they allow.. or support multiple instances .. of the "same brand" of video capture card.. mixing and matching multiples of different brands was never built into the system.. because most systems only had one or two threads and not enough resources to multiplex the capture streams.

    This has not changed even up to Windows 10... even if you have multiple cores and hyperthreads (which is deprecated).
    Last edited by jwillis84; 19th Feb 2020 at 18:46.
    Quote Quote  
  5. Originally Posted by videocapn00b View Post
    I have just been playing a bit with capturing using iuVCR and WinFast PxDVR3200 H and it seems to perform much better than VirtualDub
    VirtualDub is very flexible and can usually be made to work with just about any capture device. On the other hand that flexibility makes it harder to get configured correctly.
    Quote Quote  
  6. @jwillis84 - yes but that seemed like a lot of work to get it done. I have tried setting up different things but nothing that I did made it work. I was suspecting that it has to do something with the Radeon / ATI software but never had time to try and remove it...

    @jagabo - I ended up recording with iuVCR. I have just captured a 3hour video without any sync problems, so I'll keep using it. I record uncompressed video and audio so the files are quite big (about 75GB per hour) but I don't care as long as there are no sync problems. I compress the video once the capture is done, delete the big file and proceed to the next one. I'm really happy with how iuVCR as it works really good and is really simple to use (I just start it and press record) as it loads all the custom settings as they were so no setup is needed once the app is started. Also it allows you to make profiles for different captures that you can load easily.
    Last edited by videocapn00b; 20th Feb 2020 at 05:37.
    Quote Quote  



Similar Threads