VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 16 of 16
Thread
  1. Hi,
    when I'm using QTGMC, it's denoising and I don't want it.

    See picture below.

    Deinterlaced in 25p with other programm

    Click image for larger version

Name:	Deinterlace Premiere.jpg
Views:	143
Size:	110.3 KB
ID:	51178

    Deinterlaced in QTGMC
    You see the "ghosting" letters...

    Click image for larger version

Name:	QTGMC.jpeg
Views:	149
Size:	157.9 KB
ID:	51179

    (For the example I took Frame 10)

    How can I disalbe the Denoising process.

    Thank you
    Image Attached Files
    Quote Quote  
  2. use the lossless mode such as:

    # official qtgmc docu: Twice refined source-match with true lossless. Exact detail, but likely combing and shimmer
    QTGMC( Preset="fast", SourceMatch=3, Lossless=1, Sharpness=0.4, TR2=2, EdiThreads=4)
    Selecteven()
    Quote Quote  
  3. Hello themaster1

    I forgot the fact, that I want a 50p file.

    So with this script, you see that the picture is a little bit "jumping" up and down.

    You can see it on the logo, when you're clicking frame by frame in virtualdub.

    I've the newest QTGMC installed.
    Image Attached Files
    Quote Quote  
  4. Originally Posted by diginoob View Post
    I want a 50p file
    Remove the SelectEven(). There will still be a little ghosting though.
    Quote Quote  
  5. @jagabo

    Yes, thats right.
    But the little jumping effect (seen on logo for example) are there.
    (See jumping.avi above)
    Quote Quote  
  6. Yes, by forcing QTGMC to keep the original fields you are reducing its ability to remove vertical bounce like you see in the logo.
    Quote Quote  
  7. OK, with default parameters (but with denoising ON which I don't want) it's not bouncing.

    So why I can't disable denoising and get a stable picture?

    I don't understand, why the denosing process is stabilizing the picture.
    You know what I mean.
    Quote Quote  
  8. Because denoising is a part of stabilizing the picture. Occasional ghosting is a side effect of that process.
    Quote Quote  
  9. Originally Posted by jagabo View Post
    Because denoising is a part of stabilizing the picture. .
    Ok, wow.
    I never thought that.
    So I have two choices.

    1. ghosting, stabilized Picture
    2. no ghosting, unstabilized Picture

    I couldn't say, which "error" I will take. They are not aceptable to me.
    Quote Quote  
  10. All deinterlacers have side effects. There's simply no perfect way to convert half pictures (every other scan line) to full pictures.
    Quote Quote  
  11. Originally Posted by jagabo View Post
    All deinterlacers have side effects. There's simply no perfect way to convert half pictures (every other scan line) to full pictures.
    ... which is why I recommend that everyone quit doing deinterlacing. Leave it as interlaced and let your TV do the deinterlacing. They all do a near-perfect job these days, so deinterlacing is simply a waste of time, and a way to needlessly degrade your video.

    Most people say that you still need to deinterlace when you re-size interlaced video, but even that isn't true. You can resize without deinterlacing, if you know what you're doing. Here's one example:

    Code:
    function IResize(clip Clip, int NewWidth, int NewHeight) {
      Clip
      SeparateFields() 
      Shift=(GetParity() ? -0.25 : 0.25) * (Height()/Float(NewHeight/2)-1.0)
      E  = SelectEven().Spline36resize(NewWidth, NewHeight/2, 0,    Shift)
      O  = SelectOdd( ).Spline36resize(NewWidth, NewHeight/2, 0,   -Shift)
      Ec = SelectEven().Spline36Resize(NewWidth, NewHeight/2, 0,  2*Shift)
      Oc = SelectOdd( ).Spline36Resize(NewWidth, NewHeight/2, 0, -2*shift)
      Interleave(E, O)
      IsYV12() ? MergeChroma(Interleave(Ec, Oc)) : Last
      Weave()
    }
    Here's a link to a generic function which lets you apply any function to interlaced video, without deinterlacing:

    ApplyInterlacedFilter

    [edit]Here's a link to the long discussion where IResize was developed:

    IResize Development
    Last edited by johnmeyer; 23rd Dec 2019 at 10:01. Reason: added last link
    Quote Quote  
  12. You can try a little post processing yourself. Create two QTGMC versions, one normal, the other lossess. Build a horizontal edge mask to use as an alpha mask to overlay them.

    Code:
    ll = QTGMC(Preset="fast", SourceMatch=3, Lossless=1, Sharpness=0.4, TR2=2, EdiThreads=4)
    nm = QTGMC(Preset="fast")
    edges = AbsSubtract(ll.Blur(0.0, 1.0), ll).mt_binarize(12).mt_expand(chroma="-128").Blur(1.0)
    Overlay(ll, nm, mask=edges)
    The normal, highly stabilized, version is used only where there are strong horizontal edges.
    Quote Quote  
  13. Did you put 'AssumeTFF' before using QTGMC? It makes a difference.

    Or you can try a different deinterlacer:

    AVISource("denoising.avi")
    AssumeTFF()
    yadifmod(mode=1, edeint=nnedi3(field=-2))
    Image Attached Files
    Quote Quote  
  14. Originally Posted by manono View Post
    Did you put 'AssumeTFF' before using QTGMC? It makes a difference.
    Good idea. And, if that doesn't work, try AssumeBFF. Most modern video is TFF, but this is doom9.org, and people bring strange videos to this place.
    Quote Quote  
  15. Remove assumetff and try QTGMC with these settings.
    This gets rid of that bouncing left and right that you didn't like, and has less ghosting artifacts than your picture example does.

    QTGMC(preset="slow", matchpreset="slow", matchpreset2="slow", fpsdivisor=2, sourcematch=3)

    The minor leftover ghosting artifacts go by so quick, that I doubt you will even see them in real time playback. You will most likely have to pause over and over quickly to actually look for them.
    Quote Quote  
  16. Originally Posted by killerteengohan View Post
    QTGMC(preset="slow", matchpreset="slow", matchpreset2="slow", fpsdivisor=2, sourcematch=3)
    Maybe you didn't notice the post where he said he wants 50p?
    Quote Quote  



Similar Threads