VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 11 of 11
Thread
  1. I have a video file from a ProRes recorder (Odyssey 7Q+) and when I copy an audio stream to a new file, ffmpeg seems to be changing the audio properties, including the codec. MediaInfo also says the original audio is signed, and the new audio is unsigned.


    ffmpeg i Video1.mov -map 0:6 -c copy New video.mov

    Original Audio (stream 0:6): pcm_s32be (lpcm / 0x6D63706C), 48000 Hz, 2 channels, s32, 3072 kb/s (default)

    New Audio (stream 0:0): pcm_s32be (in32 / 0x32336E69), 48000 Hz, stereo, s32, 3072 kb/s (default)

    Any help is appreciated!
    Last edited by vandalay22; 5th Nov 2019 at 20:49.
    Quote Quote  
  2. I believe lpcm is an alias for in32 (different versions of the Quicktime spec). Both audios show the pcm-s32be -- pcm, signed, 32 bit, big endian. MediaInfo is probably just wrong. Is the audio playing incorrectly?
    Quote Quote  
  3. Originally Posted by jagabo View Post
    I believe lpcm is an alias for in32 (different versions of the Quicktime spec). Both audios show the pcm-s32be -- pcm, signed, 32 bit, big endian. MediaInfo is probably just wrong. Is the audio playing incorrectly?
    Something is wrong, as the Convergent Design muxing software that I am using is giving the following error when it hits the new file: unsupported audio compression:kDataFormatTypeUnknown

    Any suggestions?
    Quote Quote  
  4. Try using the -atag option to fource the tag to lpcm.
    Quote Quote  
  5. Originally Posted by jagabo View Post
    Try using the -atag option to fource the tag to lpcm.
    Good thought. I used this (not sure it it is correct)

    ffmpeg -i Video1.mov -map 0:6 -atag lpcm -c copy New_video.mov

    It resulted in an error "Tag lpcm incompatible with output codec id '65545' (in32)"

    Any other suggestions?
    Quote Quote  
  6. You can try submitting a ffmpeg bug report ticket to have a developer look at it
    https://trac.ffmpeg.org/wiki

    or try asking CD, they have good support
    Quote Quote  
  7. As a quick test, you can use a hex editor to change the tag manually.
    Quote Quote  
  8. Originally Posted by jagabo View Post
    As a quick test, you can use a hex editor to change the tag manually.
    Thanks jagabo. In the hex editor I changed in32 entries to lpcm. After this ffmpeg displayed:

    Audio: pcm_s16be (lpcm / 0x6D63706C), 48000 Hz, stereo, s16, 1536 kb/s (default)

    Which is the correct codec label, but it is now listed as 16bit and 1536 kb/s (instead of 32bit, 3072 kb/s). Media Info also reported 16bit, but now the audio was signed (as it was supposed to be originally)

    I figure these results are a mistake (due to me messing around with the hex editor), as the file size didn't change. The Convergent Design CDProRes Transfer Tool now muxes the files, but the audio for the newly replaced section is just bursts of static. Image is fine, and audio for the rest is fine. So I am making progress. Thanks for the help.

    Still not sure how to make end up with lpcm and 32bit though...
    Quote Quote  
  9. I ended up messing around more with the hex editor and finally got the desired results. Thanks again for your suggestions, jagabo.
    Quote Quote  
  10. What was the problem? What else did you have to change?
    Quote Quote  
  11. Originally Posted by jagabo View Post
    What was the problem? What else did you have to change?
    Besides changing each in32 entry to lpcm, I also had to change a "10' to a '20' that appeared shortly after each in32 entry. This was trial and error of me copying and pasting chunks from the original file until I found something that worked.
    Quote Quote  



Similar Threads