VideoHelp Forum

+ Reply to Thread
Results 1 to 5 of 5
  1. Member
    Join Date
    Dec 2006
    United States
    Search Comp PM
    Hi yesterday i reformatted my laptop to reinstall linux mint 19.2. Everything installs fine so far expect mkvtoolnix. I cannot get it to install v38. The default its installing is v19. I know how to install it. It installs fine but if i try now to reinstall v19 or try to upgrade to v38. I get these errors. I looked all over on google so far no results on my issue. Does anyone know I can do to fix these errors?

    Depends: mkvtoolnix but it is not going to be installed
    Depends: libboost-filesystem1.67.0 but it is not installable
    Depends: libboost-regex1.67.0 (>=1.67.0-10) but it is not installable
    Depends: libboost-system1.67.0 but it is not installable
    Depends: libcmark0 but it is not installable
    Depends: libqt5core5a (>=5.12.2) but 5.9.5+dfsg-0ubuntu2.3 is to be installed
    Depends: libqt5gui5 (>=5.11.0~rc1) but 5.9.5+dfsg-0ubuntu2.3 is to be installed or
    libqt5gui5-gles (>=5.11.0~rc1) but it is not installable
    Depends: libqt5widgets5 (>=5.11.0~rc1) but 5.9.5+dfsg-0ubuntu2.3 is to be installed
    Quote Quote  
  2. Member
    Join Date
    Mar 2011
    Nova Scotia, Canada
    Search Comp PM
    Originally Posted by october262 View Post
    That's right, you should use the appimage version. The sort of error messages you got were because there's actually veru little backwards compatibility in Linux. If you did install the dependencies suggested somehow there'sd an excellent chance that would break something else. This is why so many new Linux programs are being issued as appimages or snaps. You'll have to use chmod to make the appimage executable.
    Quote Quote  
  3. Member
    Join Date
    Mar 2008
    Search Comp PM
    Well i have mkvtoolnix v38 installed on linuxmint 19.2 and works fine.

    Uninstall the linuxmint repo version first
    Just do what here is written by the author of mkvtoolnix:

    18.04 "Bionic Beaver", 19.04 "Disco Dingo", 19.10 "Eoan Ermire"

    I provide i386 and amd64 binaries for MKVToolNix.

    I do not provide binaries for libEBML and libMatroska anymore as they're already part of the official distribution. If those are too old MKVToolNix even bundles the current version of both libraries.

    You first have to import my public GPG key because all of my pools are signed. Run this once: wget -q -O - | sudo apt-key add -

    You can access the packages by adding the appropriate lines below to a file such as /etc/apt/sources.list.d/
    Version APT source
    19.10 "Eoan Ermire" deb eoan main
    deb-src eoan main
    19.04 "Disco Dingo" deb disco main
    deb-src disco main
    18.04 "Bionic Beaver" deb bionic main
    deb-src bionic main

    Now simply run sudo apt update followed by sudo apt install mkvtoolnix mkvtoolnix-gui.

    If updating the package lists fails, make sure you have the package apt-transport-https installed.

    Ubuntu 16.04 "Xenial": you can still get versions up to v38.0.0 from my repositories.
    Version APT source
    16.04 "Xenial Xerus" deb xenial main
    deb-src xenial main

    If you're looking for older Ubuntu or MKVToolNix releases, you can look through the repository directory yourself.
    Quote Quote  
  4. mariuszfert
    Check that all dependent packages are available in different versions
    Quote Quote