VideoHelp Forum


Try DVDFab Video Downloader and rip Netflix video! Or Try DVDFab and copy Blu-rays! or rip iTunes movies!
+ Reply to Thread
Results 1 to 7 of 7
Thread
  1. Hi Friends
    I have got few .ASF DVR footage files from local law enforcement agency. Files are not playing and could be corrupt I am not sure about them.
    Is there any way to repair / convert them.

    Here is some more details of the same -

    Filename: HCVR_ch13_main_20161016101500_20161016110000.asf
    DOS Name: HCVR_C~1.ASF
    Location: E:\USB Drive\test
    Size: 744626679 bytes
    Date: Created: 10/17/2019 08:11:00PM
    Extensions: .WMV .WMA .ASF .ASR .DVR-MS
    MIME: video/x-ms-asf
    video/x-ms-asf-plugin
    video/x-ms-wm
    application/vnd.ms-asf
    audio/x-asf
    Platforms: MS Windows
    Storage: Binary, Bitmap/Raster, Digital Audio, Compressed
    Content: Video, Graphic Image, Personal/User Data, Sound/Audio
    Best Accuracy: HIGH
    Notes: This file contains highly compressed Audio and/or
    Video. The file extension WMV is used for Audio/Video
    files, and the WMA extension is used for Audio-only
    files.
    TECHNICAL DETAILS
    ASCII Header: 0&uf..blG..........
    Hex. Header: 30 26 B2 75 8E 66 CF 11 A6 D9 00 AA 00 62 CE 6C
    47 01 00 00 00 00 00 00 03 00 00 00 01 02 A1 DC


    I can share with anyone for further analysis.
    Thank you
    Regards
    sang
    Quote Quote  
  2. DECEASED
    Join Date
    Jun 2009
    Location
    Heaven
    Search Comp PM
    1) An actual MediaInfo report would be better.

    2) So you mean that not even Windows Media Player can play those files?

    3) DVR-MS is an asf that contains MPEG-2 video plus MPEG-1 or AC-3 audio multiplexed in non-standard ways Which can become even worse when the application was written by incompetent programmers...

    4) If possible you should store (temporarily) the problematic files in a file-sharing site, so that other members can examine them.
    "Like this facility, I don't exist."
    Quote Quote  
  3. hi videobruger & EL Heggunte Good morning.
    Thanks a lot for your valuable help.
    I have run mediainfo as suggested by you ,we have got report of the same. Video contains some crime scene , when police submitted it in court ,it refused to play.dont know whether it is tampered or exact reason for the same.
    I have also uploaded it so that experts like you can check what is the issue.
    here is download link -
    https://drive.google.com/file/d/1iWpc0PNX8eaWzSHPJK_0ZxsUY5_qaxw1/view?usp=sharing

    Thank you
    Image Attached Files
    Last edited by chipsang; 17th Oct 2019 at 23:23.
    Quote Quote  
  4. Originally Posted by videobruger View Post
    Maybe AsfTools -> Repair
    hi I tried this tool but its converting video file in 5kb output file ,somehow its not working.
    thanks
    Quote Quote  
  5. DECEASED
    Join Date
    Jun 2009
    Location
    Heaven
    Search Comp PM
    Humm, those ASFs contain H.264 video

    But that's not the actual problem, the actual problem is they are broken by design

    Even Windows Media Player 12 cannot handle them.

    For 2 of those 4 files, MPlayer shows only the first frame (OR one of the first frames).
    libavformat cannot demux them, so both mpv and MPC-HC will not play them.

    So you'd better ask the INCOMPETENT law enforcement agency to convert those files to a watchable format...

    FWIW, below is what MPlayer reported while trying to play the pesky """videos""":

    Code:
    [D:\TESTS\USB Drive\data0\MMC2]
    => mplayer HCVR_ch2_main_20161016105000_20161016110002.asf
    MPlayer SVN-r38150-9.1.0 (C) 2000-2019 MPlayer Team
    224 audio & 453 video codecs
    
    Playing HCVR_ch2_main_20161016105000_20161016110002.asf.
    Cache fill:  0.00% (0 bytes)
    
    libavformat version 58.28.102 (internal)
    ASF file format detected.
    [asfheader] Video stream found, -vid 2
    VIDEO:  [H264]  1280x720  24bpp  1000.000 fps    0.0 kbps ( 0.0 kbyte/s)
    ==========================================================================
    Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
    libavcodec version 58.53.101 (internal)
    Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
    ==========================================================================
    Load subtitles in ./
    Audio: no sound
    Starting playback...
    [h264 @ 0000000001aed500]No start code is found.
    [h264 @ 0000000001aed500]Error splitting the input into NAL units.
    [h264 @ 0000000001aed500]left block unavailable for requested intra mode
    [h264 @ 0000000001aed500]error while decoding MB 0 32, bytestream 200
    
    I[nhv2a6l4i d@  f0r0a0m0e0 0d0u0r0a1taieodn5 0v0a]lcuoen c(e6a7l5i2n8g4 .1507819/ 0D.C0,8 01 0=8
    >9  -A6C7,5 218048.94 9M1V) .e rDreofrasu litni nIg  ftroa m4e1
    95.328 sec.
    [h264 @ 0000000001aed500]No start code is found.
    [h264 @ 0000000001aed500]Error splitting the input into NAL units.
    [h264 @ 0000000001aed500]No start code is found.
    [h264 @ 0000000001aed500]Error splitting the input into NAL units.
    Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
    VO: [direct3d] 1280x720 => 1280x720 Planar YV12
    
    Invalid frame duration value (2013265.946/66.248 => -2013199.698). Defaulting to 2013265.875 sec
    .
    [h264 @ 0000000001aed500]No start code is found.
    [h264 @ 0000000001aed500]Error splitting the input into NAL units.
    Error while decoding frame!
    
    Invalid frame duration value (66.248/0.240 => -66.008). Defaulting to 2013265.875 sec.
    [h264 @ 0000000001aed500]No start code is found.
    [h264 @ 0000000001aed500]Error splitting the input into NAL units.
    Error while decoding frame!
    [h264 @ 0000000001aed500]No start code is found.
    [h264 @ 0000000001aed500]Error splitting the input into NAL units.
    Error while decoding frame!
    
    Invalid frame duration value (33554.712/0.320 => -33554.392). Defaulting to 33554.473 sec.
    [h264 @ 0000000001aed500]No start code is found.
    [h264 @ 0000000001aed500]Error splitting the input into NAL units.
    Error while decoding frame!
    [h264 @ 0000000001aed500]Invalid NAL unit 7, skipping.
    [h264 @ 0000000001aed500]no frame!
    Error while decoding frame!
    Error while decoding frame!
    [h264 @ 0000000001aed500]top block unavailable for requested intra mode
    [h264 @ 0000000001aed500][h264 @ 0000000001aed500]No start code is found.
    error while decoding MB 54 0, bytestream 2012
    [[hh226644  @@  00000000000000000011aaeedd550000]]Ecrornocre aslpilnigt t3i5n9g5  tDhCe,  i3n5p9
    u5t  AiCn,t o3 5N9A5L  MuVn ietrsr.o
    rEsr rionr  Pw hfirlaem ed
    ecoding frame!
    
    Invalid frame duration value (17.024/0.720 => -16.304). Defaulting to 16.584 sec.
    Error [whh2i6l4e  @d e0c0o0d0i0n0g0 0f0r1aameed!5
    00[]hc2o6n4c e@a l0i0n0g0 030302020 1DaCe,d 530302]2t oApC ,b l3o3c2k2  uMnVa vearirloarbsl ei n
    f oPr  frreaqmuee
    sted intra mode
    [h264 @ 0000000001aed500]error while decoding MB 1 0, bytestream 3040
    [h264 @ 0000000001aed500]concealing 3600 DC, 3600 AC, 3600 MV errors in P frame
    
    Exiting... (Quit)
    
    [D:\TESTS\USB Drive\data0\MMC2]
    => mplayer HCVR_ch2_main_20161016110002_20161016111501.asf
    MPlayer SVN-r38150-9.1.0 (C) 2000-2019 MPlayer Team
    224 audio & 453 video codecs
    
    Playing HCVR_ch2_main_20161016110002_20161016111501.asf.
    Cache fill:  0.00% (0 bytes)
    
    libavformat version 58.28.102 (internal)
    libavformat file format detected.
    LAVF_header: av_open_input_stream() failed
    
    
    Exiting... (End of file)
    
    
    [D:\TESTS\USB Drive\data0\MMC1]
    => mplayer HCVR_ch13_main_20161016101500_20161016110000.asf
    MPlayer SVN-r38150-9.1.0 (C) 2000-2019 MPlayer Team
    224 audio & 453 video codecs
    
    Playing HCVR_ch13_main_20161016101500_20161016110000.asf.
    Cache fill:  0.00% (0 bytes)
    
    libavformat version 58.28.102 (internal)
    ASF file format detected.
    [asfheader] Video stream found, -vid 2
    VIDEO:  [H264]  1280x720  24bpp  1000.000 fps    0.0 kbps ( 0.0 kbyte/s)
    ==========================================================================
    Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
    libavcodec version 58.53.101 (internal)
    Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
    ==========================================================================
    Load subtitles in ./
    Audio: no sound
    Starting playback...
    
    Invali[dh 2f6r4a m@e  0d0u0r0a0t0i0o0n0 2vaa5ldu5e0 0(]1c.o1n4c4e/a0l.i4n2g4  3=5>5 8- 0D.C7,2 0
    3)5.5 8D eAfCa,u l3t5i5n8g  MtVo  e1r.r0o6r4s  sienc .P
     fra[mhe2
    6[4h 2@6 40 0@0 00000000000020a050d25a050d]5I0n0v]acloindc eNaAlLi nugn i1t3 20 ,D Cs,k i1p3p2i
    nAgC.,
     [1h3226 4M V@  e0r0r0o0r0s0 0i0n0 2Ia 5fdr5a0m0e]
    no frame!
    
    Invalid frame duration value (0.424/0.200 => -0.224). Defaulting to 1.064 sec.
    Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
    [h264 @ 0000000002a5d500]concealing 3562 DC, 3562 AC, 3562 MV errors in P frame
    VO: [direct3d] 1280x720 => 1280x720 Planar YV12
    
    Invalid frame duration value (0.200/0.000 => -0.200). Defaulting to 1.064 sec.
    [h264 @ 0000000002a5d500]left block unavailable for requested intra4x4 mode -1
    [h264 @ 0000000002a5d500]error while decoding MB 0 2, bytestream 4476
    [h264 @ 0000000002a5d500]concealing 3489 DC, 3489 AC, 3489 MV errors in P frame
    [h264 @ 0000000002a5d500]No start code is found.
    [h264 @ 0000000002a5d500]Error splitting the input into NAL units.
    Error while decoding frame!
    
    Invalid frame duration value (1275330.661/0.600 => -1275330.061). Defaulting to 1275330.625 sec.
    
    [h264 @ 0000000002a5d500]No start code is found.
    [h264 @ 0000000002a5d500]Error splitting the input into NAL units.
    [h264 @ 0000000002a5d500]No start code is found.
    [h264 @ 0000000002a5d500]Error splitting the input into NAL units.
    
    Exiting... (Quit)
    
    
    [D:\TESTS\USB Drive\data0\MMC1]
    => mplayer HCVR_ch13_main_20161016110001_20161016113001.asf
    MPlayer SVN-r38150-9.1.0 (C) 2000-2019 MPlayer Team
    224 audio & 453 video codecs
    
    Playing HCVR_ch13_main_20161016110001_20161016113001.asf.
    Cache fill:  0.00% (0 bytes)
    
    libavformat version 58.28.102 (internal)
    
    
    Exiting... (End of file)
    
    [D:\TESTS\USB Drive\data0\MMC1]
    =>
    "Like this facility, I don't exist."
    Quote Quote  
  6. Hi El Heggunte
    You are great , appreciate your technical expertise.
    Actually these peoples are dumb and they know nothing about file format. Dont know how files are broken ,may be tampered intentionally.
    I think cant do anything now.
    Thanks a lot for all the efforts.
    Quote Quote  



Similar Threads