VideoHelp Forum

+ Reply to Thread
Results 1 to 3 of 3
  1. Lately I have been having trouble using DVDFab HD Decrypter to rip my Blu-rays.

    I recently used it to rip the "Main Movie" and "Convert to Blu-ray SBS 3D" and it worked perfectly. It only took a matter of minutes to perform the task and I simply put the resulting M2TS file on a flash drive and could watch on my LG 3D TV with no loss in quality.

    Now when I try to rip any Blu-ray (2D or 3D), even those that worked perfectly before, DVDFab HD Decrypter stops ripping at 12%

    I sent DVDFab an email but they haven't responded.

    Has this happened to anyone else and, if so, how did you fix it?

    Quote Quote  
  2. Member
    Join Date
    Feb 2006
    United States
    Search Comp PM
    first, try checking you graphics card for a driver update and
    retry DVDFab HD Decrypter again.

    the free version may not have access to advanced features -
    Quote Quote  
  3. Try MakeMKV instead.
    Last edited by stonesfan99; 24th Apr 2020 at 09:09.
    Quote Quote  

Similar Threads