When trying to play UHD content on my desktop (16 core) machine using Zoom Player, about half the files I tried to play showed corrupt pictures, blank screens, and other severe artifacts, along with plenty of player crashes.
A similar software setup, but running on a HTPC (quadcore) in the living room works perfectly.

After a lot of messing around I discovered that setting "Threads for Multi-Threading" in LAV Video Decoder Properties to a value other than "Auto" makes the problem go away. 4 threads are not enough. 8 threads seem to be enough for the highest bitrate file I have (62181kbps). Setting 16 threads gives good results, as does setting 24 threads. Setting 32 threads gives the same behavior as setting "Auto". It is likely that "Auto" is the same as "however many your CPU can run" - 32 on the Threadripper.

I guess that having too many video decoder threads running is causing a problem somewhere.
A workaround is to set a lower number of threads.