VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 3 of 3
Thread
  1. Ive tried on Sorenson Squeeze and regular x264 (converting for bluray), and no matter what preset (im just using default presets, like film, grain, etc) I ALWAYS get these lines, and especially on a scene like this that I have attached. Is this just how h264 is working? How can I get rid of this? I have also done this with other videos and you can notice slight hard horizontal lines sometimes. And nope, it has nothing to do with interlacing, this is all progressive material, no interlace flags set etc.

    Image
    [Attachment 50255 - Click to enlarge]
    Quote Quote  
  2. x264 has problems with scenes like this, it's a known issue for long time. It's a problem with high quantizer / low bitrate allocation to this type of scene

    Normally you could use zones, specifying a bitrate multiplier for those sections. But for BD, you options are limited, because zones might violate VBV restrictions (incompatible BD)


    You can try:
    1) higher bitrate - maybe not feasible in BD scenario , because of bitrate restrictions / fixed capacity

    2) AQ settings - mode 2 or 3, with higher AQ strength. But you "waste" bitrate overall (can't use zones safely), and possibly cause edge artifacts with higher AQ strengths . Pros/cons

    3) preprocessing - adding small amounts of grain or noise to those scenes selectively will "convince" x264 to use higher bitrates in those scenes. But this takes away more bitrate from others, especially in a bitrate restricted scenario, like BD . Pros/cons

    4) some combination of 1-3

    x264 does not have BD compliant segment encoding, but that would be "perfect" in this sceneario
    Quote Quote  
  3. Thanks, and I had to end up adjusting colors a bit and applying a grain video layer on top, as much as I could on the light as well and it turned out way better, but its still quite faint. I also upped my bitrate as well, thanks. Haven't noticed it does this till now.
    Quote Quote  



Similar Threads