VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Page 1 of 2
1 2 LastLast
Results 1 to 30 of 43
Thread
  1. Member
    Join Date
    Oct 2018
    Location
    Gillette Stadium, United States
    Search Comp PM
    I have my VHS captures rock solid in lossless huffyuv, then using Hybrid to run QTGMC, they always stutter when played back. They LOOK nice, but stutter. My final delivery is for internet or phone/tablet. What is the trick to making this work? I hope W10 isnít the issue.
    Last edited by Barrythecrab; 8th Sep 2019 at 14:06. Reason: More info.
    Quote Quote  
  2. Member
    Join Date
    Oct 2018
    Location
    Gillette Stadium, United States
    Search Comp PM
    To be clear, I am exporting from Hybrid as Huffyuv AVI and then using PowerDirector to fix color and export as MP4. The stutter is present in the deinterlaced AVI, so it is obvious in the MP4.
    Quote Quote  
  3. Use AssumeTFF() or AssumeBFF() to the correct field order assumption. The default assumption in AviSynth is BFF so you probably want the former.
    Quote Quote  
  4. Member
    Join Date
    Oct 2018
    Location
    Gillette Stadium, United States
    Search Comp PM
    I have done that. TFF, and medium or slow. I want to export as AVI so when I mess with it in PD I only have the one lossy render.
    Quote Quote  
  5. Did you put AssumeTFF() before QTGMC()? Post your whole script.
    Quote Quote  
  6. Member
    Join Date
    Oct 2018
    Location
    Gillette Stadium, United States
    Search Comp PM
    I cannot seem to find a way to see the script this is generating so I can share it with you.
    For the moment I am going to try Vaporsynth to see if it makes any difference.
    Quote Quote  
  7. Member
    Join Date
    Oct 2018
    Location
    Gillette Stadium, United States
    Search Comp PM
    May I ask ...how does one manipulate the order of filters in Hybrid?Oh, I see it, been browsing Hybrid forum, too. But that leaves the question of how to specify tff before Qtgmc, I just thought the two were intertwined and it dealt with that on itís own.
    Last edited by Barrythecrab; 8th Sep 2019 at 19:47.
    Quote Quote  
  8. I've never used Hybrid. Maybe the order of the filters is the order you add them?

    Interlaced frames contain two half pictures that are intended to be viewed separately and sequentially. QTGMC needs to know which of the two pictures is to be displayed first. So you must specify the field order before calling QTGMC. If the field order is wrong you get fast-jerky-flickery video. Instead of seeing the pictures in the correct order 0,1,2,3,4,5... you see each pair in the wrong order 1,0,3,2,5,4...

    Another possibility is that your player simply can't play 60p video smoothly.
    Quote Quote  
  9. Member
    Join Date
    Oct 2018
    Location
    Gillette Stadium, United States
    Search Comp PM
    Iím not bobbing Iím getting 29.97. Should I bob, Iíve got 40 tapes captured and now Iím just stuck in the mud.
    Capture in mpeg2 or mp4 is so easy but I want to use these lossless files for a better result. By the way Iím using WMP.
    Quote Quote  
  10. QTGMC bobs by default. Did you disable that?
    Quote Quote  
  11. Member
    Join Date
    Oct 2018
    Location
    Gillette Stadium, United States
    Search Comp PM
    InHybrid it has a checkbox for bob. Is that the preferred method? Double frame rate? Are there any negative aspects to that?
    Quote Quote  
  12. AviSynth's Bob() filter is the worst of the deinterlacing methods (though it has it's uses). If you really have interlaced video you want to use QTGMC() which normally doubles the frame rate -- 29.97 fps interlaced video becomes 59.94 fps progressive video. But as I told you before you have to assume the correct field order before QTGMC.
    Quote Quote  
  13. @Barrythecrab
    In Hybrid you can select the avisynth deinterlacer "QTGMC(Avisynth)". For bobbing you must also tick "Bob". This will preserve the full temporal resolution (59.94fps).
    The field order is set by the Order: 0 for BFF and 1 for TFF. Just read the Help which is enabled by CTRL+F10

    If you should prefer single rate deinterlacing (29.97fps) you have to untick "Bob" and Select Even or Odd depending on which field you want to keep. You would get half of the temporal resolution only which is less demanding for the playback device if this should be the cause for the stutter.
    Quote Quote  
  14. 1. You can see the Avisynth Script Hybrid uses (Filtering->Avisynth->Show current Avisynth script).
    2. Hybrid adds AssumeBFF/AssumeTFF based on the detected field order (this can by overwritten by setting 'QTGMC Avisynth->Order' or using 'Overwrite input scan type to' and sticking with order 0).

    Cu Selur
    users currently on my ignore list: deadrats, Stears555
    Quote Quote  
  15. Member
    Join Date
    Oct 2018
    Location
    Gillette Stadium, United States
    Search Comp PM
    It appears to me, I get the best results using the very slow preset and of course forcing the scan to interlaced TFF. Smooth, no stutter, and not using bob.
    This Hybrid, especially QTGMC, is a God-send. I have captured lossless many times, and prefer it, but the de-interlacing was always a problem. After using this the results are so much better I almost want to redo half the tapes I've captured in the last 10 years. Of course with 40 fights I am converting I will be busy waiting...
    Quote Quote  
  16. Member
    Join Date
    Oct 2004
    Location
    United States
    Search PM
    I had a VHS that I recently de-interlaced with QTGMC and it looked beautiful, all interlaced "jaggies" were gone...but when panning sideways it stuttered real bad...this is usually indicative of the field order being wrong. So I changed the order in QTGMC from BFF to TFF..figuring this would fix the problem. NOPE..it looked way worse...interlace city...

    So I went back to BFF for the field order in QTGMC and then added SelectEven() to my script right under the QTGMC line...smooth and no jaggies....and put it back to the original framerate...

    Was that the right answer? I don't know...but after hours of messing with scripts and bad encodes you stop caring and want it to just work....
    Quote Quote  
  17. Originally Posted by greymalkin View Post
    So I went back to BFF for the field order in QTGMC and then added SelectEven()...

    Was that the right answer?
    Almost certainly not. But we'd have to see your source to say what it really needed.
    Quote Quote  
  18. Member
    Join Date
    Oct 2004
    Location
    United States
    Search PM
    I was mainly just being funny. Iíll start my own thread when I really start to foul things up
    Quote Quote  
  19. Yes, sometimes a video is just too messed up to fix "properly" and you have to use a compromise.
    Quote Quote  
  20. Member
    Join Date
    Oct 2018
    Location
    Gillette Stadium, United States
    Search Comp PM
    Nah, oh well, most every video looks fabulous but manages to stutter every few seconds, no matter the player, or the QTGMC setting. Damn shame, I know it's me or my Windows 10, or something here because nobody else is bitching. It's the perfect solution for my woes, I've always wanted to capture lossless and be able to maximize the use of those huge files but it's not to be. Maybe later I'll try to attach a section that is stuttering, would that be of any interest to anyone?
    https://www.dropbox.com/s/l7m2bzu5jloume0/Perez%20Civic%20Center-DLCsample.avi?dl=0
    Last edited by Barrythecrab; 15th Sep 2019 at 16:47. Reason: added Dropbox file
    Quote Quote  
  21. That's your capture? Untouched? It's progressive so no need at all for QTGMC. And QTGMC isn't responsible for the stuttering. Your sample is full of missing frames and duplicate frames. That's why it stutters. Your source already stutters. Something went terribly wrong somewhere; maybe the broadcast, maybe the taping, maybe your capture.

    If I had to guess, I'd say the capture is responsible. Can you provide details of your capture process?
    Quote Quote  
  22. That video is already progressive at 23.976 fps. It has both missing and duplicate frames. It looks to me like somebody captured 29.97i video poorly resulting in duplicate and missing frames then deinterlaced it, probably with QTGMC(fpsdivisor=2). To make it play smoothly you'll need to remove the duplicates and insert motion interpolated frames to replace the missing frames. I did it manualy for the first 100 frames with a script like:

    Code:
    AviSource("Perez Civic Center-DLCsample.avi") 
    ConvertToYV12()
    Crop(8,0,-8,-0)
    Trim(0,100)
    
    # remove duplicates
    DeleteFrame(98)
    DeleteFrame(77)
    DeleteFrame(67)
    DeleteFrame(46)
    DeleteFrame(35)
    DeleteFrame(14)
    DeleteFrame(3)
    
    # insert motion interpolated frames
    InsertFramesMC(92)
    InsertFramesMC(78)
    InsertFramesMC(63)
    InsertFramesMC(48)
    InsertFramesMC(36)
    InsertFramesMC(14)
    InsertFramesMC(8)
    That gave the result in the attached video (original on left, smoother on right). Obviously, this would be a pain to do for a full length video.
    Image Attached Files
    Quote Quote  
  23. Member
    Join Date
    Oct 2018
    Location
    Gillette Stadium, United States
    Search Comp PM
    Capture is JVC7800u>Datavideo TBC1000>VC500 using VirtualDub.
    Sometimes I use my ES15 if itís warranted.
    The capture is smooth like butter, itís only when I deinterlace that I get stutter.
    The frame rate in is the same as out, according to Hybrid.
    The sample is direct stream copy from a video subjected to QTGMC.
    EDIT: just uploaded the actual direct stream copy, longer, to see if it's a good capture. I'm just wondering about the frames, I'm sure there are other issues but I need to start at the deinterlacing. Oh, and thank you all for your assistance, most of you have forgotten more about video than I'll ever know.
    Image Attached Files
    Last edited by Barrythecrab; 15th Sep 2019 at 20:51.
    Quote Quote  
  24. What you uploaded earlier was the one you had already reencoded? Why would anyone possibly want to see that? Also, QTGMC bobs, but that sample was at the original framerate, 29.97fps. You should have provided a video sample from the source at the very beginning.

    Okay, the capture is good. You screwed up the encode. The field order is messed up and when you used QTGMC as a single-rate deinterlacer, that's where all the missing and duplicate frames came from - the combination of the two. Set the field order as TFF and use QTGMC as a bobber. Or, at least get the field order correct.

    AssumeTFF()
    QTGMC()


    With cropping and resizing to 640x480 you get this:
    Image Attached Files
    Quote Quote  
  25. Member
    Join Date
    Oct 2018
    Location
    Gillette Stadium, United States
    Search Comp PM
    I did not just go blindly into the fire, I been reading, too. I want to try things before I am a bother.
    Hybrid was set as fast, faster, slow, medium, always TFF, no Bob. I did try Bob but I got double the/frame rate and stutter in a larger file.
    Should I only use QTGMC alone? I have mostly been using it with denoiser to save time, I have 39 tapes. For what its worth I force deinterlace first.
    Quote Quote  
  26. A agree with manono: the interlaced video in post #23 has nice smooth motion. You screwed it up in your processing (post #20). The video in manono's reply is how the video is supposed to look. The proper handling for the video should be:

    Code:
    AviSource("Perez-DS_copy.avi") 
    AssumeTFF()
    QTGMC()
    If Hybrid can't deal with that properly you should use something else.
    Quote Quote  
  27. Member
    Join Date
    Oct 2018
    Location
    Gillette Stadium, United States
    Search Comp PM
    I suspect operator error, but Staxrip also has QTGMC so Iíll have a good look at that.
    Quote Quote  
  28. @Barrythecrab
    For your .avi source the jerkiness is a matter of the source filter rather than QTGMC or anything else.
    In Hybrid select via the menu 'Filtering' -> 'Avisynth' -> 'Misc' and there tick 'LibavVideoSource instead of FFmpegSource'. This should decode your interlaced .avi source correctly.
    The setting for QTGMC double-rate bobbing is as discussed before: via Menu 'Filtering'->'(De-)interlace/Telecine' and tick 'Force', select Deinterlacer: 'QTGMC (Avisynth)' and tick 'bob' and select Order:1 (for TFF).
    This should produce a smooth clip of 59.94 progressive video.
    Quote Quote  
  29. Member
    Join Date
    Oct 2018
    Location
    Gillette Stadium, United States
    Search Comp PM
    Sharc!
    Sharc!
    My initial viewings show your solution to be...EXACTLY correct. I've done 2 videos and am now fully in jaw-drop mode.
    How you might know the cause/effect/solution? All you guys (and gals?) got to understand I am a mostly blue-collar man, concrete,steel, dirt, mud, etc and although I do this for a stipend I also do this because of the wonder of turning old icky tape into an image on a monitor and a memory for the owner. Is that too corny? Screw it, it's true.
    Quote Quote  
  30. Originally Posted by Barrythecrab View Post
    How you might know the cause/effect/solution?
    I remembered from the past that some source filters/decoders have issues with certain interlaced .avi formats (like yours). The logical step was to check whether Hybrid can change its default source filter/decoder. Apparently the author of Hybrid included this option, and luckily LWLibavVideoSource decoded your interlaced .avi correctly.
    Good luck with your projects!
    Quote Quote  



Similar Threads