VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Results 1 to 25 of 25
Thread

Threaded View

  1. Hello.

    I have a question, and forgive me for being kind of a newbie. I play a lot of mkv files with my blu-ray player (SONY BDP-S1500) on my Samsung UE32J5500 TV. The player is set on an 1080p output and so the tv gives a resolution of 1080/60p, and the quality is great.
    But now I have several new mkv files (29.97 fps) that seem to be interlaced, I think that's the term, they have that combing effect. So I set my player on "auto" but it plays those files just like the others (60p), no deinterlacing. I'm forced to switch the player to a 1080i setting, for the files to play correctly.

    The issue is that all my other files play at 60i as well now. Is there a way for the player to detect the files that need to be played at 60p or 60i? And will the video quality be inferior for my "regular" mkv files played in 1080/60i?

    Thanks in advance for helping me understand this a little better.
    Last edited by Nico Darko; 7th Sep 2019 at 15:11.
    Quote Quote  
  2. Verify that your files are properly flagged as 30i. MediaInfo can tell you that. If not, the player will not know the video is interlaced and will not deinterlace. If the video is flagged as interlaced your player should be deinterlacing from 30i to 60p (when set for 60p output). If not, maybe you can remux the video to a different container (try mp4) -- maybe your player will work better with that.
    Quote Quote  
  3. Thanks, but I can't find the information with MediaInfo Although I assume the video isn't flagged as interlaced.
    And I checked, there is that combing effect when I play it with media player classic, but not VLC.


    Image
    [Attachment 50039 - Click to enlarge]
    Quote Quote  
  4. If the video was flagged as interlaced it would show up in the Video section:

    Code:
    Chroma subsampling                       : 4:2:0
    Bit depth                                : 8 bits
    Scan type                                : Interlaced
    Scan order                               : Top Field First
    If your player has a setting to force deinterlacing you should try using that. I'm not sure if there's any tool that will let you flag the video without reencoding.

    You might try remuxing to an mpeg 2 program stream. You will probably have to demux the video and audio tracks from the MKV file, then mux the resulting streams into a .MPG file.

    To answer your other question, yes, setting your BD player to 1080i output will cause a little degradation when playing 720p and 1080p videos. Colors will blur a little and you'll probably see some aliasing of sharp, near horizontal edges.
    Quote Quote  
  5. Wait, maybe 29.97fps means that it is flagged as 30i?

    EDIT: Ok, thank you.
    I'll see what can be done then.
    Quote Quote  
  6. Originally Posted by Nico Darko View Post
    Wait, maybe 29.97fps means that it is flagged as 30i?
    No, 29.97 fps can be either interlaced or progressive.
    Quote Quote  
  7. Member
    Join Date
    Aug 2008
    Location
    Canada
    Search Comp PM
    You could try opening one of the interlaced files in the MKVToolNix-GUI Header Editor. In it, you can set the Video Interlaced Flag, and then see if your player recognizes it correctly.
    Quote Quote  
  8. Originally Posted by Gramps View Post
    You could try opening one of the interlaced files in the MKVToolNix-GUI Header Editor. In it, you can set the Video Interlaced Flag, and then see if your player recognizes it correctly.
    Ok, I'm in the header editor, how do I set the flag?
    Quote Quote  
  9. Open your mkv file. Expand the Video Track section. Highlight Video Field Order. Add Element if necessary. Set value to 1, 2, 6, 9, or 14. I couldn't find docs for the header editor but you can see what changes are made in MediaInfo. Save. Try playing the file on TV.
    Quote Quote  
  10. Ok, the flag was added, mediainfo now says:

    Scan type : Interlaced
    Scan type, store method : Separated fields (2 fields per block)
    Scan order : Top Field First

    But the blu-ray player still won't deinterlace, I tried the 1080p and "auto" setting
    Quote Quote  
  11. I didn't expect a Blu-ray player, especially from Sony, to pay any attention to MKV flags. But you might as well try the other values too.
    Quote Quote  
  12. Ok, I think maybe I misjudged the issue There is a slight combing effect, but I think it's an issue with the source. The main issue is that a frame often blends into the next one, and I assumed it was an interlacing issue, but maybe it's not? And I thought setting my player to 1080/i fixed it, but it didn't.

    Image
    [Attachment 50042 - Click to enlarge]



    The blending frames is not an issue when I play the files directly on my tv though, or with VLC, why won't it play properly on my player then?
    (And I would use my tv but the playback isn't great with larger files.)
    Quote Quote  
  13. Upload a small sample of your source. A sample that includes problematic frames, about 10 seconds long. Don't reencode.
    Quote Quote  
  14. How do I do that without reencoding?
    Quote Quote  
  15. AviDemux might be able to cut a short clip. Open the source file, use the mark-in and mark-out tools on keyframes (use the double arrow tools to seek to the next/previous keyframe) to mark a section. Set both video and audio to Copy. Save.
    Quote Quote  
  16. You have MPEG 2 video with a mix of soft and hard pulldown (DgIndex reports 95 percent soft telecine, 5 percent hard telecine). My guess is your BD player just can't handle that properly in an MKV container. I would try remuxing to an MPEG program stream, ie an MPG file. Attached is a sample MPG file for you to test.

    You might still see some combing at times because TVs sometimes take a few frames to adapt to changes between hard and soft pulldown. The video also has a problem where the chroma is messed up at shot changes. So even if your player plays the video with proper deinterlacing there will still be some chroma artifacts (1 or 2 fields/frames) at those shot changes.
    Image Attached Files
    Quote Quote  
  17. Thanks! I just tried it, but it plays it the same way :/
    Quote Quote  
  18. Do you see the comb artifacts whenever there is motion? Or just at shot changes?
    Quote Quote  
  19. Only at shot changes.
    Quote Quote  
  20. I don't know how far you want to go with this. You could mostly clean it up and reencode. A sample is attached. There is still some chroma artifacting at some shot changes. It's possible to detect scene changes and replace the chroma with the chroma from the next frame. But that may look worse depending on how much motion right after the shot change. A simple inverse telecine sample is attached.
    Image Attached Files
    Quote Quote  
  21. Yeah, I think I'll just play the files directly on my tv, it's not very user friendly, I prefer my blu-ray player, but it doesn't have those video issues.
    Thanks a lot for your help!
    Quote Quote  
  22. Just for fun I played around with detecting the problematic frames after an inverse telecine. Here's the result with just IVTC on the left, and IVTC plus detection of chroma combing and fixed on the right. The frames that were fixed are stamped with "NextChroma" for easy identification.
    Image Attached Files
    Quote Quote  
  23. Nice work! I don't want to reencode the files, but good to know there is a fix
    Quote Quote  
  24. It worked well here but the fix isn't perfect. When it detects residual combing in the chroma channels it replaces the chroma with a copy of the chroma in the next frame. if there is a lot of motion that chroma won't line up with the luma -- the fix could be worse than the error! Also, in this clip it was always the first frame of a new shot that had the bad chroma. So replacing it with the chroma of the next frame worked well. But if there are other places in the video where the last frame of the previous shot had the chroma problem it would replace the chroma with that of a completely unrelated shot. One could probably work out a way to detect that and handle it properly (copy the chroma from the previous frame rather than the next frame).

    This probably won't mean anything to you but here's the AviSynth I used to do this. Somebody else might find it useful some day.

    Code:
    Mpeg2Source("01x01-02 {NTSC} {DVD}.d2v", CPU2="ooooxx", Info=3) # open source video
    TFM(d2v="D:\Downloads\01x01-02 {NTSC} {DVD}.d2v") # match fields to make progressive frames
    TDecimate() # eliminate the extra frame from the telecine
    
    # make a clip with the chroma of each frame replaced with the chroma of the next frame
    NextChroma = MergeChroma(Trim(1,0)).Subtitle("NextChroma") # subtitle just for debugging
    
    # make a clip of just the chroma of each frame, for testing for combing
    TestClip = StackHorizontal(UtoY(), VtoY())
    
    # only when combing is detected in the test clip the frame's chroma is replaced with the chroma of the next frame
    ConditionalFilter(TestClip, NextChroma, last, "IsCombedTIVTC")
    The first three lines are what I used to make the video in post #21.
    Quote Quote  



Similar Threads