VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Results 1 to 2 of 2
Thread
  1. Member
    Join Date
    Sep 2019
    Location
    India
    Search Comp PM
    Details of Nache1080.mp4:-
    resolution=1920x1080
    fps=60
    Avg Video Bit Rate=11610 kbps
    duration=00:00:14
    size=19.6 MB

    I produced mpeg2 video from this mp4 video using below command:
    ffmpeg -i Nache1080.mp4 -c:v mpeg2video -s 720x576 -r 25 -b:v 20000k Nache_dvd_20000.mpg

    Details of produced mpeg2 video namely Nache_dvd_20000.mpg:-
    min Video Bit Rate=3298 kbps
    max Video Bit Rate=5954 kbps
    avg Video Bit Rate=4675 kbps
    size=8.533 mb

    The max video bit rate for DVD-Video is 9.8 MB. The max video bit rate of produced mpeg2 video is 5954 kbps. But I specified 20000k as input for video bit rate which is greater than 9.8 MB.

    1. Will DVD-player be able to play this video? What problems -b:v 20000k will create for DVD-Player?

    2. Will PAL-TV be able to display this video? What problems -b:v 20000k will create for PAL-TV?

    The above command produced below warning on FFMPEG console:
    [mpeg @ 0000000000604c80] VBV buffer size not set, using default size of 230KB If you want the mpeg file to be compliant to some specification Like DVD, VCD or others, make sure you set the correct buffer size

    3. Will this warning cause any problems for DVD-Player and/or PAL-TV?

    If I add -target pal-dvd to remove the warning FFMPEG generates below error and produces a mpeg2(or output) video having 0 bytes:

    F:ffmpeg-4.2-win64-static\bin>ffmpeg -i Nache1080.mp4 -c:v mpeg2video -s 720x576 -r 25 -b:v 20000k -target pal-dvd Nache_dvd_20000.mpg

    ffmpeg version 4.2 Copyright (c) 2000-2019 the FFmpeg developers
    built with gcc 9.1.1 (GCC) 20190807
    configuration: --enable-gpl --enable-version3 --enable-sdl2 --enable-fontconfig --enable-gnutls --enable-iconv --enable-libass --enable-libdav1d --enable-libbluray --enable-libfreetype - -enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-libshine --enable-libsnappy --enable-libsoxr --enable-libtheora --en able-libtwolame --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxml2 --enable-libzimg --enable-lzma --enable-zlib --enable-gmp --enable-l ibvidstab --enable-libvorbis --enable-libvo-amrwbenc --enable-libmysofa --enable-libspeex --enable-libxvid --enable-libaom --enable-libmfx --enable-amf --enable-ffnvcodec --enable-cuvid -- enable-d3d11va --enable-nvenc --enable-nvdec --enable-dxva2 --enable-avisynth --enable-libopenmpt
    libavutil 56. 31.100 / 56. 31.100
    libavcodec 58. 54.100 / 58. 54.100
    libavformat 58. 29.100 / 58. 29.100
    libavdevice 58. 8.100 / 58. 8.100
    libavfilter 7. 57.100 / 7. 57.100
    libswscale 5. 5.100 / 5. 5.100
    libswresample 3. 5.100 / 3. 5.100
    libpostproc 55. 5.100 / 55. 5.100
    Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'Nache1080.mp4':
    Metadata:
    major_brand : isom
    minor_version : 512
    compatible_brands: isomiso2avc1mp41
    encoder : Lavf57.56.100
    Duration: 00:00:14.03, start: 0.000000, bitrate: 11767 kb/s
    Stream #0:0(und): Video: h264 (High) (avc1 / 0x31637661), yuv420p, 1920x1080, 11623 kb/s, 60.07 fps, 60 tbr, 15360 tbn, 120 tbc (default)
    Metadata:
    handler_name : VideoHandler
    Stream #0:1(und): Audio: aac (LC) (mp4a / 0x6134706D), 44100 Hz, stereo, fltp, 171 kb/s (default)
    Metadata:
    handler_name : SoundHandler
    Stream mapping:
    Stream #0:0 -> #0:0 (h264 (native) -> mpeg2video (native))
    Stream #0:1 -> #0:1 (aac (native) -> ac3 (native))
    Press [q] to stop, [?] for help
    [mpeg2video @ 0000000002f500c0] bitrate above max bitrate Error initializing output stream 0:0 --
    Error while opening encoder for output stream

    0:0 - maybe incorrect parameters such as bit_rate, rate, width or height
    Conversion failed!
    Quote Quote  
  2. Member
    Join Date
    Mar 2008
    Location
    United States
    Search Comp PM
    If you want DVD compliant mpg or video_ts folder, use AVStoDVD instead
    Quote Quote  



Similar Threads