VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Results 1 to 18 of 18
  1. Hello!

    I've only tried yesterday to make a 2 pass encode to AVI by using the Job Control, but after the first pass it's stopped working.

    This is how I've done:

    Loaded the video set the 1st pass parameters and selected Job Control->Save as AVI
    Than selected the 2nd pass compression parameters and also selected Job Control->Sava as AVI (with the same filename as for 1st Pass)
    Then opened Job Control, there I've seen my two queued operation listed and clicked Start.
    But it did halt at the end of the first operation and didn't start the second one, and the progress bar has stuck at 6%. Even after I've tried to do something manually, the Start button was all grayed out.

    What am I missing to do this right?

    Quote Quote  
  2. Show VirtualDub log ("View"->"Log" or F8, right-click->"Copy to clipboard"). Show encoder settings of first and second path. Show MediaInfo ("View"->"Text") of input file. Show AviSynth script in case you use AviSynth.
    Quote Quote  
  3. I guess there's shouldn't be the matter of my settings as if I run the First and than the Second Pass manually and independently (without the Job Queue) it starts and finishes both Passes just right. The bug only appears if I try to do EXACTLY the same with the Job Queue. I tried it again and the progress of the first pass was very-very slow as seen:

    Only 0.25fps/s advance, while running manually I can get even 25-30fps/s. So there's something definitely messed up here with the Job Control.
    [Attachment 49952 - Click to enlarge]

    Here's the log after a few minutes of waiting and then aborting the first pass, but nothing useful:
    [*] Beginning dub operation.

    [i] Dub: Input (decompression) format is: YUV420.

    [i] Dub: Output (compression) format is: YUV420.
    [*] Ending operation.
    Quote Quote  
  4. MediaInfo of input file? What input driver? What version of VirtualDub?
    Quote Quote  
  5. Image
    [Attachment 49953 - Click to enlarge]

    Don't know exactly what you mean by input driver? I have the latest Xvid-1.3.5-20171208 Release installed. And Virtual Dub 1.10.4-AMD64 release (and it's the Portable version).
    Quote Quote  
  6. VirtualDub has different input options. From your screenshot it seems you are using the ffmpeg input plugin.
    I'm wondering what the problem could be:
    - bug in Xvid version? Test different encoder to exclude this possibility.
    - bug in audio decoding or encoding? Test with audio disabled.
    - (video) decoding problem? Try different input option. E.g. through AviSynth instead of VirtualDub ffmpeg plugin. (Bug in input plugin or broken input file.)
    From the given information it is hard to guess/debug.
    Quote Quote  
  7. Cranking Process Priority up to Even Higher will not reduce the time it takes to encode unless you have some other CPU hungry processes competing for CPU time. And high priorities can lead to problems as the user process competes for CPU time with the OS. User processes should almost never run at more than Normal priority. I usually run encoding at Idle priority. That runs just as fast as any higher priority if there is no other CPU hungry process running, and it leaves the computer usable for other things if needed (of course, the encoding will be slowed if you do so).
    Quote Quote  
  8. That's just one shot taken to show that it runs sluggishly slow even set on higher priority. It's the same happening on Normal or any other priority. I have done the manual -non queued- encodes on Normal and also on Even Higher priorities with success and without errors, so that must not be the cause.

    Edit: Will try later those as suggested, right now I stand to deal with manual control. And yes, I have the FFMpeg plugin (64bit version) placed in the VirtualDub folder. I've tried to avoid any unnecessary installation as possible, that's another reason, why I didn't have Avisynth installed.
    Last edited by Mounter81; 29th Aug 2019 at 22:08.
    Quote Quote  
  9. I wasn't suggesting the high priority was the likely the cause of your problem. Just that it's not a good idea to run user processes at high priority.

    What kind of CPU usage are you seeing when the slowdown happens vs. when it's running normally? How many threads is Xvid set to use? Are you using any slow filters in VirtualDub?
    Quote Quote  
  10. Member
    Join Date
    Mar 2008
    United States
    Search Comp PM
    Some suggestions. Try Virtualdub2. Secondly, for the first pass, setup the encoder, then
    queue batch operation/run video analysis pass
    Quote Quote  
  11. A wanted to try VirtualDub2, but the AC3 ACM encoder juts isn't working. It doesn't even set the parameters I've adjusted, so every time I reopen Audio->Compression it's back to the default "empty" stage.
    [Attachment 49970 - Click to enlarge]

    When I try to Save the Video it shows the following pop-up:

    [Attachment 49969 - Click to enlarge]

    These are my working settings with the "original" VirtualDub after having these codecs installed:

    [Attachment 49971 - Click to enlarge]
    Last edited by Mounter81; 30th Aug 2019 at 07:59.
    Quote Quote  
  12. Convert the audio to 16 bit PCM.
    Quote Quote  
  13. Originally Posted by jagabo View Post
    Convert the audio to 16 bit PCM.
    Why? My intention is to convert to AC3.
    Quote Quote  
  14. The AC3 encoder requires 16 bit PCM as input.
    Quote Quote  
  15. What you mean by that conversion method to run through? I don't need any other conversion in the original VirtualDub and the setting to convert to AC3 works straight for all audio streams. So why doesn't work in VD2? So how to done this properly, first convert and save a PCM stream in a different file?
    Quote Quote  
  16. The source filter in VirtualDub2 is decompressing the audio as floating point. The AC3 encoder needs 16 bit integers. Turn on Audio -> Full Processing Mode. Then use Audio -> Conversion to convert the audio to 16 bit integers. Then select the AC3 encoder for compression.
    Quote Quote  
  17. Originally Posted by jagabo View Post
    The source filter in VirtualDub2 is decompressing the audio as floating point. The AC3 encoder needs 16 bit integers. Turn on Audio -> Full Processing Mode. Then use Audio -> Conversion to convert the audio to 16 bit integers. Then select the AC3 encoder for compression.
    Thanks, that seems working now!

    Tho' I've just have tried to 2 pass convert a 1min part of a video, but also the Job Control seems working right in VD2!

    I only wonder about these missing setting in the AC3 Codec Configuration Settings that I have in the original VD, but not in VD2...?! Why are these missing?:
    [Attachment 49972 - Click to enlarge]
    Last edited by Mounter81; 30th Aug 2019 at 09:23.
    Quote Quote  

Similar Threads