VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Results 1 to 11 of 11
Thread
  1. Everything I say is false koberulz's Avatar
    Join Date
    Oct 2006
    Location
    Australia
    Search Comp PM
    I know how to split files, and how to add chapters, but what's the easiest way of finding the timecode I need to use to split at a certain point, or create a chapter at a certain point?
    Quote Quote  
  2. Maybe not what you want but if it's at chapter points start by using Chapter Database.

    Image
    [Attachment 49931 - Click to enlarge]
    Quote Quote  
  3. Everything I say is false koberulz's Avatar
    Join Date
    Oct 2006
    Location
    Australia
    Search Comp PM
    No, I want to insert my own chapters.

    Basically I have a series of sporting events with five to ten minutes of pregame coverage, but no chapter marker between the start of the broadcast and the start of the game. I want to insert one so I can skip ahead. It's not super important to be frame-perfect in this context but I'd like to have an option if I do need to be frame-perfect for anything down the line.
    Quote Quote  
  4. Everything I say is false koberulz's Avatar
    Join Date
    Oct 2006
    Location
    Australia
    Search Comp PM
    So it seems AVIDemux will do what I want. But I've got a stray commercial in one and MKVToolnix just refuses to cut at the right spot. I've set it to trim at 28:02.081, and yet it's cutting at 28:07.386.

    There's an I-frame at 28:02.114. I tried putting this into MKVToolnix the first time and when it cut at 28:07.386 I figured maybe it was looking for the first I-frame after the nominated point, so I picked the frame before the I-frame at which I wished to cut and it still cut to 28:07.386. Why is this happening? How do I get it to cut where I want it to cut?
    Quote Quote  
  5. I've seen ffmpeg have that problem. The solution was to specify 2 frames before the I frame.
    Quote Quote  
  6. Everything I say is false koberulz's Avatar
    Join Date
    Oct 2006
    Location
    Australia
    Search Comp PM
    Tried two frames before, still no dice.
    Quote Quote  
  7. You said it's an I frame but maybe mkvmerge does not think it's a keyframe. E.g. because it's not marked that way in your source container (either erroneously or correctly).
    Quote Quote  
  8. Everything I say is false koberulz's Avatar
    Join Date
    Oct 2006
    Location
    Australia
    Search Comp PM
    I'm not sure I follow.
    Quote Quote  
  9. An I frame is a frame that can be decoded without knowledge of any other frames. But that does not necessarily imply it's a good split point. E.g. the frames after the I frame might reference the frames before said I frame. For splitting files into multiple parts (where all parts are kept and playable) the I frames should be IDR frames. It's also possible that while your split point is an IDR frame it was not marked that way by the original muxer and now mkvmerge does not detect this.

    Also be aware when splitting files with subtitles using mkvmerge. Mkvmerge does not split at points where certain types of subtitles are active.
    Quote Quote  
  10. Everything I say is false koberulz's Avatar
    Join Date
    Oct 2006
    Location
    Australia
    Search Comp PM
    Setting it to cut at 28:02 exactly gets the cut at 28:02.114. Maybe it just doesn't like decimals?
    Quote Quote  



Similar Threads