VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 9 of 9
Thread
  1. I have a 720p m4v file that looks quite good and plays smoothly. However, seeking is sluggish and I cannot make frame accurate cuts using VideoReDo TVSuite V5. Normally I have no problem using VideoReDo with h.264 video. AviDemux gives similar issues. It will only cut a certain points which I assume are at GOP boundaries and from the look of things given the way those boundaries jump in AVIDemux the boundaries are far apart. As best I understand VideoReDo should be able to cut at any point by re-encoding frames up to the boundary and then copying without encoding the remainder. This appears to be happening but the resultant file will not play smoothly at all. Sometimes frames are skipped at the beginning or end of cuts.

    I don't know what it is about the encoding of this file that is giving this problem. I would like to re-encode this file so that cutting will be accurate. I would be grateful for any setting in either VideoReDo or AVIDemux to facilitate this.

    Thanks!
    Image Attached Thumbnails Click image for larger version

Name:	MediaArea.net_MediaInfo.jpg
Views:	29
Size:	100.5 KB
ID:	49846  

    Quote Quote  
  2. Unfortunately we cannot see all the the details in your screenshot. It's better to set MediaInfo to "View"->"Text" and copy&paste everything here. In the "Encoding settings" look if it shows "open_gop=1". Many softwares do not properly support OpenGOP. That might include the mp4(m4v) muxer you have been using. So demuxing and muxing again with a good muxer might fix issues. Maybe VideoReDo doesn't support this properly either (I do not know).
    Quote Quote  
  3. sneaker, Thanks for your assistance! I see open_gop=0 Is your recommendation the same (try remuxing)? Thanks!

    General
    Complete name : F:\RT.m4v
    Format : MPEG-4
    Format profile : Base Media / Version 2
    Codec ID : mp42 (isom/iso2/avc1/mp41)
    File size : 9.40 GiB
    Duration : 6 h 59 min
    Overall bit rate mode : Variable
    Overall bit rate : 3 203 kb/s
    Encoded date : UTC 2018-01-08 07:59:49
    Tagged date : UTC 2018-01-08 07:59:49
    Writing application : HandBrake 0.10.5 2016021100

    Video
    ID : 1
    Format : AVC
    Format/Info : Advanced Video Codec
    Format profile : High@L4
    Format settings, CABAC : Yes
    Format settings, ReFrames : 9 frames
    Codec ID : avc1
    Codec ID/Info : Advanced Video Coding
    Duration : 6 h 59 min
    Source duration : 6 h 59 min
    Bit rate : 3 071 kb/s
    Width : 1 280 pixels
    Height : 720 pixels
    Display aspect ratio : 16:9
    Frame rate mode : Constant
    Frame rate : 29.970 (30000/1001) FPS
    Color space : YUV
    Chroma subsampling : 4:2:0
    Bit depth : 8 bits
    Scan type : Progressive
    Bits/(Pixel*Frame) : 0.111
    Stream size : 9.01 GiB (96%)
    Source stream size : 9.01 GiB (96%)
    Writing library : x264 core 142 r2479 dd79a61
    Encoding settings : cabac=1 / ref=9 / deblock=1:-3:-3 / analyse=0x3:0x133 / me=umh / subme=9 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=24 / chroma_me=1 / trellis=2 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=0 / chroma_qp_offset=-2 / threads=6 / lookahead_threads=1 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=6 / b_pyramid=2 / b_adapt=2 / b_bias=0 / direct=3 / weightb=1 / open_gop=0 / weightp=2 / keyint=300 / keyint_min=30 / scenecut=40 / intra_refresh=0 / rc_lookahead=60 / rc=crf / mbtree=1 / crf=19.0 / qcomp=0.60 / qpmin=0 / qpmax=69 / qpstep=4 / ip_ratio=1.40 / aq=1:1.00
    Encoded date : UTC 2018-01-08 07:59:49
    Tagged date : UTC 2018-01-08 07:59:49
    Color range : Limited
    Color primaries : BT.709
    Transfer characteristics : BT.709
    Matrix coefficients : BT.709
    Menus : 3
    Quote Quote  
  4. Originally Posted by 201flyer View Post
    Duration : 6 h 59 min
    Wow!
    Quote Quote  
  5. Originally Posted by 201flyer View Post
    I see open_gop=0 Is your recommendation the same (try remuxing)?
    It's worth a try.

    Do you usually edit such big files without performance problems?
    Quote Quote  
  6. My goal is not to edit this large file. I want to cut out about 45 min, then cut into smaller sections. It is the smaller cuts that are inaccurate and that will play choppy after cutting with VRD. I suspect that the I frames are too far apart.

    I did remux the file with mp4muxer but this made no change at all. I should probably re-encode the file but I'm unsure what settings to try particularly with respect to GOP size which I am guessing could be made smaller.
    Quote Quote  
  7. Originally Posted by 201flyer View Post
    I did remux the file with mp4muxer but this made no change at all.
    I'm not familiar with that. Try something like:
    Code:
    mp4box -raw 1 "input.mp4"
    mp4box -raw 2 "input.mp4"
    mp4box -add "input_track1.h264" -add "input_track2.aac" -new "remux.mp4"
    and/or with mkvmerge:
    Code:
    mkvmerge -o "remux.mkv" "input_track1.h264" "input_track2.acc"
    Important is to extract to raw H.264 ES first. Then to feed that input mp4box/mkvmerge or other suitable muxer. These often have different paths when muxing from mp4/mkv (can copy wrong muxing from source to output) compared to when muxing from raw H.264 ES so some errors may be fixed this way.

    Either way this is only a test. I don't know what the problem is in this case.
    Quote Quote  
  8. Sorry, Sneaker, I didn't see your post. I'll try your suggestion. I did manage a solution through VideoReDo by forcing a GOP size to 32 during a re-encode. I think this original video has a very large GOP though I'm not sure how one finds out this information. Or, maybe the issue is with open Gop as you suggested in your first post.
    Quote Quote  
  9. MediaInfo says "keyint=300" was used for the x264 encoding. On Blu-Ray only 1/10 or 1/5 of that would be allowed. So if the videos you usually edit have such a much smaller GOP size that could indeed be the reason why this one feels sluggish.
    Quote Quote  



Similar Threads