VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Results 1 to 6 of 6
Thread
  1. I'm trying to create a test mp4 with it using external encoders. Video encoder is set to x264 - HQ, audio encoder is set to qaac, multiplexer is set to MP4Box. For x264 - HQ, I'm using x264_64.exe (location set correctly), the command arguments are,

    --crf 19 --preset medium --level 4.1 --keyint 24 --tune film --min-keyint 1 --bluray-compat --b-pyramid none --demuxer raw --input-csp i420 --input-res %(width)x%(height) --fps %(fpsnum)/%(fpsden) -o "%(tempvideofile)" -

    and the output filename is,

    %(outputname).264

    For qaac, the command arguments are,

    -q 0.80 -ignorelength -if - -of "%(tempaudiofile)"

    I'm not sure about the output filename. Maybe that's what giving me the oroblem. Right now, it's,

    %(outputname).m4a

    I had tried %(outputname).audio but that gave me a problem as well. The problem is that every time I try to export the mp4, I'm given the error message,

    The audio encoding process has prematurely exited with an error code of 1 (00000001). Check the log for possible error messages.

    [*] Beginning dub operation.

    [i] Dub: Input (decompression) format is: YUV420P16.

    [i] Dub: Output (compression) format is: RGBA32.
    [*] Ending operation.
    [*] Beginning dub operation.

    [i] Dub: Input (decompression) format is: YUV420P16.

    [i] Dub: Output (compression) format is: YUV420.

    [i] Dub: Command line encoding started with format: YUV420.

    [i] video encoder: "C:\Users\Bruce\Desktop\x264_64.exe" --crf 19 --preset
    medium --level 4.1 --keyint 24 --tune film --min-keyint 1 --bluray-compat
    --b-pyramid none --demuxer raw --input-csp i420 --input-res 1920x800 --fps
    24000/1001 -o "C:\Users\Bruce\Desktop\test.mp4.264" -

    [i] audio encoder: "C:\Users\Bruce\Desktop\qaac.exe" -q 0.80 -ignorelength -if
    - -of "C:\Users\Bruce\Desktop\test.mp4.m4a"

    [i] AudioEnc: invalid option -- g

    [E] Error: The audio encoding process has prematurely exited with an error
    code of 1 (00000001). Check the log for possible error messages.
    [*] Ending operation.
    Quote Quote  
  2. -if and -of aren't valid qaac parameters. Use --ignorelength or -i , not -ignorelength.
    https://github.com/nu774/qaac/wiki/Command-Line-Options

    If you want to pass wav to pass the audio to qaac you need to tick that option in the VirtualDub settings.
    Quote Quote  
  3. Originally Posted by sneaker View Post
    -if and -of aren't valid qaac parameters. Use --ignorelength or -i , not -ignorelength.
    https://github.com/nu774/qaac/wiki/Command-Line-Options

    If you want to pass wav to pass the audio to qaac you need to tick that option in the VirtualDub settings.
    Ya see, my problem is I didn't write those command arguments. RacerX did several years ago for neroaac. I just copied them from him and assumed they'd work for qaac too. I actually have no idea what any of them mean. Can you tell me where I can find command arguments that will work fine for qaac?
    Quote Quote  
  4. Possibly if you follow the link I kindly provided in my last post.
    Quote Quote  
  5. Originally Posted by sneaker View Post
    Possibly if you follow the link I kindly provided in my last post.
    Ah but that's not quite what I meant, ya see. I just meant a particular set that I could just copy and paste into VirtualDub rather than having to try and choose ones myself. I don't understand enough to do that. It's alright anyway. I found another vdprof that was written for qaac rather than neroaac so that should do me.
    Quote Quote  
  6. Seriously, how difficult is it to "decode" the commands in one command line and then adapt them for a second program? It REALLY isn't rocket science.
    Quote Quote  



Similar Threads