VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 3 of 3
  1. Alright, I've got a MKV extracted from a BluRay using MakeMKV. It contains DTS audio. I'm feeding this to ffmpeg and trying to encode only a fraction of the track, however ffmpeg outputs "Output file is empty, nothing was encoded (check -ss / -t / -frames parameters if used)"

    Track metadata:

    BPS-eng         : 1797639
    DURATION-eng    : 02:55:41.056000000
    NUMBER_OF_FRAMES-eng: 988224
    NUMBER_OF_BYTES-eng: 2368627780
    SOURCE_ID-eng   : 001100
    _STATISTICS_WRITING_APP-eng: MakeMKV v1.14.4 win(x64-release)
     _STATISTICS_WRITING_DATE_UTC-eng: 2019-07-30 11:08:48
    The encoding command I use

    ffmpeg -ss 10:22.9 -to 13:25.8 -i ".\t10.mkv" -c:a pcm_s32le -f wav "S01E004.wav"
    Obviously the track is long enough for this, so what gives? I've tried seeking earlier in the track and everything works correctly up until the 8:41.110 mark where the audio cuts abruptly (at least when encoded, the original file has no problem that I can see, or hear)
    Quote Quote  
  2. Sounds like either your file or ffmpeg is broken. As a workaround try output seeking (-i -ss -to instead of -ss -to -i). I would try to re-rip the Blu-Ray, if possible using a different ripper like AnyDVD. If it still shows the same error I would try to cut a small sample around the 8:41.110 mark to send to the ffmpeg developers. What errors is ffmpeg showing? You left out its log. Which Blu-Ray is this? Maybe others with the same Blu-Ray can chime in.

    That said I'm surprised input seeking would stumble across such a problem. AFAIK input seeking should seek directly to the part you want to cut and ignore anything before it, i.e. shouldn't break on 8:41.110 if your seek is at 10:22.9.
    Quote Quote  
  3. FFmpeg does not output any error when that happens, as if the track was simply that short. I've tried re-ripping the BluRay and the issue was gone (and the file was much shorter) I guess something must have gone wrong with MakeMKV that I failed to catch.
    Quote Quote  

Similar Threads