VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Page 3 of 3
FirstFirst 1 2 3
Results 61 to 72 of 72
Thread
  1. Both of that screens are simulated so you can see what I see, this is why you didn't see that over my previous samples because I do not convert the levels, I use as is. Over here (desktop) there is no settings to control limited or full range available anywhere:




    On my display however there is a setting for color dynamic range that is set to 'full', on my Blu-Ray player there is a setting for limited or Full range settings that I use as Full, seting up this way it display very beautiful colors and a decente black levels.









    The only way I can see those screenshots the way I assume you must be seeing them, is to change my monitor's setting to expect a limited range input. That way the "limited" screenshot looks way too dark and the "full" screenshot looks about right (because the levels should have been expanded for the screenshots as jpgs are full range), but that's not how they should display. I'm confused.....
    This is exactly what I do, but instead of messing up with the source levels I just use this limited input from source and encode it as full range, this is enough to make the footage look about right just as you saw it.

    Again, this is how things looks over here, maybe with a different setup, a different display, things might work the way you know it works.
    Quote Quote  
  2. Well, I can't see how taking a limited range video and encoding it while specifying full range for the VUI info can possibly make it display better, if everything else is setup correctly, because all it should achieve is to give the playback chain incorrect levels information.

    We're not going to get anywhere with this though because we're not seeing the same thing for video, and full range playback seems to be broken on my PC anyway (which I think is the reason I'm not seeing grey borders for your "full range" encodes) but what you're saying still doesn't make sense to me. If you take limited range video and encode it while specifying full range so the levels aren't expanded on playback, if anything it should look washed out rather than cinematic, yet your last screenshots, if anything, look overly-dark to me. All the darker detail is gone.

    Over here (desktop) there is no settings to control limited or full range available anywhere:
    I don't understand. It's there in your screenshot in the drop down list. "RGB 444 PC Standard (Full RGB)" and "RGB 444 PC Studio (Limited RGB)". Given there's no separate option for setting video levels I don't know if it applies to both Windows and to video or if the player is supposed to take care of the video levels, but there's definitely full and limited range choices for RGB. YCbCr is probably fixed at one or the other.

    On my display however there is a setting for color dynamic range that is set to 'full', on my Blu-Ray player there is a setting for limited or Full range settings that I use as Full, seting up this way it display very beautiful colors and a decente black levels.
    Color dynamic range would just be some color enhancing crap, but if you can set the Bluray player's output to full range, then logically the TV's input should be set to full range too. That way though, the limited range video levels would probably never be expanded to full range because the Bluray player thinks they're already full range and the display thinks the input levels are full range. Logically, if the display's input was set to limited range, there'd be an output/input levels mismatch which would probably cause the levels to be expanded to full range by the display, making up for the fact the limited range video is labelled as full range incorrectly, and as a result, the mismatch might cause the limited range video to display correctly. Just a theory....
    Last edited by hello_hello; 1st Oct 2019 at 15:52.
    Quote Quote  
  3. Originally Posted by hello_hello View Post
    Well, I can't see how taking a limited range video and encoding it while specifying full range for the VUI info can possibly make it display better, if everything else is setup correctly, because all it should achieve is to give the playback chain incorrect levels information.
    I never said it display "better", it display too dark images.

    Originally Posted by hello_hello View Post
    We're not going to get anywhere with this though because we're not seeing the same thing for video, and full range playback seems to be broken on my PC anyway (which I think is the reason I'm not seeing grey borders for your "full range" encodes) but what you're saying still doesn't make sense to me. If you take limited range video and encode it while specifying full range so the levels aren't expanded on playback, if anything it should look washed out rather than cinematic, yet your last screenshots, if anything, look overly-dark to me. All the darker detail is gone.
    This is the only way to show you what happens if I display a limited source with my full range settings, the blacks are to black and the whites are too white. Encoding a limited range as full range without messing with the source levels, make everything looks correct on my setup as you saw in my previous post with that two pictures.

    On your setup, with your display, it might look washed out and the black bars might look a bit grey, over here it looks correct, the colors, the levels, everything. Why it happen? I don't know.
    The only thing I know for sure is what I have to do to make it look correct, another thing that I set and many people set different it's the display color temperature, people like to set as "hot 1" or "hot 2" over here i use default (neutral).

    Originally Posted by hello_hello View Post
    I don't understand. It's there in your screenshot in the drop down list. "RGB 444 PC Standard (Full RGB)" and "RGB 444 PC Studio (Limited RGB)". Given there's no separate option for setting video levels I don't know if it applies to both Windows and to video or if the player is supposed to take care of the video levels, but there's definitely full and limited range choices for RGB. YCbCr is probably fixed at one or the other.
    Sorry I meant the video player, the AMD settings are set as "RGB 444 PC Standard (Full RGB)" the same as the HDMI port connected to my PC.
    Quote Quote  
  4. Well there's no point going around in circles, but my question remains.... if a video has limited range levels and it's labelled as limited range, shouldn't it display correctly, and if it takes labelling it as full range to make it display correctly even though it's limited range, what must be wrong?

    Or to put it another way, why does labelling limited range video as full range even make sense? Isn't it something like taking a rec.709 video and labelling it as rec.601 in order to get it to display as rec.709? It seems that way to me.
    Quote Quote  
  5. Originally Posted by hello_hello View Post
    Well there's no point going around in circles
    That it's the beauty of this forum, we can discuss and learn together.

    Originally Posted by hello_hello View Post
    but my question remains.... if a video has limited range levels and it's labelled as limited range, shouldn't it display correctly
    Possible yes on a limited 8-bit color display, I don't have any to test it out. Maybe if the display can't handle full range it fall to default.

    Originally Posted by hello_hello View Post
    and if it takes labelling it as full range to make it display correctly even though it's limited range, what must be wrong?
    You have answered that:
    "The only way I can see those screenshots the way I assume you must be seeing them, is to change my monitor's setting to expect a limited range input. That way the "limited" screenshot looks way too dark and the "full" screenshot looks about right"

    Limited source > limited input [x264] full output > image looks correct.
    Limited source > limited input [x264] limited output > image looks dark.

    Originally Posted by hello_hello View Post
    Or to put it another way, why does labelling limited range video as full range even make sense? Isn't it something like taking a rec.709 video and labelling it as rec.601 in order to get it to display as rec.709? It seems that way to me.
    Strange, if I mess up with that the final result get all screwed up.

    Tell me something, how does this sample look to you, does it look too dark or too light?
    Over here it's dark, not too dark but dark in many areas. This is encoded as 4:2:0 Limited.
    Image Attached Files
    Quote Quote  
  6. Originally Posted by amaipaipai View Post
    Originally Posted by hello_hello View Post
    Isn't it something like taking a rec.709 video and labelling it as rec.601 in order to get it to display as rec.709? It seems that way to me.
    Strange, if I mess up with that the final result get all screwed up.
    That was my point.

    Originally Posted by amaipaipai View Post
    Tell me something, how does this sample look to you, does it look too dark or too light?
    Over here it's dark, not too dark but dark in many areas. This is encoded as 4:2:0 Limited.
    Yeah it looks a bit dark, but I think the levels have been messed up in the first place. All I can do is show you how it displays when it's saved as a jpeg, which is independent of any monitor settings. There's places where the blacks looked crushed, but that's probably nothing to do with whether it's displaying "correctly" and everything to do with the video itself having messed up levels in the first place.

    How it displays normally:
    According to IranView most of the girl's hair is pure black, which is how it looks to me.



    Converted from PC to TV levels with a pixel shader:
    Lightening the picture by changing the levels doesn't fix the problem. The crushed black just becomes crushed grey. The detail in her hair is gone. Is that how you see it when you encode it as full range without converting the levels? I'd possibly try to make that one look better by adjusting the gamma or brightness etc, but still encode it as limited range.



    Converted from TV to PC levels with a pixel shader:
    Obviously just makes a bad picture worse.



    You can do the same thing to a video that has more correct levels. This is also limited range, although it's not labelled as such because not too many people bother, given unless otherwise specified, the assumption is limited range.

    How it displays normally:
    Edit: It's probably a camera setting (I don't know enough about it), but even in my sample the white wall on the left, around frame #490, looks like the white has been severely clipped. There's no detail.



    Logically, this is how it should display when encoded as full range without converting the levels.
    PC to TV (it's a bit washed out):



    And if you go the other way it looks too dark, so I'm pretty sure it's displaying correctly.
    The only way to know for certain though is to use the black borders test I mentioned a while ago to determine if black is displaying as black and if the borders and picture get lighter or darker when you change the levels. Once you know it's technically displaying "correctly" you can go about trying to fix a picture if it has bad levels.
    TV to PC:

    Image Attached Files
    Last edited by hello_hello; 4th Oct 2019 at 12:20.
    Quote Quote  
  7. Originally Posted by hello_hello View Post
    Logically, this is how it should display when encoded as full range without converting the levels.
    PC to TV (it's a bit washed out):
    This one looks pretty fine here, it doesn't look washed out or anything.

    The sample looks dark:


    Maybe this is happening because I'm using a TV as a monitor???
    Maybe it's because of Sony "X-Reality Pro" engine??

    The engine it's "turned off" in the settings but who knows for real if it is really turned off or not.
    Last edited by amaipaipai; 4th Oct 2019 at 12:53.
    Quote Quote  
  8. I've found what was causing all this trouble, it's a setting hidden inside the picture settings called "Adv. Contrast Enhancer", it was set as 'low'. The TV uses profiles sou you can have one different setting for GAME mode, TV so on and so forth, for PC I use "GRAPHIC" mode so it suppose to turn everything off but it is sharing the same settings for "MOVIE" mode.

    All looks how it suppose to be now, including your sample.

    Thank you.

    Quote Quote  
  9. I hate to be a party-pooper but I'm still not sure....

    The pic in your post #67 does look too dark. It looks exactly like the third screenshot I posted where I applied a TV to PC conversion with a pixel shader.
    My "normal" screenshot was how it looked without any levels adjustment. To take the screenshot with the levels expanded to PC range I did this (I have some shaders saved as presets to make it easier):



    So it makes sense that your screenshot you said looked too dank looks like my "TV to PC" screenshot (the third one), but now I'm confused why your screenshot from post #68 looks like my "PC to TV" screenshot rather than the first, "normal" one.
    At least I assume it does, unless the brightness changed, because it's not the same frame.

    By the way, I don't know if your TV has the same feature as mine, but mine has a "PC" mode. It's a special mode where all the image enhancing crap that's supposed to be disabled when you disable it, but probably isn't, should be disabled. When it's active, most of the picture enhancing stuff is greyed out. I'd have to connect it again to check I've got it right (the PC monitor is currently connected to the PC's DVI out), but from memory if I connect the PC to the HDMI input marked HDMI (DVI), or it might be HDMI (PC), and the PC is connected at 1920x1080 and the refresh rate is 60Hz, the TV automatically puts itself into PC mode. It may even be fixed at full range input in PC mode, I can't remember for sure, but that's how PC mode for my TV works. It's also old enough to have a VGA input, so naturally when that's being used the TV also runs in PC mode.

    Mind you my TV can be a bit frustrating too. It remembers the various picture settings for each HDMI input individually, which is great, because you can configure different devices to display differently, but it's also really annoying, because if you unplug something and then plug it into a different HDMI input, it'll probably display differently.

    You don't have any erroneous pixel shaders enabled with MPC-BE, by any chance?
    Last edited by hello_hello; 4th Oct 2019 at 15:50.
    Quote Quote  
  10. Originally Posted by hello_hello View Post
    I hate to be a party-pooper but I'm still not sure....

    The pic in your post #67 does look too dark. It looks exactly like the third screenshot I posted where I applied a TV to PC conversion with a pixel shader.
    My "normal" screenshot was how it looked without any levels adjustment. To take the screenshot with the levels expanded to PC range I did this (I have some shaders saved as presets to make it easier):



    So it makes sense that your screenshot you said looked too dank looks like my "TV to PC" screenshot (the third one), but now I'm confused why your screenshot from post #68 looks like my "PC to TV" screenshot rather than the first, "normal" one.
    At least I assume it does, unless the brightness changed, because it's not the same frame.
    Let's try that again from the same frame.

    Virtualdub2


    MPC-BE


    Originally Posted by hello_hello View Post
    By the way, I don't know if your TV has the same feature as mine, but mine has a "PC" mode. It's a special mode where all the image enhancing crap that's supposed to be disabled when you disable it, but probably isn't, should be disabled. When it's active, most of the picture enhancing stuff is greyed out. I'd have to connect it again to check I've got it right (the PC monitor is currently connected to the PC's DVI out), but from memory if I connect the PC to the HDMI input marked HDMI (DVI), or it might be HDMI (PC), and the PC is connected at 1920x1080 and the refresh rate is 60Hz, the TV automatically puts itself into PC mode. It may even be fixed at full range input in PC mode, I can't remember for sure, but that's how PC mode for my TV works. It's also old enough to have a VGA input, so naturally when that's being used the TV also runs in PC mode.

    Mind you my TV can be a bit frustrating too. It remembers the various picture settings for each HDMI input individually, which is great, because you can configure different devices to display differently, but it's also really annoying, because if you unplug something and then plug it into a different HDMI input, it'll probably display differently.
    Yes, it has, it's called "graphic mode" everything it's supposed to be off and grayed out, maybe this was caused by a firmware update I did last year. They recommend that you do a full hardware reset after the update and I never did. I did now and everything it's off as it suppose to be.

    Originally Posted by hello_hello View Post
    You don't have any erroneous pixel shaders enabled with MPC-BE, by any chance?
    My pixel shaders are empty, there is nothing there. On my 'media player classic' there is a bunch of them but I rarely use MPC, it's here as a second option. On my MPC however the renderer settings > Output Range it's set as 'PC 0-255' (default).
    Quote Quote  
  11. Wow! I think we're seeing the same thing now! If not, at least our screenshots finally seem to match.

    Although.... I still don't quite understand why they didn't in the first place, given they should be independent of any display settings.... ie even if you turned the display's contrast down to nothing it shouldn't effect the screenshot.... but I think I'll decide not to think about that....
    Last edited by hello_hello; 4th Oct 2019 at 16:46.
    Quote Quote  
  12. Originally Posted by hello_hello View Post
    Wow! I think we're seeing the same thing now! If not, at least our screenshots finally seem to match.

    Although.... I still don't quite understand why they didn't in the first place, given they should be independent of any display settings.... ie even if you turned the display's contrast down to nothing it shouldn't effect the screenshot.... but I think I'll decide not to think about that....
    I agree, now we are seeing the exact same thing!
    All fine by me!

    Thank you!
    Quote Quote  



Similar Threads