VideoHelp Forum

Try DVD Fab Video Downloader and rip Netflix video! Or Try DVD Fab and copy Blu-rays! or rip iTunes movies!
+ Reply to Thread
Results 1 to 6 of 6
  1. Hi

    It is first time to ask a question here.

    I encountered a problem which is related to downloading the streaming video through ffmpeg. But it always showed HTTP error 403 Forbidden. Can someone help me get through this?

    BTW I tried youtube-dl and streamlink, which i failed.

    The details of the debug of ffmpeg are below.

    Note: the link that i use is a video related to porn. If i am not allowed to to put this kind of link i will delete this question and re-ask again

    ffmpeg -v debug -headers $'Cookie: logged_in=yes; tracker=direct\r\n' -i,1561502276/428085_high.mpd
    ffmpeg version N-94099-gdd662bbdd2 Copyright (c) 2000-2019 the FFmpeg developers
    built with gcc 9.1.1 (GCC) 20190621
    configuration: --enable-gpl --enable-version3 --enable-sdl2 --enable-fontconfig --enable-gnutls --enable-iconv --enable-libass --enable-libdav1d --enable-libbluray --enable-libfreetype --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-libshine --enable-libsnappy --enable-libsoxr --enable-libtheora --enable-libtwolame --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxml2 --enable-libzimg --enable-lzma --enable-zlib --enable-gmp --enable-libvidstab --enable-libvorbis --enable-libvo-amrwbenc --enable-libmysofa --enable-libspeex --enable-libxvid --enable-libaom --enable-libmfx --enable-amf --enable-ffnvcodec --enable-cuvid --enable-d3d11va --enable-nvenc --enable-nvdec --enable-dxva2 --enable-avisynth --enable-libopenmpt
    libavutil 56. 29.100 / 56. 29.100
    libavcodec 58. 53.100 / 58. 53.100
    libavformat 58. 28.100 / 58. 28.100
    libavdevice 58. 7.100 / 58. 7.100
    libavfilter 7. 55.100 / 7. 55.100
    libswscale 5. 4.101 / 5. 4.101
    libswresample 3. 4.100 / 3. 4.100
    libpostproc 55. 4.100 / 55. 4.100
    Splitting the commandline.
    Reading option '-v' ... matched as option 'v' (set logging level) with argument 'debug'.
    Reading option '-headers' ... matched as AVOption 'headers' with argument '$Cookie: logged_in=yes; tracker=direct\r\n'.
    Reading option '-i' ... matched as input url with argument ',1561502276/428085_high.mpd'.
    Finished splitting the commandline.
    Parsing a group of options: global .
    Applying option v (set logging level) with argument debug.
    Successfully parsed a group of options.
    Parsing a group of options: input url,1561502276/428085_high.mpd.
    Successfully parsed a group of options.
    Opening an input file:,1561502276/428085_high.mpd.
    [NULL @ 0000025a28c69580] Opening ',1561502276/428085_high.mpd' for reading
    [https @ 0000025a28c69e40] Setting default whitelist 'http,https,tls,rtp,tcp,udp,crypto,httpproxy'
    [https @ 0000025a28c69e40] No trailing CRLF found in HTTP header. Adding it.
    [tcp @ 0000025a28c6c740] Original list of addresses:
    [tcp @ 0000025a28c6c740] Address port 443
    [tcp @ 0000025a28c6c740] Interleaved list of addresses:
    [tcp @ 0000025a28c6c740] Address port 443
    [tcp @ 0000025a28c6c740] Starting connection attempt to port 443
    [tcp @ 0000025a28c6c740] Successfully connected to port 443
    [https @ 0000025a28c69e40] request: GET /dash/6BSufj-_lPq-lc0vI9Khtw,1561502276/428085_high.mpd HTTP/1.1
    User-Agent: Lavf/58.28.100
    Accept: */*
    Range: bytes=0-
    Connection: close
    Icy-MetaData: 1
    $Cookie: logged_in=yes; tracker=direct\r\n

    [https @ 0000025a28c69e40] HTTP error 403 Forbidden,1561502276/428085_high.mpd: Server returned 403 Forbidden (access denied)
    Quote Quote  
  2. You may need to supply a referer and a user agent.
    Quote Quote  
  3. Originally Posted by jagabo View Post
    You may need to supply a referer and a user agent.
    Can you tell me more specifically what referer and user agent i need to use? I tried some of them but still don't work.
    Quote Quote  
  4. Average video editor Sviests's Avatar
    Join Date
    Sep 2018
    Search Comp PM
    Originally Posted by jcrayquaza View Post
    He means URL where it's embeded.
    Quote Quote  

Similar Threads