VideoHelp Forum

+ Reply to Thread
Results 1 to 3 of 3
Thread
  1. Hello everyone!

    I've been scouring the internet for longer than I care to admit before finally deciding that I should just ask via forum.

    The situation is that I have a Canon Vixia HFS100 Camcorder. One day I left it in the car for too long and now every time I turn it on it has a green screen. This screen is everywhere. If I record something, the camcorder will pick up the audio and show nothing but this weird green screen. Even when I view the files on my computer I can hear audio... no video.

    I know I might have to replace the display or some other related part. However, when researching this problem, not only do others not have the "green screen" issue (it's always a black screen issue), but sometimes their ways of fixing the problem has nothing to do with the display. A few people commenting under a Youtube video of a similar issue said that they simply shook their camcorder in a certain way for awhile and bam problem solved. I also know that the problem may be so severe that the camcorder cannot be saved. I am just so frustrated that, whatever the truth about my situation is, I'm far past ready to hear it and move forward. Once again, I don't know why I waited so long to just ask :/

    Has anyone even heard of this problem before? Any help would be appreciated. Thank you so much for reading.
    Quote Quote  
  2. I haven't heard of the problem, and you may very well have fried something in the heat. However, I'd suggest you research the Internet and find out how to do a hard reset. Some camcorders have a recessed reset button. Others can be reset by not only removing the main battery, but also the backup battery (many have a small lithium coin battery to keep the clock and other things going).

    It's worth a try.

    [edit]Here's a link to one such set of reset instructions:

    https://support.usa.canon.com/kb/index?page=content&id=ART127997&cat=4454B001&actp=LIST
    Last edited by johnmeyer; 16th Jun 2019 at 23:02. Reason: added link
    Quote Quote  
  3. Originally Posted by Sora View Post
    every time I turn it on it has a green screen... Even when I view the files on my computer I can hear audio... no video.
    Then the screen isn't the problem (or not the only problem). It's the image sensor or other electronics.
    Quote Quote