VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Results 1 to 25 of 25
Thread
  1. Do AviSynth and VirtualDub has a filter that gets rid of video blur on the edge?
    Quote Quote  
  2. You should probably post a short and untouched video sample showing the problem.
    Quote Quote  
  3. Originally Posted by jseo13579 View Post
    blur on the edge?
    What does that mean? Blurry near the edge of the frame but not the rest? Blurry edges in a video? As suggested, you should post a sample showing the problem.
    Quote Quote  
  4. Not an blurry edge. I am talking about videos with black borders. There are some videos that have slight artifact at the clear edge of the video with black borders. Are there any ways to make it look clean after cropping out all black borders? Here's the example. Look at the left side. Image
    [Attachment 49540 - Click to enlarge]
    Quote Quote  
  5. I see ringing artifacts. For example, in this contrast stretched 8x enlargement of the area around the letter x in the word jukebox:

    Image
    [Attachment 49541 - Click to enlarge]


    Is that what you are talking about? Some of it i scaused by compression, some caused by scaling SD to HD, possibly other causes like sharpening filters, etc. There are some filters designed to alleviate them but they can be very damaging to the picture. Is that from your source or is that after you processed it?
    Last edited by jagabo; 13th Jul 2019 at 20:38.
    Quote Quote  
  6. It's an untouched source
    Quote Quote  
  7. You can reduce the first generation halos with AviSynth and FineDehalo(rx=1, ry=3):
    Image
    [Attachment 49542 - Click to enlarge]


    The video also needs to have the chroma better aligned with the luma, ChromaShiftSP(x=2.0, y=1.0):
    Image
    [Attachment 49543 - Click to enlarge]
    Quote Quote  
  8. Member ChapmanDolly's Avatar
    Join Date
    Sep 2017
    Location
    United Kingdom
    Search Comp PM
    You also have the problem that it is a low resolution low bitrate image hence the stepping on edges.
    Canon G40 - Dell XPS8700 i7 - Win 10 - 24gb RAM - GTX 1060 6GB - DaVinci Resolve 16.0b6 -- Dell dual Xeon Workstation - Win 7 Ultimate - 16gb ECC RAM - GTX 650 - Pro Tools 2018.3
    Quote Quote  
  9. I've download FineDehalo and ChromaShiftSP files, but they are both in avsi format. I've put all of those contents into AviSynth Plugin and SysWOW64 folders, but filters still don't work. Image
    [Attachment 49547 - Click to enlarge]
    Quote Quote  
  10. Is that the right AviSynth folder? Do you have both 32 bit and 64 bit AviSynth installed? Are you using an editor/converter that uses a private version of AviSynth? MeGUI, for example.
    Quote Quote  
  11. Yes it is. I've downloaded other filters and they work just fine without any problems. I don't know if there's any requirement files missing. Are files supposed to be converted from avsi to dll?
    Quote Quote  
  12. [QUOTE=jseo13579;2555184]I don't know if there's any requirement files missing.
    Why didn't you check when you downloaded the avsi files?

    http://avisynth.nl/index.php/FineDehalo#Requirements
    http://avisynth.nl/index.php/ChromaShiftSP#Requirements

    Originally Posted by jseo13579 View Post
    Are files supposed to be converted from avsi to dll?
    No.
    Quote Quote  
  13. Yes, that's where I got all my files from. There's only avsi file and I've saved it before pasting it into AviSynth Plugin and SysWOW64 folders.
    Quote Quote  
  14. Yeah, I've downloaded those as well. You can see those folders in my AviSynth Plugin file on my screenshot I've posted above.
    Quote Quote  
  15. I see folders, not dll files. AviSynth only looks in the plugins folder, not sub folders from there. You need to put the dll files from those folders into the plugins folder.
    Quote Quote  
  16. I don't understand, but dll files are not included in the download. I've downloaded zip files and none of them include dll files. Where do I get it?
    Quote Quote  
  17. I just downloaded masktools2-v2.2.18.7z from AviSynth.nl (which lead to github) and found this inside:

    Code:
    C:\>dir/s/b/a-d masktools2
    C:\masktools2\LICENSE
    C:\masktools2\old_README.md
    C:\masktools2\old_readme.txt
    C:\masktools2\README.md
    C:\masktools2\with_dual_filter_signatures\readme-when-to-use.txt
    C:\masktools2\with_dual_filter_signatures\x64\masktools2.dll
    C:\masktools2\with_dual_filter_signatures\x64_xp\masktools2.dll
    C:\masktools2\with_dual_filter_signatures\x86\masktools2.dll
    C:\masktools2\with_dual_filter_signatures\x86_xp\masktools2.dll
    C:\masktools2\x64\masktools2.dll
    C:\masktools2\x64_xp\masktools2.dll
    C:\masktools2\x86\masktools2.dll
    C:\masktools2\x86_xp\masktools2.dll
    The others include dll files too.
    Quote Quote  
  18. I suppose that's 7z file which does not open on my pc. What do I need to install?
    Quote Quote  
  19. Member
    Join Date
    Jan 2019
    Location
    Europe
    Search Comp PM
    Originally Posted by jseo13579 View Post
    I suppose that's 7z file which does not open on my pc. What do I need to install?
    https://www.7-zip.org/
    Quote Quote  
  20. Image
    [Attachment 49579 - Click to enlarge]
    Image
    [Attachment 49580 - Click to enlarge]
    . Now I have installed all required files for FineDehalo and ChromaShiftSP, but both of them don't work.
    Quote Quote  
  21. Forget FineDehalo() for now and concentrate on ChromaShiftSP() -- it doesn't have any third party requirements so it's easier to diagnose. Remove the FineDehalo() line from your script and add the ChromaShiftSP() line I gave you earlier. Do you get a "no function named ChromaShiftSP" error when you open the script? If so, import the AVSI manually in your script by adding this line to the top of the script:

    Code:
    import("C:\Program Files (x86)\AviSynth\plugins\ChromaShiftSP.avsi")
    Do you still get an error message?
    Last edited by jagabo; 17th Jul 2019 at 21:39.
    Quote Quote  
  22. Yes, there's still a problem. Image
    [Attachment 49584 - Click to enlarge]
    Quote Quote  
  23. I've figured it out. Thanks for your help.
    Quote Quote  



Similar Threads