VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Page 2 of 2
FirstFirst 1 2
Results 31 to 41 of 41
Thread
  1. Originally Posted by poisondeathray View Post
    Originally Posted by celsoac View Post

    Isn't libfftw3f.3.dylib loaded either? How can I install either/both , with brew? Or, how to compile a dylib? Thanks again.
    1): Library not loaded: @loader_path/../libfftw3f.3.dylib
    It says libfftw3f.3.dylib not loaded . And it's a prerequisite as indicated in post 18 in that thread

    I just checked and it also needs FFTW3 as well, sorry about that, in the process of getting all these up all in one day I missed marking those two. The easy way to fix would be to downloaded the provided dependencies and place them in the libraries folder (either through the shortcuts on the desktop or by browsing to /Library/Frameworks/VapourSynth.framework/lib). Having both of those should fix the issue.
    https://forum.doom9.org/showthread.php?p=1844578#post1844578

    It's in the dependencies folder
    https://www.mediafire.com/folder/wvdlnjapm1vvw#9iuigreunnq6i



    Not sure how to use brew or compile a dylib

    You should register at doom9 forum if you haven't already, because it takes a few days to get approoved . Not many mac users of vapoursynth, and they all probably visit there
    I do have libfftw3f.3.dylib installed. If I try to load it, instead of libmvstools.dylib, this is the error:

    Failed to evaluate the script:
    Python exception: No entry point found in /usr/local/lib/vapoursynth/libfftw3f.3.dylib

    Traceback (most recent call last):
    File "src/cython/vapoursynth.pyx", line 1937, in vapoursynth.vpy_evaluateScript
    File "src/cython/vapoursynth.pyx", line 1938, in vapoursynth.vpy_evaluateScript
    File "/PATH/tempPreviewVapoursynthFile01_15_54_503.vpy", line 6, in
    File "src/cython/vapoursynth.pyx", line 1843, in vapoursynth.Function.__call__
    vapoursynth.Error: No entry point found in /usr/local/lib/vapoursynth/libfftw3f.3.dylib


    But if I add the two lines in this order:
    core.std.LoadPlugin("/usr/local/lib/vapoursynth/libfftw3f.3.dylib")
    core.std.LoadPlugin("/usr/local/lib/vapoursynth/libmvtools.dylib")

    this is the error message:
    Failed to evaluate the script:
    Python exception: No entry point found in /usr/local/lib/vapoursynth/libfftw3f.3.dylib

    Traceback (most recent call last):
    File "src/cython/vapoursynth.pyx", line 1937, in vapoursynth.vpy_evaluateScript
    File "src/cython/vapoursynth.pyx", line 1938, in vapoursynth.vpy_evaluateScript
    File "/Users/celso/DOCUMENTOS/VÍDEO/TEMP/HybridTest/tempPreviewVapoursynthFile01_15_54_503.vpy", line 6, in
    File "src/cython/vapoursynth.pyx", line 1843, in vapoursynth.Function.__call__
    vapoursynth.Error: No entry point found in /usr/local/lib/vapoursynth/libfftw3f.3.dylib

    That is, I'm not sure whether the script stops and it doesn't load libmvtools.dylib, or it does load it, in which case the problem with be libfftw3f.3.dylib .

    I'll check into doom3, even all this is really beyond my knowledge. I wish there were just a simple Mac to be able to use QTMGC, which is all I want at this point. I might try vapoursynth for Windows in a virtual machine, but that would slow video processing even more.

    Thank you very much again.

    -celso
    Quote Quote  
  2. Do you have all the dependencies ? Did you read that whole mac thread ? post 23, 24 ?

    kolak copied them and he said it worked for him

    l33tmeatwad:
    To be completely specific about every dependencies you need, you will need links or copies of the following in /Library/Frameworks/VapourSynth.framework/lib:
    libfftw3f_threads.3.dylib
    libfftw3f.3.dylib
    libgcc_s.1.dylib
    libstdc++.6.dylib

    kolak:
    I have those libs. Lets see if copying yours will fix it.

    update: it's working now with your libraries. It's very possible it would work with main also, but I had missing dot in one of the names!
    Quote Quote  
  3. Originally Posted by poisondeathray View Post
    Do you have all the dependencies ? Did you read that whole mac thread ? post 23, 24 ?

    kolak copied them and he said it worked for him

    l33tmeatwad:
    To be completely specific about every dependencies you need, you will need links or copies of the following in /Library/Frameworks/VapourSynth.framework/lib:
    libfftw3f_threads.3.dylib
    libfftw3f.3.dylib
    libgcc_s.1.dylib
    libstdc++.6.dylib

    kolak:
    I have those libs. Lets see if copying yours will fix it.

    update: it's working now with your libraries. It's very possible it would work with main also, but I had missing dot in one of the names!
    Yes, I have all of those , both in the /usr/local/lib/vapoursynth and in the Frameworks... directories .
    Quote Quote  
  4. I have no more ideas . Your best bet is to ask there , since there are a handful of active vapoursynth mac users there

    These types of issues occur on windows too, both avisynth and vapoursynth, but the greater number of users means help and support is much better
    Quote Quote  
  5. Originally Posted by poisondeathray View Post
    I have no more ideas . Your best bet is to ask there , since there are a handful of active vapoursynth mac users there

    These types of issues occur on windows too, both avisynth and vapoursynth, but the greater number of users means help and support is much better
    Thank you very much indeed. I managed to install ffwt3 (brew install ffwt, or whatever) and now the script loads those plugins, though I get this error

    Error: znedi3: error reading weights

    Well, I think it's an improvement, just have to fix that znedi plugin! I'll keep researching.

    -celso
    Quote Quote  
  6. Do you have the nnedi3_weights.bin file ? You need it for nnedi3 , or any of the derivatives like znedi3

    https://github.com/dubhater/vapoursynth-nnedi3/blob/v6/src/nnedi3_weights.bin

    Also, if you can document how you "fixed" or installed something, it might help other mac users
    Quote Quote  
  7. Originally Posted by poisondeathray View Post
    Do you have the nnedi3_weights.bin file ? You need it for nnedi3 , or any of the derivatives like znedi3

    https://github.com/dubhater/vapoursynth-nnedi3/blob/v6/src/nnedi3_weights.bin
    Downloaded! Where do I put it?? In /usr/local/bin ?
    Quote Quote  
  8. It has to be in the same path , so wherever you have your plugins or linked libaries
    Quote Quote  
  9. Originally Posted by poisondeathray View Post
    It has to be in the same path , so wherever you have your plugins or linked libaries
    Done! No error messages! Video encoded with QTGMC in clumsy iMac! Finally! Thanks a lot, you've been extremely helpful, I owe you one! (I don't know how, I'm not into video, but I owe you one anyway).

    Cheers,

    -celso
    Quote Quote  
  10. Cheers

    "Pay it forward" and don't forget to help out the next guy having problems
    Quote Quote  
  11. Originally Posted by poisondeathray View Post
    Cheers

    "Pay it forward" and don't forget to help out the next guy having problems
    Sure, I will and I do, whenever I can, in what are my abilities.
    Quote Quote  



Similar Threads