VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Page 1 of 2
1 2 LastLast
Results 1 to 30 of 46
Thread
  1. Member
    Join Date
    Dec 2010
    Location
    quebec
    Search Comp PM
    i tried to translate avisynth's smoothlevels settings (from SmoothAjdust) into vegas' levels plugin

    everything went kinda ok ..except for the interlacing of the output

    i've disable resampling on the timeline and used windows YUV output with MagicYUV codec

    but can't seam to get interlacing right ..i'm i doing something wrong or is it Vegas' fault ??

    i can't beleive Vegas can't handle interlaced input..must be a way around it

    i'm using VMS 14 platinium
    Quote Quote  
  2. What do you mean by can't get the interlacing right ? What is wrong exactly ? Is it progressive, or interlaced by flagged progressive, or completely progressive ?

    It should be the same thing in VMS Platinum, but In the pro version you need to make sure the project settings, asset interpretation (what vegas "thinks" the video is; you can right click the file in the clip bin to change), export settings all match up
    Quote Quote  
  3. Member
    Join Date
    Dec 2010
    Location
    quebec
    Search Comp PM
    well for example xvid4psp can't detect interlacing and gives me a 1 in 5 decimation detection
    with useless frames when a know it's an hybrid interlaced-film

    i used the new project from "match media settings" so everything was setup right
    Quote Quote  
  4. Did you examine the output directly ? Is there an actual problem with the output , or a problem with xvid4psp ?

    Did you enable interlaced checkbox in magicyuv ?
    Quote Quote  
  5. Member
    Join Date
    Dec 2010
    Location
    quebec
    Search Comp PM
    the interlaced box was check and i see combing when viewed in virtualdub

    i just reinstalled xvid4psp.. maybe a source detection problem?
    but hybrid gives me a progressive detection result also ..
    Quote Quote  
  6. Why do you need to "detect source" if you already know what it is ?
    Quote Quote  
  7. Member
    Join Date
    Dec 2010
    Location
    quebec
    Search Comp PM
    Originally Posted by poisondeathray View Post
    Why do you need to "detect source" if you already know what it is ?
    i know my source but not the result of my VMS encoding ..i just do not want things being mixed up

    and MeGUI gave me a good detection so .at least i learned witch source detection is better
    Quote Quote  
  8. Did you check media clip properties (right click event on timeline/properties,media TAB)?

    All NLE's might interpret footage in a wrong way for whatever reason. If output is wrong that is the first place to check.

    Also no decimation could be processed by Vegas if source needs it.
    No resize of interlace footage should be attempted also if that's your case.
    Quote Quote  
  9. Originally Posted by smartel View Post
    ...when a know it's an hybrid interlaced-film
    There's no such thing as a "hybrid interlaced film". No one can help when they're only guessing. Please provide a 10-second sample direct from your source - one with steady motion - so we can have a look and better determine what you really have and what has to be done.
    Quote Quote  
  10. Member
    Join Date
    Dec 2010
    Location
    quebec
    Search Comp PM
    i always try to get the settings right.. in the media pool , the timeline and the output to match the input

    i think VMS may work in RGB in it's timeline thus sometimes stretching the colorspace to full
    depending on the codec or the resolution or someting else ..

    so i was thinking that it may do something to interlacing too i'm in trial and error mode here
    and maybe not, i read somewhere that VMS was made for DV from it's begining ..so..
    Quote Quote  
  11. Member
    Join Date
    Dec 2010
    Location
    quebec
    Search Comp PM
    Originally Posted by manono View Post
    Originally Posted by smartel View Post
    ...when a know it's an hybrid interlaced-film
    There's no such thing as a "hybrid interlaced film". .
    film interlaced mostly interlaced ..is xvid4psp , megui wrong ? if i made a typo , my error

    and my question is for VMS handling of interlaced material and how to keep it that way
    Quote Quote  
  12. Member
    Join Date
    Dec 2010
    Location
    quebec
    Search Comp PM
    10 sec sample
    Image Attached Files
    Quote Quote  
  13. Vegas 14 Pro, interprets footage ok, 704,480, tff, no problem here exporting from Vegas,

    while exporting you must set resolution as 704x480, not 720x480 and Upper field first
    Quote Quote  
  14. Originally Posted by smartel View Post
    film interlaced mostly interlaced ..is xvid4psp , megui wrong ? if i made a typo , my error
    Well, if they said all that, then they're wrong, yes. Nothing analyzes a source better than your own eyes. Don't trust any of those automatic analyzers, especially for difficult material.

    It was shot on video, so it's not film. At least that section isn't film. It's not hybrid. At least that section isn't hybrid.It's pure interlaced material, that short sample. I have no idea what the rest is like. Why do you need Vegas at all, if you already know how to use AviSynth and its filters? And what's the intended output format? Another DVD, an MP4, what?
    Quote Quote  
  15. I've used Vegas Pro every day for almost twenty years. The one sentence in the first post that hit me was that you disabled resampling. That may be causing the problem (see below for another possibility). Resampling is required to be on for interlaced material. There are lots of posts and YouTube videos that recommend disabling it. This is because the main use of resampling is to create intermediate frames and fields when video speed is changed (slow motion, NTSC<-->PAL, etc. ). It creates the new frames by blending adjacent frames which, while it will give you smooth video, makes the video look fuzzy because you're basically looking at a crossfade for each frame. However, resample also gets used when dealing with interlaced video and if you turn it off while still rendering to an interlaced output, you may not get the results you expect.

    I haven't looked at the VOB you provided, but other people have already looked and verified that it is a standard interlaced file. To help further, I'd need to see the output you produced. It is also possible that the real problem is in the render settings for your MagicYUV codec. Vegas gives you total control over a lot of settings, and it is really easy -- especially when rendering interlaced material -- to do the wrong thing. If I can see five seconds of the original, and then five seconds of the rendered output and, if possible, see a screen shot of the Render As dialog box, I think I can tell you what to change.
    Quote Quote  
  16. Member
    Join Date
    Dec 2010
    Location
    quebec
    Search Comp PM
    my source , output and dialog box
    Image Attached Thumbnails Click image for larger version

Name:	Properties.png
Views:	12
Size:	17.9 KB
ID:	48523  

    Click image for larger version

Name:	Settings.png
Views:	11
Size:	40.9 KB
ID:	48524  

    Click image for larger version

Name:	MagicYUV.png
Views:	17
Size:	35.7 KB
ID:	48525  

    Image Attached Files
    Quote Quote  
  17. Member
    Join Date
    Dec 2010
    Location
    quebec
    Search Comp PM
    "Why do you need Vegas at all, if you already know how to use Avisynth and its filters?"

    I just want a better understanding on how VMS works and i like the way the colors come out .
    VMS colors looks more natural and artistic to me ..
    Quote Quote  
  18. I don't have the MagicYUV codec, so I can't comment on this part.
    However, I loaded the OP's true interlaced 704x480i29.97 source into VMS and selected the project template accordingly. I rendered with the MPEG-2 standard template. Resampling was by default "smart".
    I expected to get a true interlaced output, like the source. However to my surprise:
    The output was zoomed to 720x480. For the resizing it was probably (or hopefully) deinterlaced beforehand, so the temporal resolution of the original was lost. Instead VMS generated an interlaced encoded output with many blended fields.
    Quote Quote  
  19. Originally Posted by smartel View Post
    my source , output and dialog box
    Output.avi was just as interlaced as source.mpg. The problem you are having is that the AVI container doesn't support interlace flagging. So downstream software (players, editors, encoders) won't know the magicyuv video is interlaced. You have to tell them.
    Quote Quote  
  20. I too was not able to view the MagicYUV encoded video because I don't have that codec. Even VLC, which has its own codecs, wouldn't play the video portion of the file.

    I did, however, load the original MPEG-2 file and got the same results as Sharc. In addition, I served it into VirtualDub through a two-line AVISynth script that is simply:

    assumeTFF()
    separatefields()

    I do this with every video I receive in order to tell if it is interlaced or progressive and to then determine, if interlaced, if the field order is correct. Your video has three strange fields at the beginning (way out of order), probably from how the software cut it at the GOP points, and after that is upper field first.

    I think you said that you used the Project Properties to match the video properties to this source. If so, the project properties should also be upper field first. However, the big question is whether the MagicYUV codec is observing that field order. The Render As dialog you provided has a check mark for Interlaced, and it is indeed checked. However, I didn't see any way to set the field order. If this is set incorrectly, you will get very strange results. If the codec is merely guessing, it is likely that it made the wrong guess because NTSC standard definition video was almost always lower field first, whereas yours is top field first. The video will look just fine regardless of which field order is chosen, but once it is set, you can't render using the other field first without creating big problems (unless you fix things up with an AVISynth script).

    You can't fix this by changing the field order because only the things in the bottom half of that dialog affect the rendering, and the field order setting is in the top half, which only affects the playback.

    That brings me to one last thing that I forgot about until now. In the Vegas project properties do not set "deinterlace method" to "none." Set it to blend or interpolate. This is very confusing because, since you are keeping it interlaced, you would think that setting it to none is what you want to do. However, if you make any change to size or aspect ratio (like going from 704x480 to 720x480 as Sharc did) you have to let Vegas first do a deinterlace before it then re-sizes and re-interlaces the result. Best, of course, would be to keep the video at 704x480 to avoid that un-needed re-sizing.

    Sorry I don't have a more complete answer, but maybe some of these hints will let you get it sorted out.
    Quote Quote  
  21. Member
    Join Date
    Dec 2010
    Location
    quebec
    Search Comp PM
    Virtualdub uses MagicYUV for decompressing .. so MagicYUV isn't used for every application ?
    some do..and some don't ??.. i guess this codec can recognise itself ..
    it's a FourCC thing stored in the header and .AVI doesn't support it . Am i understanding this well ?

    Would it be better exporting in .mov via the quicktime 7 option ?

    i won't resize so i let it to "none" i guess...
    Last edited by smartel; 31st Mar 2019 at 10:35.
    Quote Quote  
  22. I don't have MagicYUV installed so I used ffVideoSource() to read the AVI file. It delivered RGB32 by default.

    And once again, AVI doesn't support the flagging of interlaced video. I don't have MagicYUV installed but the interlaced setting in it probably doesn't do anything except control how it converts YV12 to RGB or RGB to YV12 (if asked to do so). It may also effect how the codec handles the video internally. MagicYUV also probably doesn't differentiate between TFF and BFF because it doesn't have to. It's up to you to keep track of that.

    Regarding what decoder is used for different programs, programs can use any decoder that supports the compression scheme. They can used installed VFW decoders, installed DirectShow decoders, or their own internal decoders. On top of that you have both 32 bit and 64 bit subsystems. What happens in one may differ from what happens in the other depending on what's installed.
    Quote Quote  
  23. Sharc - you have to export 704x480 (and TFF)

    Smartel - I do not have magicYUV like others so I cannot compare that output avi, because I do not have a codec to decompress it,

    but I tried exporting utvideo lossles or frame_server.avi from Vegas out of yours VTS_01_.MPG and they are just fine, there is just couple of frames discrepancies at the beginning as johnmeyer says but then it is in sync and interlaced. Lossless is lossless, technically it does not matter, if there is interlace choice in configurations it might apply for code only, somehow to be more effective or something, but should not be seen in actual result.
    Setting for Vegas properties and script I used to compare those clips:

    Code:
    import vapoursynth as vs
    from vapoursynth import core
    
    input=r'F:/frame_server.avi'
    clip = core.avisource.AVISource(input)
    clip = core.resize.Bicubic(clip, matrix_s = '170m', format = vs.YUV420P8)
    clip = core.std.AssumeFPS(clip, fpsnum = 30000, fpsden = 1001)   #2997/100 has to be changed to 30000/1001 for Interleave matching clips
    
    #input=r'F:/ut_video.avi'
    #clip = core.avisource.AVISource(input)
    
    d2v_file=r'F:/VTS_01_.d2v' #from VTS_01_.MPG
    clip2 = core.d2v.Source(d2v_file)
    
    clip_out = core.std.Interleave([clip,clip2])
    clip_out.set_output()
    Image Attached Thumbnails Click image for larger version

Name:	Capture.JPG
Views:	10
Size:	58.5 KB
ID:	48528  

    Last edited by _Al_; 31st Mar 2019 at 13:31.
    Quote Quote  
  24. I just realized that ffms2 loads that Magix RGB, so I loaded it, it looks fine, cannot compare it with that MPG of yours because it is different clip, but using this script and QTGMC I got 60p. Output magix RGB to YUV and QTGMC.mp4
    Code:
    import vapoursynth as vs
    from vapoursynth import core
    import havsfunc
    input=r'F:/Output.avi' #magixyuv RGB
    clip = core.ffms2.Source(input)
    clip = core.resize.Bicubic(clip, matrix_s = '170m', format = vs.YUV420P8)
    clip = havsfunc.QTGMC(clip, Preset='Fast', TFF=True)
    clip.set_output()
    Image Attached Files
    Quote Quote  
  25. do not forget to encode it with --sar 10:11 if you do not resize to square pixel (640x480, etc, ), I did not do it in that mp4
    Quote Quote  
  26. Originally Posted by johnmeyer View Post
    That brings me to one last thing that I forgot about until now. In the Vegas project properties do not set "deinterlace method" to "none." Set it to blend or interpolate. This is very confusing because, since you are keeping it interlaced, you would think that setting it to none is what you want to do.
    Now that's definitely good to know. I couldn't imagine to set it to anything else but "none" if I wanted to keep the format interlaced. Thanks for the hint. Vegas is always good for a surprise. It also took me quite some time to figure out the effect of the different rendering quality settings (draft, preview, good, best) on how the footage gets eventually processed (resampling, clear fields or blended fields, handling of "VFR" sources etc.)
    Quote Quote  
  27. Member
    Join Date
    Dec 2010
    Location
    quebec
    Search Comp PM
    i may be resizing it to 704x528
    Quote Quote  
  28. Originally Posted by _Al_ View Post
    I just realized that ffms2 loads that Magix RGB, so I loaded it, it looks fine, cannot compare it with that MPG of yours because it is different clip
    There is overlap between the two clips.

    Code:
    v0 = Mpeg2Source("Source .d2v", CPU2="ooooxx", Info=3).AssumeTFF().ConvertToRGB32(interlaced=true)
    v1 = ffVideoSource("Output.avi").AssumeTFF().Trim(127,0) # default output is RGB32
    
    Interleave(v0.Subtitle("MPG"), v1.Subtitle("AVI"))
    Quote Quote  
  29. Member
    Join Date
    Dec 2010
    Location
    quebec
    Search Comp PM
    the 2 clips are from the same section but 2 differents edits ..don't try comparing them to each other

    this one is from the source.mpg edit
    Image Attached Files
    Quote Quote  
  30. Originally Posted by smartel View Post
    ...and i like the way the colors come out .
    VMS colors looks more natural and artistic to me ..
    Meaning you like wrong colors? Teaching yourself a new program is good. Using it because it screws up the colors isn't. If the source needs more saturation, then use the Sat setting within Tweak in AviSynth. I suspect these 'artistic' colors result from an improper conversion to RGB within Vegas.
    Quote Quote  



Similar Threads