VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Page 1 of 2
1 2 LastLast
Results 1 to 30 of 35
Thread
  1. Hi Im trying to de interlace a DVD source, using AVISynth filters in MEGUI
    Here is a sample clip
    sample.vob

    I tried
    Code:
    ord = last.getparity() ? 1 : 0
    leakkernelbob(order=ord,threshold=6)
    Srestore()
    vinverse()
    But this has resulted in jerks.
    Am I doing something wrong here?

    If not could you please suggest a proper filter.(like Yadif, Tdeint, Tfm etc).

    Note:- Im not quite sure why I used Srestore() and vinverse(), a friend just gave me...
    Quote Quote  
  2. Member
    Join Date
    Mar 2008
    Location
    United States
    Search Comp PM
    Can you provide a small sample? If so, open the source in DGindex, use the [ and ] to set the start and end points,
    and try to find a clip with steady movement.
    File/save project and demux video
    upload the m2v to the thread
    Quote Quote  
  3. Originally Posted by davexnet View Post
    Can you provide a small sample? If so, open the source in DGindex, use the [ and ] to set the start and end points,
    and try to find a clip with steady movement.
    File/save project and demux video
    upload the m2v to the thread
    The sample video is attached in the first post
    Quote Quote  
  4. Member
    Join Date
    Mar 2008
    Location
    United States
    Search Comp PM
    Something like this to give 25 FPS. If you want 23.976, you can slow down the video and audio.

    Load_Stdcall_plugin("J:\StaxRip_1.1.7.2\Applicatio ns\AviSynth plugins\Yadif\Yadif.dll")
    import("F:\Program Files\AviSynth\plugins\srestore.avs")
    mpeg2source("C:\Users\davex\Desktop\avs_test\sampl e.d2v")
    yadif(mode=1,order=1)
    srestore()
    Quote Quote  
  5. Member
    Join Date
    May 2014
    Location
    Memphis TN, US
    Search PM
    Originally Posted by davexnet View Post
    Something like this to give 25 FPS. If you want 23.976, you can slow down the video and audio.

    Load_Stdcall_plugin("J:\StaxRip_1.1.7.2\Applicatio ns\AviSynth plugins\Yadif\Yadif.dll")
    import("F:\Program Files\AviSynth\plugins\srestore.avs")
    mpeg2source("C:\Users\davex\Desktop\avs_test\sampl e.d2v")
    yadif(mode=1,order=1)
    srestore()

    yadif? Why?
    - My sister Ann's brother
    Quote Quote  
  6. Originally Posted by davexnet View Post
    Something like this to give 25 FPS. If you want 23.976, you can slow down the video and audio.

    Load_Stdcall_plugin("J:\StaxRip_1.1.7.2\Applicatio ns\AviSynth plugins\Yadif\Yadif.dll")
    import("F:\Program Files\AviSynth\plugins\srestore.avs")
    mpeg2source("C:\Users\davex\Desktop\avs_test\sampl e.d2v")
    yadif(mode=1,order=1)
    srestore()
    Thanks
    I have done my first encode with my limited knowledge

    I would like to know feedback of experts here.

    Basically this is what I did

    Code:
    Import("D:\Plugins\Srestore.avsi")
    LoadPlugin("D:\Plugins\vinverse.dll")
    LoadPlugin("D:\Plugins\Deblock.dll")
    LoadPlugin("D:\Plugins\MSharpen.dll")
    LoadPlugin("D:\Plugins\LeakKernelDeint.dll")
    LoadPlugin("D:\Plugins\mt_masktools.dll")
    LoadPlugin("D:\Plugins\degrainmedian.dll")
    LoadPlugin("D:\Plugins\removegrain.dll")
    LoadPlugin("D:\Plugins\RepairS.dll")
    LoadCPlugin("D:\Plugins\Yadif.dll")
    LoadPlugin("C:\megui\MeGUI_2525_x86\tools\dgindex\DGDecode.dll")
    DGDecode_mpeg2source("C:\Anjali\sample.d2v", info=3)
    LoadPlugin("C:\megui\MeGUI_2525_x86\tools\avisynth_plugin\ColorMatrix.dll")
    ColorMatrix(hints=true, threads=0)
    #deinterlace
    yadif(mode=1,order=1)
    Srestore()
    vinverse()
    crop(4, 76, -8, -72)
    Spline36Resize(704,328) # Spline36 (Neutral)
    degrainmedian(mode=4)
    MSharpen(threshold=10, strength=100, highq=true, mask=false)
    Tweak(sat=1.1)
    Deblock(quant=25, aOffset=0, bOffset=0)
    #denoise
    The source is in the first post.
    And here is the encode...
    Encode.mp4
    Any suggestion on how to improve...
    Quote Quote  
  7. Originally Posted by LMotlow View Post
    Originally Posted by davexnet View Post
    Something like this to give 25 FPS. If you want 23.976, you can slow down the video and audio.

    Load_Stdcall_plugin("J:\StaxRip_1.1.7.2\Applicatio ns\AviSynth plugins\Yadif\Yadif.dll")
    import("F:\Program Files\AviSynth\plugins\srestore.avs")
    mpeg2source("C:\Users\davex\Desktop\avs_test\sampl e.d2v")
    yadif(mode=1,order=1)
    srestore()

    yadif? Why?
    An encoder from a well known group said he usually uses leakYadif, Tdeint, Tfm apart from leakkernelbob.
    Is there any better way, kindly advise
    Quote Quote  
  8. I would use mpeg2source's deringing, deblock_qed() for deblocking. Alternatives to Yadif(mode=1, order=1) include QTGMC(preset="fast") or Interleave(TFM(field=GetParity()?1:0), TFM(field=GetParity()?0:1)). I'd put vinverse() before srestore() (not needed if you use QTGMC). And run a good noise reducer. Maybe:

    Code:
    Mpeg2Source("sample.d2v", CPU2="ooooxx", Info=3) 
    AssumeTFF()
    Deblock_QED_i(quant1=24, quant2=28) # edge, internal
    QTGMC(preset="fast", EZDenoise=1.0, DenoiseMC=true)
    SRestore()

    deblock_qed_i():

    Code:
    function Deblock_QED_i ( clip clp, int "quant1", int "quant2", 
     \                     int "aOff1", int "bOff1", int "aOff2", int "bOff2", int "uv" )
    {
    
    quant1 = default( quant1, 24 ) # Strength of block edge deblocking
    quant2 = default( quant2, 26 ) # Strength of block internal deblocking
    
    aOff1 = default( aOff1, 1 ) # halfway "sensitivity" and halfway a strength modifier for borders
    aOff2 = default( aOff2, 1 ) # halfway "sensitivity" and halfway a strength modifier for block interiors
    bOff1 = default( bOff1, 2 ) # "sensitivity to detect blocking" for borders
    bOff2 = default( bOff2, 2 ) # "sensitivity to detect blocking" for block interiors
    
    uv    = default( uv, 3 )    # u=3 -> use proposed method for chroma deblocking
                                # u=2 -> no chroma deblocking at all (fastest method)
                                # u=1|-1 -> directly use chroma debl. from the normal|strong deblock()
    
    last=clp
    par=getparity()
    SeparateFields().PointResize(width,height)
    Deblock_QED(last, quant1, quant2, aOff1, aOff2, bOff1, bOff2, uv)
    AssumeFrameBased()
    SeparateFields()
    Merge(SelectEven(),SelectOdd())
    par ? AssumeTFF() : AssumeBFF()
    Weave() 
    }
    Quote Quote  
  9. Originally Posted by jagabo View Post
    I would use mpeg2source's deringing, deblock_qed() for deblocking. Alternatives to Yadif(mode=1, order=1) include QTGMC(preset="fast") or Interleave(TFM(field=GetParity()?1:0), TFM(field=GetParity()?0:1)). I'd put vinverse() before srestore() (not needed if you use QTGMC). And run a good noise reducer. Maybe:

    Code:
    Mpeg2Source("sample.d2v", CPU2="ooooxx", Info=3) 
    AssumeTFF()
    Deblock_QED_i(quant1=24, quant2=28) # edge, internal
    QTGMC(preset="fast", EZDenoise=1.0, DenoiseMC=true)
    SRestore()

    deblock_qed_i():

    Code:
    function Deblock_QED_i ( clip clp, int "quant1", int "quant2", 
     \                     int "aOff1", int "bOff1", int "aOff2", int "bOff2", int "uv" )
    {
    
    quant1 = default( quant1, 24 ) # Strength of block edge deblocking
    quant2 = default( quant2, 26 ) # Strength of block internal deblocking
    
    aOff1 = default( aOff1, 1 ) # halfway "sensitivity" and halfway a strength modifier for borders
    aOff2 = default( aOff2, 1 ) # halfway "sensitivity" and halfway a strength modifier for block interiors
    bOff1 = default( bOff1, 2 ) # "sensitivity to detect blocking" for borders
    bOff2 = default( bOff2, 2 ) # "sensitivity to detect blocking" for block interiors
    
    uv    = default( uv, 3 )    # u=3 -> use proposed method for chroma deblocking
                                # u=2 -> no chroma deblocking at all (fastest method)
                                # u=1|-1 -> directly use chroma debl. from the normal|strong deblock()
    
    last=clp
    par=getparity()
    SeparateFields().PointResize(width,height)
    Deblock_QED(last, quant1, quant2, aOff1, aOff2, bOff1, bOff2, uv)
    AssumeFrameBased()
    SeparateFields()
    Merge(SelectEven(),SelectOdd())
    par ? AssumeTFF() : AssumeBFF()
    Weave() 
    }
    Im completely confused on dependencies.
    From Avisynth wiki I have loaded dependencies
    But script shows many errors

    Code:
    Import("D:\Plugins\Srestore.avsi")
    Import("D:\Plugins\QTGMC.avsi")
    LoadPlugin("D:\Plugins\MaskTools.dll")
    LoadPlugin("D:\Plugins\mvtools2.dll")
    LoadPlugin("D:\Plugins\nnedi3.dll")
    LoadPlugin("D:\Plugins\RgTools.dll")
    Import("D:\Plugins\Deblock_QED.avs")
    Import("D:\Plugins\SMDegrain.avs")
    Import("D:\Plugins\Deblock_QED_i.avsi")
    LoadPlugin("D:\Plugins\vinverse.dll")
    LoadPlugin("D:\Plugins\DctFilter.dll")
    LoadPlugin("D:\Plugins\MaskTools.dll")
    LoadPlugin("D:\Plugins\Deblock.dll")
    LoadPlugin("D:\Plugins\MSharpen.dll")
    LoadPlugin("D:\Plugins\LeakKernelDeint.dll")
    LoadPlugin("D:\Plugins\mt_masktools.dll")
    LoadPlugin("D:\Plugins\degrainmedian.dll")
    LoadPlugin("D:\Plugins\removegrain.dll")
    LoadPlugin("D:\Plugins\RepairS.dll")
    LoadCPlugin("D:\Plugins\Yadif.dll")
    LoadPlugin("C:\megui\MeGUI_2525_x86\tools\dgindex\DGDecode.dll")
    DGDecode_mpeg2source("C:\Anjali\sample.d2v", CPU2="ooooxx", info=3)
    LoadPlugin("C:\megui\MeGUI_2525_x86\tools\avisynth_plugin\ColorMatrix.dll")
    AssumeTFF()
    Deblock_QED_i(quant1=24, quant2=28) # edge, internal
    QTGMC(preset="fast", EZDenoise=1.0, DenoiseMC=true)
    SRestore()
    #ColorMatrix(hints=true, threads=0)
    #deinterlace
    crop(4, 76, -8, -72)
    Spline36Resize(704,328) # Spline36 (Neutral)
    #denoise
    Quote Quote  
  10. Originally Posted by navarannan View Post
    Im completely confused on dependencies.
    From Avisynth wiki I have loaded dependencies
    But script shows many errors
    Always show the error messages.
    Quote Quote  
  11. Originally Posted by jagabo View Post
    Originally Posted by navarannan View Post
    Im completely confused on dependencies.
    From Avisynth wiki I have loaded dependencies
    But script shows many errors
    Always show the error messages.
    The error messages , are they the javascript pop ups you get when you load the script?
    Quote Quote  
  12. You load the script into VDub. Then you provide both the complete AviSynth script and the error message VDub gives you.

    An encoder from a well known group said he usually uses leakYadif, Tdeint, Tfm apart from leakkernelbob.
    Your encoder friend is probably ten years out of date.
    Quote Quote  
  13. Originally Posted by jagabo View Post
    Originally Posted by navarannan View Post
    Im completely confused on dependencies.
    From Avisynth wiki I have loaded dependencies
    But script shows many errors
    Always show the error messages.
    Here is what I did. As this is the first time Im doing this, please excuse unwanted details...

    Initial script

    Code:
    LoadPlugin("C:\megui\MeGUI_2525_x86\tools\dgindex\DGDecode.dll")
    DGDecode_mpeg2source("C:\Anjali\sample.d2v", info=3)
    LoadPlugin("C:\megui\MeGUI_2525_x86\tools\avisynth_plugin\ColorMatrix.dll")
    ColorMatrix(hints=true, threads=0)
    #deinterlace
    crop(4, 76, -8, -72)
    Spline36Resize(704,328) # Spline36 (Neutral)
    #denoise
    1. Changed Mpeg2Source to include "CPU2="ooooxx"" and reload success
    2. Added "AssumeTFF()" and reload success
    3. Added "Deblock_QED_i(quant1=24, quant2=28) # edge, internal" and reloaded to receive error.


    So I have copied the deblock_qed_i(): Code: to a file named "Deblock_QED_i.avsi" and imported it and reloaded.
    Code:
    Import("D:\Plugins\Deblock_QED_i.avsi")
    LoadPlugin("C:\megui\MeGUI_2525_x86\tools\dgindex\DGDecode.dll")
    DGDecode_mpeg2source("C:\Anjali\sample.d2v", CPU2="ooooxx", info=3)
    AssumeTFF()
    Deblock_QED_i(quant1=24, quant2=28) # edge, internal
    LoadPlugin("C:\megui\MeGUI_2525_x86\tools\avisynth_plugin\ColorMatrix.dll")
    ColorMatrix(hints=true, threads=0)
    #deinterlace
    crop(4, 76, -8, -72)
    Spline36Resize(704,328) # Spline36 (Neutral)
    #denoise
    Got error on reload


    4. So I have imported "Deblock_QED.avs"
    Code:
    Import("D:\Plugins\Deblock_QED_i.avsi")
    Import("D:\Plugins\Deblock_QED.avs")
    LoadPlugin("C:\megui\MeGUI_2525_x86\tools\dgindex\DGDecode.dll")
    DGDecode_mpeg2source("C:\Anjali\sample.d2v", CPU2="ooooxx", info=3)
    AssumeTFF()
    Deblock_QED_i(quant1=24, quant2=28) # edge, internal
    LoadPlugin("C:\megui\MeGUI_2525_x86\tools\avisynth_plugin\ColorMatrix.dll")
    ColorMatrix(hints=true, threads=0)
    #deinterlace
    crop(4, 76, -8, -72)
    Spline36Resize(704,328) # Spline36 (Neutral)
    #denoise
    Then reloaded to get error


    4. Upon checking http://avisynth.nl/index.php/Deblock_QED, I see this needs DctFilter, DeBlock, MaskTools2
    So I have added all the dlls.
    Code:
    Import("D:\Plugins\Deblock_QED_i.avsi")
    Import("D:\Plugins\Deblock_QED.avs")
    LoadPlugin("D:\Plugins\DctFilter.dll")
    LoadPlugin("D:\Plugins\Deblock.dll")
    LoadPlugin("D:\Plugins\MaskTools.dll")
    LoadPlugin("C:\megui\MeGUI_2525_x86\tools\dgindex\DGDecode.dll")
    DGDecode_mpeg2source("C:\Anjali\sample.d2v", CPU2="ooooxx", info=3)
    AssumeTFF()
    Deblock_QED_i(quant1=24, quant2=28) # edge, internal
    LoadPlugin("C:\megui\MeGUI_2525_x86\tools\avisynth_plugin\ColorMatrix.dll")
    ColorMatrix(hints=true, threads=0)
    #deinterlace
    crop(4, 76, -8, -72)
    Spline36Resize(704,328) # Spline36 (Neutral)
    #denoise
    Then reloaded to receive error


    5. So I have commented line "ColorMatrix(hints=true, threads=0)"
    Then reload is success.

    6. Now I included "QTGMC(preset="fast", EZDenoise=1.0, DenoiseMC=true)" and reloaded


    7. Upon checking I see following dependencies
    MaskTools2
    MVTools2
    nnedi3
    RgTools
    SMDegrain

    So I added each dlls.
    Code:
    Import("D:\Plugins\Deblock_QED_i.avsi")
    Import("D:\Plugins\Deblock_QED.avs")
    LoadPlugin("D:\Plugins\DctFilter.dll")
    LoadPlugin("D:\Plugins\Deblock.dll")
    LoadPlugin("D:\Plugins\MaskTools.dll")
    LoadPlugin("D:\Plugins\mvtools2.dll")
    LoadPlugin("D:\Plugins\nnedi3.dll")
    LoadPlugin("D:\Plugins\RgTools.dll")
    Import("D:\Plugins\SMDegrain.avs")
    LoadPlugin("C:\megui\MeGUI_2525_x86\tools\dgindex\DGDecode.dll")
    DGDecode_mpeg2source("C:\Anjali\sample.d2v", CPU2="ooooxx", info=3)
    AssumeTFF()
    Deblock_QED_i(quant1=24, quant2=28) # edge, internal
    QTGMC(preset="fast", EZDenoise=1.0, DenoiseMC=true)
    LoadPlugin("C:\megui\MeGUI_2525_x86\tools\avisynth_plugin\ColorMatrix.dll")
    #ColorMatrix(hints=true, threads=0)
    #deinterlace
    crop(4, 76, -8, -72)
    Spline36Resize(704,328) # Spline36 (Neutral)
    #denoise
    On reload, it gives error


    Now I feel something is severely wrong
    Quote Quote  
  14. LoadPlugin("D:\Plugins\MaskTools.dll")
    That's probably the wrong masktools

    The 2.x branch is MaskTools2.dll

    Certain plugins can cause error loading of other plugins

    Make sure you have the correct version too of each plugin (x86 vs. x64) . Some of them are named the same. For example , nnedi3.dll is the same name for both x86, x64. Also there are different nnedi3.dll versions complied for different CPU architectures. Make sure you have to correct one. (e.g. If you use one that was compiled with AVX2 SIMD support, but your CPU doesn't have it, you will get problems)
    Quote Quote  
  15. Originally Posted by poisondeathray View Post
    LoadPlugin("D:\Plugins\MaskTools.dll")
    That's probably the wrong masktools

    The 2.x branch is MaskTools2.dll

    Certain plugins can cause error loading of other plugins

    Make sure you have the correct version too of each plugin (x86 vs. x64) . Some of them are named the same. For example , nnedi3.dll is the same name for both x86, x64. Also there are different nnedi3.dll versions complied for different CPU architectures. Make sure you have to correct one. (e.g. If you use one that was compiled with AVX2 SIMD support, but your CPU doesn't have it, you will get problems)
    No luck

    I tried
    LoadPlugin("D:\Plugins\masktools2.dll")

    Tried all masktools2.dll under x64 and x64_xp
    Quote Quote  
  16. This can happen with conflicting autoloading plugins, or avisynth version

    What version of avisynth are you using ?

    And is your plugins directory "clean" ? if not clean out your plugins directory)
    Quote Quote  
  17. Originally Posted by poisondeathray View Post
    This can happen with conflicting autoloading plugins, or avisynth version

    What version of avisynth are you using ?

    And is your plugins directory "clean" ? if not clean out your plugins directory)


    It has lots of other plugins. Its messy
    Quote Quote  
  18. Originally Posted by navarannan View Post
    It has lots of other plugins. Its messy
    Clean it out . If you want to back them up, move them to a subfolder . All those get loaded up at runtime, so makes it slower too

    Then add only the ones that you need back one by one , or use LoadPlugin() (but keep them in subfolders) .
    Quote Quote  
  19. Originally Posted by poisondeathray View Post
    Originally Posted by navarannan View Post
    It has lots of other plugins. Its messy
    Clean it out . If you want to back them up, move them to a subfolder . All those get loaded up at runtime, so makes it slower too

    Then add only the ones that you need back one by one , or use LoadPlugin() (but keep them in subfolders) .


    Same error

    My machine is 64 bit.
    Quote Quote  
  20. But that's not the default avisynth/plugins folder where things are autoloaded from. Unless you have a custom install or altered the registry
    Quote Quote  
  21. Originally Posted by poisondeathray View Post
    But that's not the default avisynth/plugins folder where things are autoloaded from. Unless you have a custom install or altered the registry
    Moved them to default directory



    And modified script

    Code:
    Import("C:\Program Files (x86)\AviSynth\plugins\Deblock_QED_i.avsi")
    Import("C:\Program Files (x86)\AviSynth\plugins\Deblock_QED.avs")
    LoadPlugin("C:\Program Files (x86)\AviSynth\plugins\DctFilter.dll")
    LoadPlugin("C:\Program Files (x86)\AviSynth\plugins\Deblock.dll")
    LoadPlugin("C:\Program Files (x86)\AviSynth\plugins\masktools2.dll")
    LoadPlugin("C:\Program Files (x86)\AviSynth\plugins\mvtools2.dll")
    LoadPlugin("C:\Program Files (x86)\AviSynth\plugins\nnedi3.dll")
    LoadPlugin("C:\Program Files (x86)\AviSynth\plugins\RgTools.dll")
    Import("C:\Program Files (x86)\AviSynth\plugins\SMDegrain.avs")
    LoadPlugin("C:\megui\MeGUI_2525_x86\tools\dgindex\DGDecode.dll")
    DGDecode_mpeg2source("C:\Anjali\sample.d2v", CPU2="ooooxx", info=3)
    AssumeTFF()
    Deblock_QED_i(quant1=24, quant2=28) # edge, internal
    QTGMC(preset="fast", EZDenoise=1.0, DenoiseMC=true)
    LoadPlugin("C:\megui\MeGUI_2525_x86\tools\avisynth_plugin\ColorMatrix.dll")
    #ColorMatrix(hints=true, threads=0)
    #deinterlace
    crop(4, 76, -8, -72)
    Spline36Resize(704,328) # Spline36 (Neutral)
    #denoise
    Still same error
    Last edited by navarannan; 8th Mar 2019 at 22:56.
    Quote Quote  
  22. Run

    Code:
    avsmeter64 avsinfo -log
    This will give you info, and list all the plugins, dates , versions


    What are you using to preview the script ?
    Quote Quote  
  23. That folder is for x86 plugins . Most people have separate x64

    Also you are loading mvtools2.dll with LoadPlugin, but it's mvtools.dll in the screenshot (I don't see mvtools2.dll) . mvtools.dll is very old too just look at the dates - that's a culprit for some problems too

    You need to check all locations where avisynth might be autoloading
    Quote Quote  
  24. Originally Posted by poisondeathray View Post
    Run

    Code:
    avsmeter64 avsinfo -log
    This will give you info, and list all the plugins, dates , versions


    What are you using to preview the script ?
    Im using MEGUI
    Where can I find avsmeter64?
    Quote Quote  
  25. Originally Posted by navarannan View Post
    Where can I find avsmeter64?
    https://www.videohelp.com/software/AVSMeter

    Make sure you check the previous comment about mvtools.dll vs. mvtools2.dll
    Quote Quote  
  26. Originally Posted by poisondeathray View Post
    That folder is for x86 plugins . Most people have separate x64

    Also you are loading mvtools2.dll with LoadPlugin, but it's mvtools.dll in the screenshot (I don't see mvtools2.dll) . mvtools.dll is very old too just look at the dates - that's a culprit for some problems too

    You need to check all locations where avisynth might be autoloading
    Sorry I have replaced the correct one. But same error
    x64 means inside Program Files isnt it.

    I dont have an AvsSynth folder under Program Files
    Quote Quote  
  27. Originally Posted by poisondeathray View Post
    Originally Posted by navarannan View Post
    Where can I find avsmeter64?
    https://www.videohelp.com/software/AVSMeter

    Make sure you check the previous comment about mvtools.dll vs. mvtools2.dll
    Code:
    C:\Users\Nav\Desktop\AVSMeter290>avsmeter64 avsinfo -log
    
    AVSMeter 2.9.0 (x64) - Copyright (c) 2012-2019, Groucho2004
    
    VersionString:              AviSynth+ 0.1 (r2772, MT, x86_64)
    VersionNumber:              2.60
    File / Product version:     0.1.0.0 / 0.1.0.0
    Interface Version:          5
    Multi-threading support:    Yes
    Avisynth.dll location:      C:\WINDOWS\SYSTEM32\avisynth.dll
    Avisynth.dll time stamp:    2018-12-20, 12:55:16 (UTC)
    PluginDir2_5 (HKLM, x64):   C:\Users\Nav\Desktop\UniversalAvisynthInstaller_2018-12-22\AvisynthRepository\AVSPLUS_x64\plugins
    PluginDir+   (HKLM, x64):   C:\Users\Nav\Desktop\UniversalAvisynthInstaller_2018-12-22\AvisynthRepository\AVSPLUS_x64\plugins
    
    
    [CPP 2.6 Plugins (64 Bit)]
    C:\Users\Nav\Desktop\UniversalAvisynthInstaller_2018-12-22\AvisynthRepository\AVSPLUS_x64\plugins\ConvertStacked.dll  [2018-12-20]
    C:\Users\Nav\Desktop\UniversalAvisynthInstaller_2018-12-22\AvisynthRepository\AVSPLUS_x64\plugins\DirectShowSource.dll  [2018-12-20]
    C:\Users\Nav\Desktop\UniversalAvisynthInstaller_2018-12-22\AvisynthRepository\AVSPLUS_x64\plugins\ImageSeq.dll  [2018-12-20]
    C:\Users\Nav\Desktop\UniversalAvisynthInstaller_2018-12-22\AvisynthRepository\AVSPLUS_x64\plugins\Shibatch.dll  [2018-12-20]
    C:\Users\Nav\Desktop\UniversalAvisynthInstaller_2018-12-22\AvisynthRepository\AVSPLUS_x64\plugins\TimeStretch.dll  [2018-12-20]
    C:\Users\Nav\Desktop\UniversalAvisynthInstaller_2018-12-22\AvisynthRepository\AVSPLUS_x64\plugins\VDubFilter.dll  [2018-12-20]
    
    C:\Users\Nav\Desktop\AVSMeter290>C:\Users\Nav\Desktop\AVSMeter290C:\Users\Nav\Desktop\AVSMeter290
    Quote Quote  
  28. "C:\Program Files (x86)\AviSynth\plugins" is the default auto load plugin folder for x86 avisynth, so I would't put them there

    Your x64 plugins folder is
    PluginDir2_5 (HKLM, x64): C:\Users\Nav\Desktop\UniversalAvisynthInstaller_20 18-12-22\AvisynthRepository\AVSPLUS_x64\plugins
    PluginDir+ (HKLM, x64): C:\Users\Nav\Desktop\UniversalAvisynthInstaller_20 18-12-22\AvisynthRepository\AVSPLUS_x64\plugins
    Quote Quote  
  29. "C:\megui\MeGUI_2525_x86\tools\dgindex\DGDecode.dll"
    Are you running this though megui 2525 ? Is that x86 pathway ?

    2525 doesn't even have x64 , can it run x64 avisynth ?
    https://www.videohelp.com/software/MeGUI/old-versions#downloadold

    Or maybe update everything; including megui


    Take your script and open it with vdub2 x64 or avspmod x64
    Quote Quote  
  30. Originally Posted by poisondeathray View Post
    "C:\megui\MeGUI_2525_x86\tools\dgindex\DGDecode.dll"
    Are you running this though megui 2525 ? Is that x86 pathway ?

    2525 doesn't even have x64 , can it run x64 avisynth ?
    https://www.videohelp.com/software/MeGUI/old-versions#downloadold

    Or maybe update everything; including megui


    Take your script and open it with vdub2 x64 or avspmod x64
    Its a different error now.
    Quote Quote  



Similar Threads