VideoHelp Forum

Try DVDFab and copy Ultra HD Blu-rays and DVDs! Or rip iTunes movies and music! Download free trial !
+ Reply to Thread
Results 1 to 3 of 3
Thread
  1. I've seen a few people post about having this problem.

    My videos render out too bright looking, as bright as the preview. This happens with wmv, x264, xvid plus most other render options, the one of only few codecs i get to look right includes Sony AVC mp4 rendering. Anyone know why this happens? I have my Nvidia Dynamic Range set to 0-255, i only learned about that fairly recently since it's set to 16-235 by default.

    I have a video i recorded of a game with OBS, if i render that footage in Anyvideoconverter to x264 the brightness looks normal in VLC but not in Media Player. If i take the OBS video into Vegas and then render to uncompressed avi it seems to look ok as well, oddly though when i take that uncompressed avi into Anyvideoconverter and then render that to x264, it comes out looking too bright again.

    I understand that the Vegas preview window is supposed to look too bright, but even snapshots do as well, which I'm assuming is normal?

    What's recommended to fix the brightness issue, other than to render out in mp4?
    Quote Quote  
  2. Vegas could give clips ComputerRGBtoStudioRGB treatment (Sony levels effect, or Magix, not sure now how they label it), If you export on your own, you might need to put it back. Internally it exports right.
    So you can apply StudioRGBtoComputerRGB before export (probably the best outcome)
    or if using Avisynth,
    ConvertToYV12(matrix="PC.709")
    or if using Vapoursynth something like,
    clip = core.resize.Point(clip, format=vs.YUV420P8, matrix_s="709", range_s = "full") #or range_in_s = "limited"
    (if input is RGB)
    Last edited by _Al_; 5th Mar 2019 at 14:52.
    Quote Quote  
  3. Eh i still don't really understand it, how come Vegas makes my video brighter upon exporting in most codecs? The original from OBS is not like that when viewed outside of Vegas.

    So everyone uses levels FX to fix it? I'm confused because elsewhere I've seen people say to disable levels fx before rendering, and others say to enable it for rendering.
    Quote Quote  



Similar Threads