VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Results 1 to 16 of 16
Thread
  1. Hi,

    on my old ubuntu 18.04 installation both l-smash and ffms2 worked with winehq-devel 3.6. now 4.1 is the last version. i used this link (https://wiki.winehq.org/Ubuntu) to install it on both installations. with winehq 4.1 ffms2 works but l-smash doesn't. i also installed vc_run 2013 and 2015. the error is

    System Error Exception access violation
    i also made some tests in a virtual machine with the same results with winehq 4.1. with wine 3.6 from the ubuntu repository its different. now l-smash works (when vc_run 2015 is installed) and ffms2 couldn't find. the error is

    there is no function called ffvideosource
    i also tried loading the plugin with loadplugin(), here i have the error

    plugin ffms2.dll is not an avisynth 2.5 plugin
    i want to have both plugins available because i had videos that could not be loaded with one of the pluigins and i had to switch. has anyone both running? what version? unfortunately i couldn't install the same version that worked on my old ubuntu installation.

    valit
    Quote Quote  
  2. oops, sorry, I thought you were talking about Vapoursynth
    Quote Quote  
  3. Originally Posted by Valit View Post
    plugin ffms2.dll is not an avisynth 2.5 plugin
    AviSynth 2.5? Seems like you are trying to combine ffms2 with headers for 2.6 with AviSynth 2.5. I think today "everyone" is either using 2.6 or latest pinterf AviSynth+.
    Quote Quote  
  4. Yes, i use avisynth 2.6. ffms2 is the last version. This wasn't a problem on all installations i made before. I used the same versions of avisynth and ffms2.

    is there a special ffms2 for avisynth 2.6?
    Quote Quote  
  5. Originally Posted by Valit View Post
    Yes, i use avisynth 2.6. ffms2 is the last version. This wasn't a problem on all installations i made before. I used the same versions of avisynth and ffms2.

    is there a special ffms2 for avisynth 2.6?
    That error message means that you're probably using the ffms2 C-plugin (as opposed to the C++-plugin). Avisynth 2.6 cannot auto-load C-plugins so you would have to use an explicit "LoadCplugin()" call in your script.

    BTW, Avisynth+ can auto-load C-plugins. I recommend updating to AVS+.

    The error message in Avisynth 2.6 should be "plugin ffms2.dll is not an avisynth 2.6 or 2.5 plugin ". You are either using Avisynth 2.5.8 or an early 2.6 alpha. You can use the Avisynth Info Tool or AVSMeter to verify your Avisynth install. At least one of them should work on Wine.
    Last edited by Groucho; 7th Feb 2019 at 05:59.
    Quote Quote  
  6. Doesnt work. I use the same avisynth and ffms2 Version AS i do On my old ubuntu 18.04 installation and there both works. Its not the c-plugin.

    I will test avs+ but i dont think thats the solution.
    Quote Quote  
  7. Originally Posted by Valit View Post
    Doesnt work. I use the same avisynth and ffms2 Version AS i do On my old ubuntu 18.04 installation
    Double check if this is true.
    Quote Quote  
  8. Checked and it doesn't work. I checked the version again:

    AviSynth: 2.60, build Mar 31 2015
    ffms2: 2.23.1
    l-smash: r929
    wine: winehq-devel 4.1, wine-development 3.6
    it seems its a difference i install vc_run using winetricks or manually. when i install it manually with winehq-devel 4.1 ffms2 works, l-smash works when i use lsmashvideosource, but lwlibavvideosource doesn't. but there isn't an error, it still loading the file and avspmod freezes. that happens when i try a mp4 and mkv file. both files are working with ffms2 and lsmashvideosource.

    vc_run 2013 and vc_run 2015 are installed. the wineprefix is set up to windows xp. problem also occurs with windows 7.
    Quote Quote  
  9. i got it to work with wine-development 3.6 from the ubuntu repo. all other didn't work.

    when i try avisynth+ with all versions of wine i have this error when opening a file in avspmod:

    Error parsing plugin string at position 0:
    in an extra window. whats that?

    the script is very simple

    v = LWLibavVideoSource("/media/data/input.mkv", threads=1)
    a = LWLibavAudioSource("/media/data/input.mkv")
    AudioDub(v,a)
    Quote Quote  
  10. Are you using and old AvsPmod version or do you use the latest from https://github.com/gispos/AvsPmod/releases ?
    users currently on my ignore list: deadrats, Stears555
    Quote Quote  
  11. I used thevold version, i didnt know there is a new one. I will try this.
    Quote Quote  
  12. @ selur

    when i start avspmod.exe its still version 2.5.1 not 2.6 and i have the error again. when i try to start the 'avsp.py' i have this error

    python avsp.py
    Traceback (most recent call last):
    File "avsp.py", line 18981, in <module>
    main()
    File "avsp.py", line 18975, in main
    app = MainApp(redirect_flag)
    File "/usr/lib/python2.7/dist-packages/wx-3.0-gtk3/wx/_core.py", line 8628, in __init__
    self._BootstrapApp()
    File "/usr/lib/python2.7/dist-packages/wx-3.0-gtk3/wx/_core.py", line 8196, in _BootstrapApp
    return _core_.PyApp__BootstrapApp(*args, **kwargs)
    File "avsp.py", line 18962, in OnInit
    self.frame = MainFrame()
    File "avsp.py", line 5061, in __init__
    self.LoadAvisynth()
    File "avsp.py", line 6161, in LoadAvisynth
    import avisynth_cffi as avisynth
    File "/home/ich/AvsPmod/src/avisynth_cffi.py", line 48, in <module>
    import cffi
    ImportError: No module named cffi
    Quote Quote  
  13. When I start AvsPmod it's 2.6.0.6. -> seems like you messed up somewhere.
    No clue why you build try to start the 'avsp.py' which is in the 'src'-folder, doesn't make any sense. That file is not meant to be executed.
    users currently on my ignore list: deadrats, Stears555
    Quote Quote  
  14. Ive read this somewhere in avspmod thread in doom9 forum Yeats ago, that u can Start avspmod also with that file. But it results in an error in terminal.
    Quote Quote  
  15. But that would try to start avspmod in your native Windows environment not in wine,...
    users currently on my ignore list: deadrats, Stears555
    Quote Quote  
  16. i tried avspmod 2.6.0.6 and avisynth+ on a virtual machine and it works, but it doesn't on my normal ubuntu. i can open a avs script with avspdmod 2.6 with avisynth 2.6, but when i install avisynth+ avspmod can't be opened anymore. there isn't any wine error.

    using winedebug is absolutely useless because there are hundreds of error messages. there is also a AvsPmod.exe.log with that error

    Traceback (most recent call last):
    File "run.py", line 48, in <module>
    File "avsp.pyo", line 137, in <module>
    File "wxp.pyo", line 33, in <module>
    File "wx\lib\agw\hyperlink.pyo", line 80, in <module>
    File "webbrowser.pyo", line 517, in <module>
    File "webbrowser.pyo", line 486, in register_X_browsers
    File "webbrowser.pyo", line 131, in _iscommand
    File "webbrowser.pyo", line 107, in _isexecutable
    File "genericpath.pyo", line 37, in isfile
    KeyboardInterrupt
    Traceback (most recent call last):
    File "run.py", line 48, in <module>
    File "avsp.pyo", line 134, in <module>
    File "wx\stc.pyo", line 8, in <module>
    KeyboardInterrupt
    i downloaded avspmod twice but had the problems with both versions.
    Quote Quote  



Similar Threads