VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Results 1 to 3 of 3
Thread
  1. First of I am a newbie, maybe I am doing some things very wrong.

    Source is DVDISO downloaded online, so maybe it is the fault of whoever uploaded it. But hopefully you guys can help me out here.

    Source is an anime, which is probably hard telecined. NTSC format. However, I am having problems with IVTCing it using TIVTC. It will always seem combed(?)

    The following avisynth script would give this frame(screenshot from virtualdub2) : https://imgur.com/a/wHSUpBp

    Mpeg2source("VTS_01_1.d2v", cpu=4)
    tfm(order=0, mode=1, slow=2, pp=0)
    Tdecimate(mode=1)

    Here is a 3 second sample which is quite problematic, without any filters: http://www.mediafire.com/file/9tazkvd1zcnythx/Test.mkv/file
    I am not very sure how to upload a sample of the original file, so it had to be encoded in x264 first.

    What I think is happening, is that the video was first hard telecined, and then heavily compressed, such that the parts that are interlaced contain artifacts preventing a proper IVTC from happening. However I wonder what you guys think, and if there is any way to at least make it look better even if its not perfect.

    Of course, as mentioned earlier, there is a chance the source I downloaded from (the only source I can find) is the problem and I should find another copy of it.

    EDIT: Want to mention that using deblock() or smoothd2() and trying it out a bit didn't really help for me, maybe I am not using the right settings.
    Quote Quote  
  2. The video is 25 fps with hard pulldown. Use TDecimate(Cycle=5, CycleR=1) or TDecimate(mode=2, rate=25).

    For more complete analysis you'll need to upload a sample of the original. Make a sample of the original MPEG 2 data using DgIndex (part of the DgMpegDec package). Open a VOB, mark-in, mark-out, File -> Save project and Demux Video. Upload the resulting M2V file.

    You can use DeblockQED() to reduce macroblocking (there's a variation for interlaced video.

    https://forum.videohelp.com/threads/361152-Correct-usage-of-Deblock_QED-for-Interlaced...ge#post2290489

    Or use Mpeg2Source() to open the video and enable it's internal deblocking. You should almost always be using Mpeg2Source with DVD source anyway.

    Use vInverse() to eliminate residual combing (over compression will keep the field matching of TFM from working perfectly).

    Code:
    Mpeg2Source("filename.d2v")
    AssumeBFF()
    Deblock_qed_i(quant1=35, quant2=35)
    TFM()
    vInverse()
    TDecimate(Cycle=5, CycleR=1)
    McTemporalDenoise(settings="high")
    Image Attached Files
    Last edited by jagabo; 31st Jan 2019 at 08:40.
    Quote Quote  
  3. Thank you for your time in explaining, I will try out the suggestions soon, but for now here is the m2v file. The sample in the first post is at the end of this m2v file.
    http://www.mediafire.com/file/8yw91oeuv750cmo/VTS_01_1.demuxed.m2v/file

    Using cpu=4 for mpeg2source helps a bit but does not fully remove the problem.

    EDIT: While it kind of works better now using your suggestion, there are parts where are still far from perfect. Although I use higher quant values, I guess there are some limits to fixing a bad source.
    Last edited by attackworld; 1st Feb 2019 at 04:53.
    Quote Quote  



Similar Threads