VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Results 1 to 5 of 5
Thread


  1. Hi. The picture up is how it shows in: KMPlayer, VLCmedia, Photoshop and even the as a video in the browser from the source BUT it's supposed to look like the one below, I've managed to get the below one from Sony Vegas while editing and also in FreeMake Video Converter (you can cut video there and it lets you play it all and the video looks exactly bright as it should). So my question is, is there any way to get that brightness in KMPlayer except the forceful playing with brightness-saturation etc. (I tried but the quality is worse, much worse than the one below).

    Maybe helpful note: when I edit in Sony Vegas and there's a normal bright video and I change "pixel format" setting from 8-bit to 32-bit floating point (video levels/full range) it literally renders that normal bright video into the exact same dark one as you can see. I don't know what to do with this information and how to work with it in KMPlayer but it may be helpful? Thank you for any advice
    Quote Quote  
  2. This appears to be a PC vs. video Levels problem. The picture isn't darker, the darks are darker and the brights are brighter. I only have a very old version but check the video preferences. Options -> Preferences -> Video Processing -> Soften/Levels -> Level Controls. Is it only this one video that has the problem or all videos?

    Oh, also check your graphics card's settings. Look for full range (0-255) vs. limited range (16-235) options.
    Quote Quote  
  3. Originally Posted by jagabo View Post
    This appears to be a PC vs. video Levels problem. The picture isn't darker, the darks are darker and the brights are brighter. I only have a very old version but check the video preferences. Options -> Preferences -> Video Processing -> Soften/Levels -> Level Controls. Is it only this one video that has the problem or all videos?

    Oh, also check your graphics card's settings. Look for full range (0-255) vs. limited range (16-235) options.

    Thanks for the advice, but that's actually what I tried to change up, but my KMPlayer doesn't seem to react to those changes at all? Even if I try to change brightness/contrast/saturation right now it doesn't react, I have no idea what's up with that, it worked like weeks ago. Anyways, I don't think it's a graphic card's settings problem since it's only this video (and other videos from the same site) that do this. I have no idea what to do next, I wish converting the file to different formats would work but it doesn't
    Quote Quote  
  4. Originally Posted by marow View Post
    I don't think it's a graphic card's settings problem since it's only this video (and other videos from the same site)
    Most video is encoded as YUV. What's displayed on the monitor is RGB. So the video has to be converted from YUV to RGB for you to see it. The international standard is "limited range" YUV where Y (the greyscale image) ranges from 16 to 235. Ie, Y=16 is full black, Y=235 if full white. When converted to RGB that limited range is converted to full range RGB. Y=16 becomes RGB=0, Y=235 becomes RGB=255. With this algorithm any Y values less than 16 also become RGB 0, and any Y values above 235 also become RGB 255.

    That particular video is encoded as "full range" YUV where Y=0 is defined as black, Y=255 is defined as white. Your player is displaying it as if it was limited range YUV. So darks are too dark and crushed in the darkest areas, brights are too bright and crushed in the brightest areas. There are two possible causes of this problem. Either the video isn't flagged as full range (so the player doesn't know not to perform the usual contrast stretch) or it is flagged and the player isn't responding to the flag. MediaInfo might be able to tell you if the video is flagged.

    You can adjust the players proc amp settings (Options -> Preferences -> Color Controls -> Hardware and Software) to compensate. Of course, then you'll have to go back the the normal settings to play other videos.
    Quote Quote  
  5. Originally Posted by jagabo View Post
    Originally Posted by marow View Post
    I don't think it's a graphic card's settings problem since it's only this video (and other videos from the same site)
    Most video is encoded as YUV. What's displayed on the monitor is RGB. So the video has to be converted from YUV to RGB for you to see it. The international standard is "limited range" YUV where Y (the greyscale image) ranges from 16 to 235. Ie, Y=16 is full black, Y=235 if full white. When converted to RGB that limited range is converted to full range RGB. Y=16 becomes RGB=0, Y=235 becomes RGB=255. With this algorithm any Y values less than 16 also become RGB 0, and any Y values above 235 also become RGB 255.

    That particular video is encoded as "full range" YUV where Y=0 is defined as black, Y=255 is defined as white. Your player is displaying it as if it was limited range YUV. So darks are too dark and crushed in the darkest areas, brights are too bright and crushed in the brightest areas. There are two possible causes of this problem. Either the video isn't flagged as full range (so the player doesn't know not to perform the usual contrast stretch) or it is flagged and the player isn't responding to the flag. MediaInfo might be able to tell you if the video is flagged.

    You can adjust the players proc amp settings (Options -> Preferences -> Color Controls -> Hardware and Software) to compensate. Of course, then you'll have to go back the the normal settings to play other videos.
    Okay, thank you so much. I've actually played up with the settings a little and changing the Video Renderer setting to Enhanced Video Renderer did the thing because the changed level I set up (input and output from 0-255 to 16-235 like you said) suddenly started working on the video (hence the other ones were too bright, but that's okay since I know now what to change up). The things is, I need to do continuous screencaps from there through KMPlayer, right, and when I do that it still screencaps the dark video and not what I see. I remember that changing brightness/contrast/etc. from hardware/software settings worked on that and it showed on my screencaps, but soften/levels option doesn't have any effect on the screencaps it seems, so it's still dark. Do you, please, by any chance know what I could do with that? I tried to search and found that changing the "condition" in Video Processing section to "Always Use" could help but it didn't do anything
    Quote Quote  



Similar Threads