VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or try DVDFab and copy, convert or make Blu-rays and DVDs! :)
+ Reply to Thread
Results 1 to 3 of 3
Thread
  1. Hi,

    I am trying to digitize old VHS tapes and have been following the instructions at (in German) https://gleitz.info/forum/index.php?thread/47572-tutorial-hochwertiges-digitalisieren-...en-und-andere/

    Recording of the videos in VirtualDub works find and I have the videos losslessly compressed (using either UtVideo YUV422 BT.601 and Lagarith). These files look and play fine in VLC. Color depth is YUY2 (4:2:2).

    The problems are in the final step, which is converting the videos to h.264 using XMedia Recode 3.4.5.0.

    The output videos have colorful stripes all across the video. This does seem to depend on the input codec, if I use other files (e.g. MPEG4, h264 etc) this does not occur. It only occurs with the lossless formats.
    I have also tried to convert the format to YV12 4:2:0 planar in VirtualDub first and then use XMedia Recode, as YUV 4:2:0 planar seems to be the only color format that is available in XMedia. But the issue is the same.

    The issue seems to be how the input video is decompressed. Even if I choose UtVideo in XMedia the stripes appear.

    Before (VirtualDub)
    Image
    [Attachment 47777 - Click to enlarge]


    After (XMedia Recode)
    Image
    [Attachment 47778 - Click to enlarge]


    Thanks for your help
    Quote Quote  
  2. Member
    Join Date
    Aug 2013
    Location
    Central Germany
    Search PM
    There seems to be an issue in XMR handling different color space and subsampling formats. I would suggest trying another converter.

    VirtualDub2 contains an internal x264 encoder (if the preview looks well, it should be fed correctly), and it can also save the result in MP4 or MKV containers.
    Quote Quote  
  3. Thank you!

    I just solved the problem by fiddling with some settings:

    Choosing the right color space was the solution. In VirtualDub the output color depth was set to YUY2.

    Changing this to the apparently more common "UYVY" fixes the problem.

    Thanks also for pointing to VirtualDub2.
    Quote Quote  



Similar Threads