VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or try DVDFab and copy, convert or make Blu-rays and DVDs! :)
+ Reply to Thread
Results 1 to 14 of 14
Thread
  1. Member
    Join Date
    Mar 2014
    Location
    Brazil, Rio de Janeiro
    Search Comp PM
    Laptop Specs:


    Video Info:


    MPC-HC Settings:




    What could be the reason for this? Maybe I just don't have enough horsepower to play this video smoothly?
    Quote Quote  
  2. Probably not enough horsepower to decode 4K h.264 video at 60 fps and downscale it to 1600x900 for display. Try using a different output device (not madVR).

    Don't be fooled by the CPU model name. An i7 7500U is about equivalent to a i3 in a Desktop.
    Quote Quote  
  3. Yup, the gpu (https://en.wikichip.org/wiki/intel/hd_graphics_620#Hardware_Accelerated_Video) doesn't support 'High 4:4:4' AVC and the cpu is way to slow to handle such content. (I doubt not using madVR will really make a difference, but it might be worth a try)
    users currently on my ignore list: deadrats, Stears555
    Quote Quote  
  4. Member
    Join Date
    Jul 2007
    Location
    United States
    Search Comp PM
    You might give Potplayer or VLC a try. Videos that used to chug along on my old PC with MPC-HC, played fine with Potplayer and VLC. Also, since you're already underpowered, shut down any programs / processes you don't need running in the background and don't do anything else when playing the video.
    Quote Quote  
  5. Yes, you can also see here:

    https://en.wikipedia.org/wiki/Intel_Graphics_Technology#Hardware-accelerated_algorithms

    that Kaby Lake's GPU doesn't support High 4:4:4 video decoding.
    Quote Quote  
  6. /edit:
    Ignore, I looked at the wrong spec...
    Last edited by sneaker; 6th Dec 2018 at 09:20.
    Quote Quote  
  7. 4K 60p video will be tough to play on any PC. However, you can sometimes get better performance by using a different player. For awhile, I used to be able to play 4K video using the player you're using, but then I started getting less than full frame rate. I then tried VLC which didn't used to play these videos smoothly. However, a newer version actually worked, whereas it didn't used to work.
    Quote Quote  
  8. Member
    Join Date
    Mar 2014
    Location
    Brazil, Rio de Janeiro
    Search Comp PM
    Originally Posted by lingyi View Post
    You might give Potplayer or VLC a try. Videos that used to chug along on my old PC with MPC-HC, played fine with Potplayer and VLC. Also, since you're already underpowered, shut down any programs / processes you don't need running in the background and don't do anything else when playing the video.
    Wow! The video played perfectly on VLC. Who would've thought.
    Quote Quote  
  9. Member
    Join Date
    Mar 2014
    Location
    Brazil, Rio de Janeiro
    Search Comp PM
    Sorry for the double post, but I found what's the culprit of the slowness on MPC. It's the H264/AVC internal transform filter. Disabling that makes the video play smoothly, but the video quality gets decreased (doesn't seem to display as RGB 4:4:4 anymore).

    The problem isn't with my hardware, it's just MPC's internal filter that has poor performance (probably doesn't use all CPU cores). I can play the same video with the correct quality without any lag on VLC.

    So, can you guys recommend me a good external decoding filter to replace MPC's internal one? I thought of using the same one as VLC, but I don't know what they use there.
    Quote Quote  
  10. MPC-HC's internal filter has been LAV Video for a long time. Both VLC and LAV Filters are based on ffmpeg. Differences should be negligible.

    Originally Posted by synnchan View Post
    doesn't seem to display as RGB 4:4:4 anymore
    Your display is 4:4:4/RGB so that's impossible. Copy the filter list here. Did you try e.g. Enhanced Video Renderer instead of madvr like jagabo suggested?
    Quote Quote  
  11. Member
    Join Date
    Mar 2014
    Location
    Brazil, Rio de Janeiro
    Search Comp PM
    Originally Posted by sneaker View Post
    Your display is 4:4:4/RGB so that's impossible.
    Then what's the explanation for this:

    Video screenshot (H264/AVC internal filter enabled)
    https://i.imgur.com/0q7weSj.png

    Video screenshot (H264/AVC internal filter disabled)
    https://i.imgur.com/g7UReNk.png

    Left is a random video frame as it shows in the video, and right was photo-shopped so you can see the color bleeding more clearly. It only happens when the filter is disabled.
    RGB 4:4:4 would not have chroma subsampling like that. That's probably some YUV.

    Originally Posted by sneaker View Post
    Copy the filter list here.
    You mean this?


    Originally Posted by sneaker View Post
    Did you try e.g. Enhanced Video Renderer instead of madvr like jagabo suggested?
    Yes, I've tested all of them. Out of the ones in my list, "Old Video Renderer" is the only one that doesn't lag while still displaying full image quality. But it has a lot of tearing/choppiness, possibly because it doesn't accept VSync. The option (accessible through "View > Renderer Settings > VSync") becomes grayed out when I pick that filter.
    Quote Quote  
  12. Originally Posted by synnchan View Post
    Originally Posted by sneaker View Post
    Copy the filter list here.
    You mean this?
    No, I mean "Play"->"Filters".
    Quote Quote  
  13. Member
    Join Date
    Mar 2014
    Location
    Brazil, Rio de Janeiro
    Search Comp PM
    Filters currently loaded:
    - Default DirectSound Device
    - Enhanced Video Renderer (custom presenter)
    - Audio Switcher
    - LAV Video Decoder (internal)
    - LAV Audio Decoder (internal)
    - LAV Splitter Source (internal)
    Quote Quote  
  14. So either way it's using LAV Video?

    I still don't really get your comments about chroma subsampling with an RGB source.
    Quote Quote  



Similar Threads