VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or try DVDFab and copy, convert or make Blu-rays and DVDs! :)
+ Reply to Thread
Results 1 to 13 of 13
Thread
  1. Here's my code.
    Code:
    MPEG2Source("VTS_01_1.d2v")
    D = QTGMC(Preset="Medium", FPSDivisor=2)
    TFM(D2V="VTS_01_1.d2v", slow=2, pp=4, clip2=D)
    TDecimate(mode=1)
    Crop(0, 0, -4, -0)
    KNLMeansCL(D = 1, A = 1, h = 4, device_type="auto")
    DeHalo_alpha_mt(rx=2.0, ry=2.0, darkstr=1.0, brightstr=1.0, lowsens=50, highsens=50, ss=1.5)
    There's a few seconds where a mouth has a few combed frames in my output. I can't seem to remove it. Any help using TFM/TDecimate?
    Quote Quote  
  2. You can try reducing cthresh or MI in TFM.
    Quote Quote  
  3. Originally Posted by jagabo View Post
    You can try reducing cthresh or MI in TFM.
    What's MI?
    Quote Quote  
  4. You know, you could just try reading the TFM doc to get your questions answered:

    MI -

    The # of combed pixels inside any of the blocky by blockx size blocks on the frame
    for the frame to be detected as combed. While cthresh controls how "visible" the
    combing must be, this setting controls "how much" combing there must be in any localized
    area (a window defined by the blockx and blocky settings) on the frame. Min setting = 0,
    max setting = blocky x blockx (at which point no frames will ever be detected as combed).

    Default: 80 (int)
    Quote Quote  
  5. Originally Posted by manono View Post
    You know, you could just try reading the TFM doc to get your questions answered:

    MI -

    The # of combed pixels inside any of the blocky by blockx size blocks on the frame
    for the frame to be detected as combed. While cthresh controls how "visible" the
    combing must be, this setting controls "how much" combing there must be in any localized
    area (a window defined by the blockx and blocky settings) on the frame. Min setting = 0,
    max setting = blocky x blockx (at which point no frames will ever be detected as combed).

    Default: 80 (int)
    I'm gonna try setting the cthresh to 4
    Quote Quote  
  6. Originally Posted by Vitality View Post
    I'm gonna try setting the cthresh to 4
    You do that. And don't forget to put on "Display=True" in TFM (just for testing) so you can see how many frames are needlessly deinterlaced.

    Me, I find that adding Vinverse() after the IVTC is often the better solution to the problem of leftover interlacing.
    Quote Quote  
  7. Originally Posted by manono View Post
    Originally Posted by Vitality View Post
    I'm gonna try setting the cthresh to 4
    You do that. And don't forget to put on "Display=True" in TFM (just for testing) so you can see how many frames are needlessly deinterlaced.

    Me, I find that adding Vinverse() after the IVTC is often the better solution to the problem of leftover interlacing.
    So Vinverse() after TFM/TDecimate?
    Quote Quote  
  8. It seems totally wrong to me to deinterlace (QTGMC) first and then do IVTC. If your material is telecined, then QTGMC is completely unnecessary, unless you later want to use it just for denoising (and there are better options for that).
    Quote Quote  
  9. Originally Posted by johnmeyer View Post
    It seems totally wrong to me to deinterlace (QTGMC) first and then do IVTC. If your material is telecined, then QTGMC is completely unnecessary, unless you later want to use it just for denoising (and there are better options for that).
    no tfm calls qtgmc
    Quote Quote  
  10. In that script the QTGMC frames are only used when TFM's post processor decides a frame is still interlaced after field matching (because of orphaned fields or some other problem). Instead of using its own deinterlacer TFM uses the frame from QTGMC.
    Last edited by jagabo; 25th Nov 2018 at 21:18.
    Quote Quote  
  11. Originally Posted by jagabo View Post
    In that script the QTGMC frames are only used when TFM's post processor decides a frame is still interlaced after field matching (because of orphaned fields or some other problem). Instead of using its own deinterlacer TFM uses the frame from QTGMC.
    Oops! Thanks for that. I didn't see the "Clip2=D" statement on the TFM line.
    Quote Quote  
  12. Originally Posted by Vitality View Post
    Originally Posted by manono View Post
    Originally Posted by Vitality View Post
    I'm gonna try setting the cthresh to 4
    You do that. And don't forget to put on "Display=True" in TFM (just for testing) so you can see how many frames are needlessly deinterlaced.

    Me, I find that adding Vinverse() after the IVTC is often the better solution to the problem of leftover interlacing.
    So Vinverse() after TFM/TDecimate?
    Yes.
    Quote Quote  
  13. Originally Posted by Sharc View Post
    Originally Posted by Vitality View Post
    Originally Posted by manono View Post
    Originally Posted by Vitality View Post
    I'm gonna try setting the cthresh to 4
    You do that. And don't forget to put on "Display=True" in TFM (just for testing) so you can see how many frames are needlessly deinterlaced.

    Me, I find that adding Vinverse() after the IVTC is often the better solution to the problem of leftover interlacing.
    So Vinverse() after TFM/TDecimate?
    Yes.
    Code:
    D = QTGMC(Preset="Slower", FPSDivisor=2)
    TFM(D2V="VTS_01_1.d2v", slow=2, cthresh=4, mi=0, pp=7, clip2=D)
    TDecimate(mode=1)
    vinverse(sstr=2.7, amnt=255, uv=3, scl=0.25)
    Crop(0, 0, -4, -0)
    KNLMeansCL(D = 1, A = 1, h = 4, device_type="auto")
    DeHalo_alpha_mt(rx=2.0, ry=2.0, darkstr=1.0, brightstr=1.0, lowsens=50, highsens=50, ss=1.5)
    This appears to have fixed everything
    Quote Quote  



Similar Threads