VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or try DVDFab Passkey and copy Blu-ray and DVDs! :)
+ Reply to Thread
Results 1 to 13 of 13
Thread
  1. Member
    Join Date
    Oct 2018
    Location
    United States
    Search PM
    For mpeg2 (dvd) to h.264 conversion with handbrake, scenes that have fine parallel lines (example the window blinds, or some sort of a fine grid) end up bad with very visible artifacts even at high RF quality settings like 16-18 (the rest settings being just same as built in preset like 'Fast 480p30'). The output instead of a still window image is something like a gif with some kind of motion happening. Is there some setting that will avoid this? I tried a RF10 value (placebo quality) but that doesn't address this. Thanks!
    Last edited by uvhp; 10th Oct 2018 at 16:08.
    Quote Quote  
  2. 'Fast 480p30'? Meaning 30fps? Is it a movie? Do you have an unreencoded short 10-second sample made from the DVD? One with steady movement? An M2V perhaps created in DGIndex?
    Quote Quote  
  3. Member
    Join Date
    Oct 2018
    Location
    United States
    Search PM
    "Fast 480p30' is the name of a preset in handbrake. The src is 30fps.
    Quote Quote  
  4. Are you resizing, deinterlacing, or sharpening? That causes moire artifacts like those you are describing, not the encoding.
    Quote Quote  
  5. Originally Posted by uvhp View Post
    "Fast 480p30' is the name of a preset in handbrake. The src is 30fps.
    I repeat:

    Originally Posted by manono View Post
    Is it a movie? Do you have an unreencoded short 10-second sample made from the DVD? One with steady movement? An M2V perhaps created in DGIndex?
    Quote Quote  
  6. Member
    Join Date
    Oct 2018
    Location
    United States
    Search PM
    I am attaching a sample (source and output mp4). Notice the grid pattern behind the person.
    Image Attached Files
    Quote Quote  
  7. Member
    Join Date
    May 2014
    Location
    Memphis TN, US
    Search PM
    You didn't say you cropped the frame to mod2 dimensions and inverse telecined it.
    - My sister Ann's brother
    Quote Quote  
  8. Member
    Join Date
    Oct 2018
    Location
    United States
    Search PM
    It is from a default setting in handbrake. I did not use any explicit cropping settings. What is mod2, inverse telecine? IMO this artifact seems to be unrelated to the dimension/crop and happens regardless.
    Quote Quote  
  9. Those coarse lines in the background from deinterlacing post processing after fieldmatching. The fine patterns are detected as "combing" by handbrake . If you can disable that in handbrake it will "less bad" . If you were using avisynth , it would be TFM(pp=0).TDecimate() to IVTC but disable the post processing. Not sure of what the equivalent would be in handbrake . Maybe --no-decomb ?

    https://handbrake.fr/docs/en/latest/cli/command-line-reference.html

    But some of it is unavoidable - fine lines and patterns will always cause moire patterns, especially from dvd.

    eg. (not cropped or resized)
    Image Attached Files
    Last edited by poisondeathray; 12th Oct 2018 at 15:26.
    Quote Quote  
  10. Another way with TFM is to increase the post processing combing threshold from the default of 9 up to 11 -- TFM(cthresh=11).

    In Handbrake Set Detelecine to Default and Deinterlace to Off. Set the frame rate to constant, 23.976.
    Image Attached Files
    Quote Quote  
  11. Member
    Join Date
    Oct 2018
    Location
    United States
    Search PM
    Changing the Deinterlace option (in the filters tab) from Default to Off makes the output a lot better. With so many settings I did not know which one to experiment with. Thank you people so much for your directions.

    Now that makes me wonder what the downside is if I turn that filter off? That filter is ON at default in all the presets. There must be a reason. What does it do anyway? Does it do more good than harm? I will try to read some information about it as well.

    Thanks again.
    Quote Quote  
  12. Originally Posted by uvhp View Post
    Now that makes me wonder what the downside is if I turn that filter off?
    True interlaced material won't be rendered correctly -- comb artifacts will appear in the output file.
    Quote Quote  
  13. Member
    Join Date
    Oct 2018
    Location
    United States
    Search PM
    What is a good way to decide to keep the decomb filter on or off or keep at some intermediate setting? How do we find if the source is interlaced or not?

    Also you suggested "Set the frame rate to constant, 23.976". Should I do that or set it to "same as source"? The dvd is 2.97 fps.
    Last edited by uvhp; 12th Oct 2018 at 16:48.
    Quote Quote  



Similar Threads