VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Results 1 to 17 of 17
Thread
  1. Hi there,

    I have this NTSC which is blended from a PAL source. After using qtgmc and srestore, the video seems quite OK except for the fact that it is "wobbly" in the sense that there are top and bottom black lines that dance back and forth (and they are not there in the source). Maybe this issue has a name but I don't know it.

    How can I get rid of that nasty wobbling? I tried changing bobbers, just in case (yadif instead of qtgmc), but to no avail.

    Here are two samples (the "vanilla" one has no processing). Thank you!
    Image Attached Files
    Quote Quote  
  2. Try cropping away the top/bottom black borders, before or after QTGMC:

    Code:
    LWLibavVideoSource("wobble vanilla.mkv") 
    QTGMC()
    SRestore(frate=25)
    Crop(0,2,-0,-2)
    #AddBorders(0,2,0,2) # optional
    Image Attached Files
    Quote Quote  
  3. Another option is to use border=true for QTGMC
    Quote Quote  
  4. First of all, sorry, I didn't explain myself correctly above: it's not just the black bars that come and go, but the whole image that wobbles.

    But neither of those two options seem to work for me, even though jagabo's NoWobble file indeed has no wobble. Here's my current script:
    MPEG2Source("source.d2v", cpu=0)
    Crop(10, 68, -0, -72) #used to be (10, 66, -0, -70)
    QTGMC()
    srestore()

    (and a Trim command to get that snippet) and what I get, attached, still wobbles. It's easily noticeable in the letters at the beginning. What's going on?
    Image Attached Files
    Quote Quote  
  5. you should crop at the end not before qtgmc and srestore
    Quote Quote  
  6. Doesn't help:
    Image Attached Files
    Quote Quote  
  7. If you're working with an MPEG 2 source why didn't yo upload a sample of that? Use DgIndex, mark a section, File -> Save Project and Demux video. Upload the resulting M2V file.
    Last edited by jagabo; 10th Oct 2018 at 13:00.
    Quote Quote  
  8. Sorry, I didn't know how to do that. Here's the m2v.

    (P.S. I saw your AssumeTFF or AssumeBFF suggestion before the edit; didn't help)
    Image Attached Files
    Quote Quote  
  9. I get no wobble with:

    Code:
    Mpeg2Source("test.demuxed.d2v", CPU2="ooooxx", Info=3) 
    QTGMC()
    SRestore(frate=25)
    Or with Crop(12,68,-8,-72) before or after QTGMC().
    Last edited by jagabo; 10th Oct 2018 at 13:41.
    Quote Quote  
  10. All of those suggestions keep giving me the same kind of wobbliness present already in the first qtgmc file. I don't understand what's going on here.

    Here's another wobbly file, gotten with the following script:

    Code:
    MPEG2Source("test.demuxed.d2v", CPU2="ooooxx", Info=3)
    Crop(12,68,-8,-72)
    QTGMC()
    srestore(frate=25)
    I'm at a loss here, I've no idea what's going on
    Image Attached Files
    Quote Quote  
  11. You probably have some version incompatibility with the filters that QTGMC uses.

    I don't think this is your problem but be sure DgIndex is in Video -> Field Operation -> Honor Pulldown Flags mode when you create the index.
    Quote Quote  
  12. Yeah, that's how DGIndex is set, all right.

    And indeed, it seems to be a QTGMC problem, since replacing it with yadif gives no more wobbling.

    Any ideas what it might be and how to fix it?

    Thanks for all your help!

    EDIT: Note that I've done some rips with QTGMC in the past with the same settings and everything was OK... I just checked one of those other .avs which worked and it's still giving a nice, non-wobbly encode.
    Quote Quote  
  13. I don't know what the problem is. All I can suggest is you try replacing each of the required plugins and the AVSI, one at a time.
    Quote Quote  
  14. Your original has a width (710) that is not divisible by four. This can cause problems. You might try cropping one pixel from either side before you do anything, thus making it 708x344.

    I had to convert to uncompressed to view the video with my tools, so maybe I screwed up something, but it looks to me that the video is bottom field first. I think many PAL conversions assume top field first. You might therefore want to try putting an AssumeBFF() command in the script just after you load the video, but before you call QTGMC.
    Quote Quote  
  15. Originally Posted by jagabo View Post
    I don't know what the problem is. All I can suggest is you try replacing each of the required plugins and the AVSI, one at a time.
    Since I'm getting a similar problem with another file, I decided to try and to this. Sigh. QTGMC was a pain to set up.

    I've a Win XP (virtual) machine. I replaced QTMGC.avsi for the latest one, 3.358s (i.e. I replace the .avsi in my plugins folder), and I get: "mdegrain1 does not have a named argument out16". I upgraded mvtools2 to the latest one, 2.7.33, and I get "Script error: there is no function named MSuper". But my mvtools2.dll is in my plugins folder, all right.
    Quote Quote  
  16. Mr. Computer Geek dannyboy48888's Avatar
    Join Date
    May 2007
    Location
    Texas, USA
    Search Comp PM
    doing this gave me smooth playback without any jumping lines with your supplied m2v sample:
    MPEG2Source("C:\Users\danny\Desktop\test.demuxed.d 2v", cpu=0)
    QTGMC( Preset="Slow", EZDenoise=0, NoisePreset="Slow", SourceMatch=3)
    srestore(frate=25)

    however if it is for some reason with the rest of your film the following also gave decent results:
    MPEG2Source("C:\Users\danny\Desktop\test.demuxed.d 2v", cpu=0)
    tfm(order=-1, mode=5)
    TDecimate(m2PA=True,maxndl=7,Mode=2,Rate=25)
    if all else fails read the manual
    Quote Quote  
  17. Problem solved with some help from the AVSMeter script! Thanks to the guys at the QTGMC thread over at doom9 for the pointer.

    First, the problem got solved by upgrading to AviSynth+. That got my QTGMC working faultily again (but at least something showed up).

    What was causing the wobbliness was masktools. I had both a newer version and an older version, mt-masktools-26.dll, which was loading instead of the newer one. So I deleted the older and QTGMC now works like a charm. Whew.
    Quote Quote  



Similar Threads