VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or try DVDFab DRM and remove iTunes movie & music protection! :)
+ Reply to Thread
Results 1 to 6 of 6
Thread
  1. Member
    Join Date
    Jan 2009
    Location
    United Kingdom
    Search Comp PM
    I did a test with the Sony DCR-TRV283E (PAL) camcorder of capturing Video8 tapes. Its a Digital8 camcorder which can convert Video/Hi8 on the fly through the firewire or s-video.

    For some reason the firewire has really odd interlacing issue with colour bleed. The s-video (captured using Blackmagic Shuttle Intensity with Blackmagic 8bit 422 codec).

    Take a look at the attached images and you can see the issue quite clearly! They're screen caps from VirtualDub which has deinterlaced filter applied on the right using bob doubler to both of them.

    Image
    [Attachment 46630 - Click to enlarge]


    Image
    [Attachment 46631 - Click to enlarge]


    I certainly didn't expect this with firewire! Anyone know what's going on? Why are there lines and colours bleeding from the previous field?? The s-video capture looks much clearer and colours don't bleed.
    Last edited by Bassquake; 28th Aug 2018 at 05:44. Reason: Detail on blackmagic codec used
    Quote Quote  
  2. VirtualDub doesn't handle interlaced YV12 properly. That's the cause of the comb-like color artifacts. The source video is probably fine. You might be able to work around the problem by forcing the source filter to output YUY2 instead of YV12.
    Quote Quote  
  3. Member
    Join Date
    Jan 2009
    Location
    United Kingdom
    Search Comp PM
    I tried setting the Convert Format filter as the 1st in the filter list before deinterlace to YUY2 but didnt make any difference.

    Both video report as YUV in MediaInfo.

    Edit: I notice theres no bleeding and lines in original VirtualDub! Think Ill report this as a bug for VirtualDub2.
    Quote Quote  
  4. Member Bernix's Avatar
    Join Date
    Apr 2016
    Location
    Europe
    Search Comp PM
    Hi,
    it is not same frame. If VD say so, have you checked right fields order in deinterlacer?
    Probably I'm wrong, but field order is really important thing.


    Bernix
    Quote Quote  
  5. The Convert Format filter won't work if VirtualDub has already screwed up the YV12 chroma interlacing. Try Video -> Decoder Format -> 4:2:2 YCbCr (YUYV, YUY2). In that case VirtualDub asks the decoder to provide YUY2.

    PAL DV is internally YV12. The difference between the original VirtualDub and VirtualDub2 may be which decoder is used by default, with one putting out YUY2 and the other YV12. Try specifying the decoder at the File Open dialog. VirtualDub also has a built in DV decoder you can specify (Options -> Preferences -> AVI -> Prefer Internal Decoders...
    Quote Quote  
  6. Member
    Join Date
    Jan 2009
    Location
    United Kingdom
    Search Comp PM
    @Jagabo: Looks like changing the "Open using" in the file dialog sorted it. Was originally on "Caching input driver".

    Thanks all.
    Image Attached Thumbnails Click image for larger version

Name:	change-format2.PNG
Views:	12
Size:	12.2 KB
ID:	46632  

    Quote Quote  



Similar Threads