VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or try DVDFab and copy, convert or make Blu-rays and DVDs! :)
+ Reply to Thread
Results 1 to 3 of 3
Thread
  1. I have a problem with automatic switching to proper audio track in MPC-HC when internal audio switcher is enabled. In that case by default internal track is chosen instead of external with proper language even if it doesn't match language priorities. If I disable internal audio switcher then two audio tracks are played simultaneously. In case if there are only internal tracks then proper language is chosen without any problem. I couldn't find a solution so please help me.
    Last edited by Uzyrgyv; 25th Aug 2018 at 00:19.
    Quote Quote  
  2. I've never been able to get the built-in LAV splitter to select languages, but if you have your preferred languages set under Options/Playback, and the first part of the audio track's name is identical to the whole video file name, and the three letter language code is in square brackets, it should work. Under Options/Playback "auto-load audio files" must also be checked.

    For "My Video.mkv" the audio name must begin with "My Video", but I don't think it matters from there, aside from the brackets. ie

    This Is My Movie.mkv
    This Is My Movie 02 [fre] delay 64ms.ac3

    There may be other magic combinations, but that's the only one I'm aware of.

    PS. The tooltip for the language section offers an example that could be interpreted as including quotes.
    It looks something like this,
    "fre jap eng"
    but they should be entered like this,
    fre jap eng
    or comma separated codes should also work
    fre,jap,eng
    Last edited by hello_hello; 25th Aug 2018 at 01:07.
    Quote Quote  
  3. hello_hello, Wow! Your advice is awesome! It worked, thank you very much!
    Quote Quote  



Similar Threads