VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 9 of 9
Thread
  1. Hey girls and boys.

    I have 4k HDR files and trying to convert them to x265 1080p without success. I also want keep to HDR metadata.

    I'm using latest Megui and try to loading them but giving me this error:

    FFVideoSource: No suitable output format found
    Btw I have instaled latest ffms2 and AVS+
    Quote Quote  
  2. Post a complete MediaInfo log ("View"->"Text") of the file. Try a different 4K/HDR file.

    "Latest" ffms2 means 2.23.1?
    Quote Quote  
  3. Thanks for really quick response.

    Here's mediaInfo log (video part):

    Video
    ID : 1
    Format : HEVC
    Format/Info : High Efficiency Video Coding
    Commercial name : HDR10
    Format profile : Main 10@L5.1@High
    Codec ID : V_MPEGH/ISO/HEVC
    Duration : 1 h 57 min
    Bit rate : 50.0 Mb/s
    Width : 3 840 pixels
    Height : 2 160 pixels
    Display aspect ratio : 16:9
    Frame rate mode : Constant
    Frame rate : 23.976 (24000/1001) FPS
    Color space : YUV
    Chroma subsampling : 4:2:0 (Type 2)
    Bit depth : 10 bits
    Bits/(Pixel*Frame) : 0.251
    Stream size : 41.0 GiB (90%)
    Writing library : ATEME Titan File 3.8.3 (4.8.3.0)
    Default : Yes
    Forced : No
    Color range : Limited
    Color primaries : BT.2020
    Transfer characteristics : PQ
    Matrix coefficients : BT.2020 non-constant
    Mastering display color primaries : Display P3
    Mastering display luminance : min: 0.0050 cd/m2, max: 4000 cd/m2
    Maximum Content Light Level : 1655 cd/m2
    Maximum Frame-Average Light Level : 117 cd/m2
    Yes using ffms2 2.23.1 atm.
    Quote Quote  
  4. I'd suggest ffmpeg. Don't know, what you want to do with the audio. So, I assume, you will simply copy it:

    Code:
    ffmpeg -i video.mkv -pix_fmt yuv420p10le -map 0:v:0 -map 0:a:0 -aspect 16:9 -vf scale=1920:1080 -c:v libx265 -tag:v hvc1 -preset:v fast -x265-params "colorprim=bt2020:transfer=smpte2084:colormatrix=bt2020nc:master-display=G(13250,34500)B(7500,3000)R(34000,16000)WP(15635,16450)L(40000000,50):max-cll=1655,117" -crf 18 -c:a copy -y video-1080.mkv
    Think Staxrip should be able to do that, too.
    Last edited by fornit; 19th Aug 2018 at 20:06.
    Quote Quote  
  5. Originally Posted by max_cady View Post
    Here's mediaInfo log (video part):
    Never reduce the MediaInfo log to just the video part.

    Originally Posted by max_cady View Post
    Color space : YUV
    Chroma subsampling : 4:2:0 (Type 2)
    Bit depth : 10 bits
    Yes using ffms2 2.23.1 atm.
    Ok, so it's 10 bit 4:2:0. Are you sure it is using AviSynth+? In MeGUI's settings activate "Always use included AviSynth" and set Auto Update to use the development update server. Run MeGUI's update and make sure AviSynth portable and ffms are up-to-date.

    To check AviSynth version create a simple script and view it:
    Code:
    Version()
    Last edited by sneaker; 20th Aug 2018 at 06:27.
    Quote Quote  
  6. Originally Posted by sneaker View Post
    Originally Posted by max_cady View Post
    Here's mediaInfo log (video part):
    Never reduce the MediaInfo log to just the video part.

    Originally Posted by max_cady View Post
    Color space : YUV
    Chroma subsampling : 4:2:0 (Type 2)
    Bit depth : 10 bits
    Yes using ffms2 2.23.1 atm.
    Ok, so it's 10 bit 4:2:0. Are you sure it is using AviSynth+? In MeGUI's settings activate "Always use included AviSynth" and set Auto Update to use the development update server. Run MeGUI's update and make sure AviSynth portable and ffms are up-to-date.

    To check AviSynth version create a simple script and view it:
    Code:
    Version()
    I try many thing but no success yet.

    I reinstalled Avisynth 2.6 and installed Avisynth+ before and shown Avisynth+ with Version() .

    I do everything to Megui like you said but it gives me this error:

    ----[Error] AviSynth Status: inactive - portable AviSynth build cannot be used. The loaded DLL is: d:\programlar\encoding\megui-2836-64\avisynth.dll
    ---[Error] AviSynth: not found
    Also some errors when I load the script:

    -"there is no function named FFVideoSource"
    -"Cannot load 32bit DLL in 64bit AviSynth "

    And similar errors when I try with Staxrip.

    I really thank you both.
    Quote Quote  
  7. Hm,

    I'm sure HDR encoding via AviSynth and MeGUI is the more sophisticated and challenging approach...

    But if you are looking for a working solution primarily, why not ffmpeg? If you use the latest static Zeranoe builds, then you will avoid all that trouble with software dependencies.
    Quote Quote  
  8. You are using MeGUI 64 bit. It will only use AviSynth 64 bit and 64 bit AviSynth plugins.
    Quote Quote  
  9. Originally Posted by sneaker View Post
    You are using MeGUI 64 bit. It will only use AviSynth 64 bit and 64 bit AviSynth plugins.
    Yeah looks like my problems start there.

    No problem with Staxrip atm, but Megui still has problem. Looks like I'll skip megui atm.
    Quote Quote  



Similar Threads