VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or try DVDFab and copy, convert or make Blu-rays and DVDs! :)
+ Reply to Thread
Results 1 to 8 of 8
Thread
  1. Hello, I am talking as an employee of a small company operating surveillance systems. I'm new and I have a problem with ffmpeg converting video files.

    The resulting files are corrupted, namely from converting .dat files (that are fine) into .mp4 files. The files are used to provide pseudo-livestream for a website. The conversation is done with ffmpeg and I am hoping that there is a quick solution.

    The results can be seen here: http://balatonlelle.dyndns.tv/kamera/

    The first few seconds are fine but the video becomes increasingly corrupted as the image moves.

    As seen, it shows a panorama camera's view of lake Balaton (popular holiday resort), so people can see the current state of the weather at the lake. While it is not a straight-on redirected stream, the converted files are constantly updated and the delay is merely minutes. The reason this method was chosen was from a desire that the video could be viewed from phones, back in the day, and would not require installing ActiveX addons and such to play. Hence why .mp4 format.

    The heart of the problem is twofold: first, the person who made the system is gone and left no documentation (and worse, is unavailable). Compounding the problem is that the server is a Windows XP machine and we have no funds to replace it at the moment (nor time to just make a new one as we have to go out to various locations to fix problems at locations).

    Here is the commands used in the batch file (or rather, the problematic bit) that contains command for using ffmpeg:
    copy /Y %1 %2
    set gg=%3
    set mit=%gg:~0,14%
    vid\ff\bin\ffmpeg -y -t 00:01:00 -ss 00:00:15 -r 10 -i vid\honnan\%mit%.dat -s 1280x720 -b:v 4M -preset ultrafast %2\%4.ogg
    move %2\%4.ogg vid\konvert
    vid\ff\bin\ffmpeg -y -t 00:01:00 -ss 00:00:15 -r 10 -i vid\honnan\%mit%.dat -s 1280x720 -b:v 4M -preset ultrafast %2\%4.mp4
    move %2\%4.mp4 vid\konvert
    del /F vid\honnan\%mit%.*
    rem pause
    exit
    I belive %1 and %2 are filenames, as the resulting files in the "konvert" directory are named things like

    Details of the system are below. I highlighted the problem area.

    How it works: the server plays several roles:
    1. It acts as a virtual NVR (through a network) for the panorama camera. This is done with an old version of Central Management Software. Said software continuously makes new .dat video files from panorama camera feed. This part works fine.
    2. A batch file is run that copies the latest .dat file and moves them into a different folder, readying it for conversation and deleting old files. I believe that the converstion is two-step, with the first step is converting it from a .dat file into a .avi file. This too works (the .avi file is not corrupted).
    3. PROBLEM-> A sub-batch file is run to convert the file, that I gave the code for in the above. An .mp4 video file is created. This is where the problem is as the .mp4 file is corrupted. I have checked with VLAN and it is the converted .mp4 file that is bad, not the original .dat or .avi file.
    4. The server acts as an xampp host for the the webpage linked above via xampp. The video that is seen is from a .mp4 file that is located on the server machine. As the webpage works, this part too works fine.
    5. The webpage allows playing the .mp4 file. This works.

    The version of ffmpeg used is 2014-05-14 git-0aac9b7. I have tried the latest version but that causes problems and does not work.

    I am hoping that someone savvy with FFmpeg might spot what is wrong with this, rather than require several hours of experimenting or making another batch file from scratch.
    Quote Quote  
  2. Originally Posted by Vidikon View Post
    Hello, I am talking as an employee of a small company operating surveillance systems. I'm new and I have a problem with ffmpeg converting video files.

    The resulting files are corrupted, namely from converting .dat files (that are fine) into .mp4 files. The files are used to provide pseudo-livestream for a website. The conversation is done with ffmpeg and I am hoping that there is a quick solution.

    The results can be seen here: http://balatonlelle.dyndns.tv/kamera/

    The first few seconds are fine but the video becomes increasingly corrupted as the image moves.

    As seen, it shows a panorama camera's view of lake Balaton (popular holiday resort), so people can see the current state of the weather at the lake. While it is not a straight-on redirected stream, the converted files are constantly updated and the delay is merely minutes. The reason this method was chosen was from a desire that the video could be viewed from phones, back in the day, and would not require installing ActiveX addons and such to play. Hence why .mp4 format.

    The heart of the problem is twofold: first, the person who made the system is gone and left no documentation (and worse, is unavailable). Compounding the problem is that the server is a Windows XP machine and we have no funds to replace it at the moment (nor time to just make a new one as we have to go out to various locations to fix problems at locations).

    Here is the commands used in the batch file (or rather, the problematic bit) that contains command for using ffmpeg:
    copy /Y %1 %2
    set gg=%3
    set mit=%gg:~0,14%
    vid\ff\bin\ffmpeg -y -t 00:01:00 -ss 00:00:15 -r 10 -i vid\honnan\%mit%.dat -s 1280x720 -b:v 4M -preset ultrafast %2\%4.ogg
    move %2\%4.ogg vid\konvert
    vid\ff\bin\ffmpeg -y -t 00:01:00 -ss 00:00:15 -r 10 -i vid\honnan\%mit%.dat -s 1280x720 -b:v 4M -preset ultrafast %2\%4.mp4
    move %2\%4.mp4 vid\konvert
    del /F vid\honnan\%mit%.*
    rem pause
    exit
    I belive %1 and %2 are filenames, as the resulting files in the "konvert" directory are named things like

    Details of the system are below. I highlighted the problem area.

    How it works: the server plays several roles:
    1. It acts as a virtual NVR (through a network) for the panorama camera. This is done with an old version of Central Management Software. Said software continuously makes new .dat video files from panorama camera feed. This part works fine.
    2. A batch file is run that copies the latest .dat file and moves them into a different folder, readying it for conversation and deleting old files. I believe that the converstion is two-step, with the first step is converting it from a .dat file into a .avi file. This too works (the .avi file is not corrupted).
    3. PROBLEM-> A sub-batch file is run to convert the file, that I gave the code for in the above. An .mp4 video file is created. This is where the problem is as the .mp4 file is corrupted. I have checked with VLAN and it is the converted .mp4 file that is bad, not the original .dat or .avi file.
    4. The server acts as an xampp host for the the webpage linked above via xampp. The video that is seen is from a .mp4 file that is located on the server machine. As the webpage works, this part too works fine.
    5. The webpage allows playing the .mp4 file. This works.

    The version of ffmpeg used is 2014-05-14 git-0aac9b7. I have tried the latest version but that causes problems and does not work.

    I am hoping that someone savvy with FFmpeg might spot what is wrong with this, rather than require several hours of experimenting or making another batch file from scratch.
    At first you can use newer ffmpeg compiled to run on XP - at least i would give a chance to newer version https://ffmpeg.zeranoe.com/forum/viewtopic.php?p=10000#p10000

    Secondly not sure if ffmpeg configuration is most optimal - but this is not main issue for you.

    Are you able to provide samples - source before and after conversion (after with errors)? If not then perhaps you can add "-report" and upload log created by ffmpeg - then we can see if there any complains (perhaps issue is somewhere else).

    I'm not command-line guru (some guys on forum are way more advanced than i) however seem there are 4 parameters passed to script %1 %2 are assume are foldernames but variable gg use %3 parameter and also seem there %4 - "-report" may help

    btw this is wrong forum - ffmpegx is explicitly Macintosh (Apple) ffmpeg app version. It is not highly popular - perhaps you should ask moderator to move this thread to more appropriate .
    Quote Quote  
  3. Mod Neophyte Super Moderator redwudz's Avatar
    Join Date
    Sep 2002
    Location
    USA
    Search Comp PM
    I'll move the thread to Newbie/General forum.
    And welcome to our forums.

    Moderator redwudz
    Quote Quote  
  4. I'm sorry I posted in the wrong forum section. I simply saw "ffmpeg" and thought it was the ideal place. I did not know that ffmpegX was its own thing.

    I can provide two samples, although not of the same time. One of the .avi and one of the .dat files.

    .Avi
    https://drive.google.com/file/d/1UErtffEX-gp02Va7MimgJbUlrNF5-8_V/view?usp=sharing
    .dat
    https://drive.google.com/file/d/1uESZIymH17sYJmdu-2BghElDK1O4x6P4/view?usp=sharing

    (I just noticed that when the google drive's video preview plays the .dat file, the video is corrupted in a similar manner as in the end product, which confuses me).
    Quote Quote  
  5. I dug around the batch file and I am afraid that the conversation process is a bit more complicated than I thought. Virtualdub is invovled (it is found among the folders).


    I will now post the complete batch file. Note that "576p.bat " is posted above.

    Translations: "töröljük a nem szükséges videókat" = "delete the unnecessary video files"


    rem @echo off
    set konyvtar=C:\RecData5319ebd4cff4454597aad4d0c111490 7\
    set kam1=0018ae3f302400
    set kam1_dat=@
    set hova=c:\xampp\htdocs\kamera\vid\honnan
    set tid=
    set kam1_time=0

    call torol.bat %konyvtar%%kam1%
    rem töröljük a nem szükséges videókat
    for /f "skip=3" %%G IN ('dir /b /a-d /o-d "%konyvtar%%kam1%"') DO del %konyvtar%%kam1%\%%G

    for /F "tokens=2 delims= " %%A IN ('tasklist /FI ^"imagename eq cmd.exe^" /NH ') DO (
    set tid=%%A
    goto again
    )

    rem timeout /t 30
    :again
    set /A cou=1
    :loop
    echo %cou%
    ping -4 -n 6 "" > nul
    rem timeout /t %kam1_time%
    del /F %hova%\*.dat
    del /F c:\xampp\htdocs\kamera\vid\hova\*.avi
    set line=
    for /f "skip=1" %%G IN ('dir /b /a-d /o-d "%konyvtar%%kam1%"') DO if not defined line set "line=%%G"
    rem pause
    if %kam1_dat% neq %line% (
    set "kam1_dat=%line%"
    start konvert-576p.bat %konyvtar%%kam1%\%line% %hova% %line% kam1
    set kam1_time=6
    )
    timeout /t 30
    if %cou%==300 (
    call taskkill /F /IM cmd.exe /FI ^"PID ne %tid%^" /T
    timeout /t 12
    for /R "c:\xampp\htdocs\kamera\vid\VirtualDub\" %%I IN ("vdsub.zip") DO (
    "c:\Program Files\7-Zip\7z.exe" x -y -o"%%~dpI" "%%~fI"
    )
    for /f "skip=3" %%G IN ('dir /b /a-d /o-d "%konyvtar%%kam1%"') DO del %konyvtar%%kam1%\%%G
    goto again
    ) ELSE (
    set /A cou+=1
    goto loop
    )
    timeout /t 30
    torol.bat
    SETLOCAL ENABLEDELAYEDEXPANSION
    set line=
    for /f %%G IN ('dir /b /a-d /o-d "%1"') DO (
    set "line=%%G"
    FOR %%A IN (%1\!line!) DO (
    set "size=%%~zA"
    if !size! LSS 40000000 (
    del %1\!line!
    )
    )
    )
    ENDLOCAL
    Quote Quote  
  6. Originally Posted by pandy View Post
    Originally Posted by Vidikon View Post
    [snip]
    At first you can use newer ffmpeg compiled to run on XP - at least i would give a chance to newer version https://ffmpeg.zeranoe.com/forum/viewtopic.php?p=10000#p10000

    Secondly not sure if ffmpeg configuration is most optimal - but this is not main issue for you.

    Are you able to provide samples - source before and after conversion (after with errors)? If not then perhaps you can add "-report" and upload log created by ffmpeg - then we can see if there any complains (perhaps issue is somewhere else).

    I'm not command-line guru (some guys on forum are way more advanced than i) however seem there are 4 parameters passed to script %1 %2 are assume are foldernames but variable gg use %3 parameter and also seem there %4 - "-report" may help

    btw this is wrong forum - ffmpegx is explicitly Macintosh (Apple) ffmpeg app version. It is not highly popular - perhaps you should ask moderator to move this thread to more appropriate .
    I have been experimenting with this and it turns otu that the heart of the problem lies with the original file. I noticed when I accidentally played it back when uploading it on google drive, the browser's webplayer giving the same corruption as before. VLC of course plays it back fine.

    So it is not that the conversion process that's messing up the file, it's something that the conversation doesn't do.

    My theory is that the converted files lack some kind of metadata that allows proper playback. VLC, being very robust, manages to find its way to give proper playback without this metadata (perhaps some sort of codec issue). That it lacks such metadata makes some sense, as these are files copied out from the NVR software's folders.

    The question I want to figure out is how to force new metadata unto converted files. This is a problem my predecessor tried to get around by using virtualdub. I may end up just writing a new batch file and method.

    Oh and I tried having the XP server machine with a newer ffmpeg that you linked. It does not solve the problem.
    Quote Quote  
  7. I have made progress.

    I managed to find out how to get ffmpeg to convert the .dat files correctly. All I had to do was:

    ffmpeg -f h264 source.dat output.mp4
    When I add that (specifying the origin file's codec), the resulting video is free of the corruption. I tested this with the same version of ffmpeg that the server machine uses.

    I have tried to add it to the batch file, it just doesn't run and the resulting file that should appear, doesn't.
    Quote Quote  
  8. I decided to add an -report to the end of the command.

    ffmpeg started on 2018-08-22 at 13:09:22
    Report written to "ffmpeg-20180822-130922.log"
    Command line:
    "vid\\ff\\bin\\ffmpeg" -y -f h264 -t 00:01:00 -ss 00:00:15 -r 10 -i "vid\\honnan\\20180822130247.dat" -s 1280x720 -b:v 4M -preset ultrafast "c:\\xampp\\htdocs\\kamera\\vid\\honnan\\kam1. mp4" -report
    ffmpeg version N-63128-g0aac9b7 Copyright (c) 2000-2014 the FFmpeg developers
    built on May 13 2014 22:01:31 with gcc 4.8.2 (GCC)
    configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-avisynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enable-iconv --enable-libass --enable-libbluray --enable-libcaca --enable-libfreetype --enable-libgme --enable-libgsm --enable-libilbc --enable-libmodplug --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-librtmp --enable-libschroedinger --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libtwolame --enable-libvidstab --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libx264 --enable-libx265 --enable-libxavs --enable-libxvid --enable-decklink --enable-zlib
    libavutil 52. 83.100 / 52. 83.100
    libavcodec 55. 61.101 / 55. 61.101
    libavformat 55. 37.102 / 55. 37.102
    libavdevice 55. 13.101 / 55. 13.101
    libavfilter 4. 5.100 / 4. 5.100
    libswscale 2. 6.100 / 2. 6.100
    libswresample 0. 18.100 / 0. 18.100
    libpostproc 52. 3.100 / 52. 3.100
    Splitting the commandline.
    Reading option '-y' ... matched as option 'y' (overwrite output files) with argument '1'.
    Reading option '-f' ... matched as option 'f' (force format) with argument 'h264'.
    Reading option '-t' ... matched as option 't' (record or transcode "duration" seconds of audio/video) with argument '00:01:00'.
    Reading option '-ss' ... matched as option 'ss' (set the start time offset) with argument '00:00:15'.
    Reading option '-r' ... matched as option 'r' (set frame rate (Hz value, fraction or abbreviation)) with argument '10'.
    Reading option '-i' ... matched as input file with argument 'vid\honnan\20180822130247.dat'.
    Reading option '-s' ... matched as option 's' (set frame size (WxH or abbreviation)) with argument '1280x720'.
    Reading option '-b:v' ... matched as option 'b' (video bitrate (please use -b:v)) with argument '4M'.
    Reading option '-preset' ... matched as AVOption 'preset' with argument 'ultrafast'.
    Reading option 'c:\xampp\htdocs\kamera\vid\honnan\kam1.mp4' ... matched as output file.
    Reading option '-report' ... matched as option 'report' (generate a report) with argument '1'.
    Finished splitting the commandline.
    Parsing a group of options: global .
    Applying option y (overwrite output files) with argument 1.
    Applying option report (generate a report) with argument 1.
    Successfully parsed a group of options.
    Parsing a group of options: input file vid\honnan\20180822130247.dat.
    Applying option f (force format) with argument h264.
    Applying option t (record or transcode "duration" seconds of audio/video) with argument 00:01:00.
    Applying option ss (set the start time offset) with argument 00:00:15.
    Applying option r (set frame rate (Hz value, fraction or abbreviation)) with argument 10.
    Successfully parsed a group of options.
    Opening an input file: vid\honnan\20180822130247.dat.
    [h264 @ 030201a0] Before avformat_find_stream_info() pos: 0 bytes read:32768 seeks:0
    [h264 @ 03020ce0] unknown SEI type 229
    [h264 @ 03020ce0] Unknown NAL code: 0 (23 bits)
    [h264 @ 03020ce0] Unknown NAL code: 0 (45 bits)
    [h264 @ 03020ce0] Unknown NAL code: 0 (23 bits)
    [h264 @ 03020ce0] unknown SEI type 229
    [h264 @ 03020ce0] unknown SEI type 229
    [h264 @ 030201a0] max_analyze_duration 5000000 reached at 5000000 microseconds
    [h264 @ 030201a0] After avformat_find_stream_info() pos: 832512 bytes read:851968 seeks:0 frames:52
    [NULL @ 03020ce0] Unknown NAL code: 0 (23 bits)
    [NULL @ 03020ce0] Unknown NAL code: 0 (45 bits)
    [NULL @ 03020ce0] Unknown NAL code: 0 (23 bits)
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] FMO not supported
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] sps_id 5 out of range
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] unknown SEI type 229
    [NULL @ 03020ce0] illegal POC type 32
    [NULL @ 03020ce0] non-existing PPS 15 referenced
    vid\honnan\20180822130247.dat: could not seek to position 15.000
    Input #0, h264, from 'vid\honnan\20180822130247.dat':
    Duration: N/A, bitrate: N/A
    Stream #0:0, 52, 1/1200000: Video: h264 (Baseline), yuv420p, 1280x720, 10 fps, 10 tbr, 1200k tbn, 20 tbc
    Successfully opened the file.
    Parsing a group of options: output file c:\xampp\htdocs\kamera\vid\honnan\kam1.mp4.
    Applying option s (set frame size (WxH or abbreviation)) with argument 1280x720.
    Applying option b:v (video bitrate (please use -b:v)) with argument 4M.
    Successfully parsed a group of options.
    Opening an output file: c:\xampp\htdocs\kamera\vid\honnan\kam1.mp4.
    Successfully opened the file.
    detected 1 logical cores
    [graph 0 input from stream 0:0 @ 0301fc20] Setting 'video_size' to value '1280x720'
    [graph 0 input from stream 0:0 @ 0301fc20] Setting 'pix_fmt' to value '0'
    [graph 0 input from stream 0:0 @ 0301fc20] Setting 'time_base' to value '1/10'
    [graph 0 input from stream 0:0 @ 0301fc20] Setting 'pixel_aspect' to value '0/1'
    [graph 0 input from stream 0:0 @ 0301fc20] Setting 'sws_param' to value 'flags=2'
    [graph 0 input from stream 0:0 @ 0301fc20] Setting 'frame_rate' to value '10/1'
    [graph 0 input from stream 0:0 @ 0301fc20] w:1280 h:720 pixfmt:yuv420p tb:1/10 fr:10/1 sar:0/1 sws_param:flags=2
    [force CFR for input from stream 0:0 @ 0301fe60] Setting 'expr' to value 'N'
    [scaler for output stream 0:0 @ 03f3fd80] Setting 'w' to value '1280'
    [scaler for output stream 0:0 @ 03f3fd80] Setting 'h' to value '720'
    [scaler for output stream 0:0 @ 03f3fd80] Setting 'flags' to value '0x4'
    [scaler for output stream 0:0 @ 03f3fd80] w:1280 h:720 flags:'0x4' interl:0
    [format @ 030221e0] compat: called with args=[yuv420p|yuvj420p|yuv422p|yuvj422p|yuv444p|yuvj444p |nv12|nv16]
    [format @ 030221e0] Setting 'pix_fmts' to value 'yuv420p|yuvj420p|yuv422p|yuvj422p|yuv444p|yuvj444 p|nv12|nv16'
    [AVFilterGraph @ 0301f840] query_formats: 7 queried, 6 merged, 0 already done, 0 delayed
    [graph 0 input from stream 0:0 @ 0301fc20] TB:0.100000 FRAME_RATE:10.000000 SAMPLE_RATE:nan
    [scaler for output stream 0:0 @ 03f3fd80] w:1280 h:720 fmt:yuv420p sar:0/1 -> w:1280 h:720 fmt:yuv420p sar:0/1 flags:0x4
    [libx264 @ 03b3f840] using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2
    [libx264 @ 03b3f840] profile Constrained Baseline, level 3.1
    [libx264 @ 03b3f840] 264 - core 142 r2431 ac76440 - H.264/MPEG-4 AVC codec - Copyleft 2003-2014 - http://www.videolan.org/x264.html - options: cabac=0 ref=1 deblock=0:0:0 analyse=0:0 me=dia subme=0 psy=1 psy_rd=1.00:0.00 mixed_ref=0 me_range=16 chroma_me=1 trellis=0 8x8dct=0 cqm=0 deadzone=21,11 fast_pskip=1 chroma_qp_offset=0 threads=1 lookahead_threads=1 sliced_threads=0 nr=0 decimate=1 interlaced=0 bluray_compat=0 constrained_intra=0 bframes=0 weightp=0 keyint=250 keyint_min=10 scenecut=0 intra_refresh=0 rc=abr mbtree=0 bitrate=4000 ratetol=1.0 qcomp=0.60 qpmin=0 qpmax=69 qpstep=4 ip_ratio=1.40 aq=0
    [h264 @ 03020ce0] Unknown NAL code: 0 (23 bits)
    [h264 @ 03020ce0] Unknown NAL code: 0 (45 bits)
    [h264 @ 03020ce0] Unknown NAL code: 0 (23 bits)
    Output #0, mp4, to 'c:\xampp\htdocs\kamera\vid\honnan\kam1.mp4':
    Metadata:
    encoder : Lavf55.37.102
    Stream #0:0, 0, 1/10240: Video: h264 (libx264) ([33][0][0][0] / 0x0021), yuv420p, 1280x720, q=-1--1, 4000 kb/s, 10240 tbn, 10 tbc
    Stream mapping:
    Stream #0:0 -> #0:0 (h264 -> libx264)
    Press [q] to stop, [?] for help
    [output stream 0:0 @ 03021ec0] EOF on sink link output stream 0:0:default.
    No more output streams to write to, finishing.
    frame= 0 fps=0.0 q=0.0 Lsize= 0kB time=00:00:00.00 bitrate=N/A

    video:0kB audio:0kB subtitle:0kB other streams:0kB global headers:0kB muxing overhead: unknown
    Input file #0 (vid\honnan\20180822130247.dat):
    Input stream #0:0 (video): 0 packets read (0 bytes); 0 frames decoded;
    Total: 0 packets (0 bytes) demuxed
    Output file #0 (c:\xampp\htdocs\kamera\vid\honnan\kam1.mp4):
    Output stream #0:0 (video): 0 frames encoded; 0 packets muxed (0 bytes);
    Total: 0 packets (0 bytes) muxed
    [libx264 @ 03b3f840] final ratefactor: 10.75
    0 frames successfully decoded, 0 decoding errors
    [AVIOContext @ 03b3fec0] Statistics: 4 seeks, 4 writeouts
    [AVIOContext @ 03020940] Statistics: 53342356 bytes read, 1 seeks
    What is going wrong?
    Last edited by Vidikon; 22nd Aug 2018 at 07:13.
    Quote Quote  



Similar Threads