VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or try DVDFab and copy, convert or make Blu-rays and DVDs! :)
+ Reply to Thread
Results 1 to 10 of 10
Thread
  1. Member TeNSoR's Avatar
    Join Date
    Mar 2014
    Location
    Hungary, Debrecen
    Search PM
    Hi!

    I try to multiplexing MP4 video with Opus audio using (MTVToolnix) but every time I get muted video, any suggestion?
    Quote Quote  
  2. Member TeNSoR's Avatar
    Join Date
    Mar 2014
    Location
    Hungary, Debrecen
    Search PM
    Originally Posted by sneaker View Post
    Ok, thanks!
    Quote Quote  
  3. Dinosaur Supervisor KarMa's Avatar
    Join Date
    Jul 2015
    Location
    US
    Search Comp PM
    Maybe your player does not support Opus. You also mean MKV not MP4 right?
    Quote Quote  
  4. Member Bernix's Avatar
    Join Date
    Apr 2016
    Location
    Europe
    Search Comp PM
    I think it is most likely videotrack from MP4 container + opus audio resulting in MKV.
    Probably wrongly added, appended or so. But I think TeNSoR is experience enough to make such mistake.


    Bernix
    Quote Quote  
  5. Member TeNSoR's Avatar
    Join Date
    Mar 2014
    Location
    Hungary, Debrecen
    Search PM
    Originally Posted by KarMa View Post
    Maybe your player does not support Opus. You also mean MKV not MP4 right?
    I played it on MPC- HC, Potplayer, VLC, nothing worked, also I tried mkv and mp4 the same muted audio.
    Quote Quote  
  6. Member TeNSoR's Avatar
    Join Date
    Mar 2014
    Location
    Hungary, Debrecen
    Search PM
    Originally Posted by Bernix View Post
    I think it is most likely videotrack from MP4 container + opus audio resulting in MKV.
    Probably wrongly added, appended or so. But I think TeNSoR is experience enough to make such mistake.


    Bernix
    I don't know, Bernix, just I converted my AC3 into wav then I converted it into Opus using Foobar2000.
    Quote Quote  
  7. Maybe I misunderstood. I thought you had Opus audio in mp4 container. If I mux such an mp4 file using mkvmerge it doesn't play for me, i.e. it is possibly an mkvmerge bug. Then again I created the mp4 with ffmpeg and ffmpeg says Opus in mp4 is experimental to begin with.

    I don't have any problems feeding Opus NOT contained in mp4 into mkvmerge. So avoid creating such files as intermediate files if you want mkv end result. But either way the problem with Opus in mp4 might be worth reporting to mkvmerge author.
    Quote Quote  
  8. Member TeNSoR's Avatar
    Join Date
    Mar 2014
    Location
    Hungary, Debrecen
    Search PM
    Originally Posted by sneaker View Post
    Maybe I misunderstood. I thought you had Opus audio in mp4 container. If I mux such an mp4 file using mkvmerge it doesn't play for me, i.e. it is possibly an mkvmerge bug. Then again I created the mp4 with ffmpeg and ffmpeg says Opus in mp4 is experimental to begin with.

    I don't have any problems feeding Opus NOT contained in mp4 into mkvmerge. So avoid creating such files as intermediate files if you want mkv end result. But either way the problem with Opus in mp4 might be worth reporting to mkvmerge author.
    No problem! sneaker! thanks for your reply,Actually, I did another qaa audio and it works fine now but anyway, I will report about this bug in mkvmerge.
    Quote Quote  
  9. use ffprobe to analyse stream
    Quote Quote  



Similar Threads