VideoHelp Forum

Try NordVPN to access Netflix or other streaming services from any country and also surf safe!
+ Reply to Thread
Results 1 to 3 of 3
  1. Member
    Join Date
    May 2004
    New Zealand
    Search Comp PM
    I have purchased two chromecast ultras. They are both set up with a wired connection, one in the bedroom and the other in the living room.

    The first one (living room) set up fine, the setup process completed, and I am able to cast to it as expected. No issues there.

    The second one is driving me nuts. Connected to network and the setup process went without a hitch, exactly the same as for the first one. Launching the google home application it shows up as a device on the network, with the status "ready to cast", just like the first one. It is also displaying backdrop art images and the correct time etc, so it's clearly connected and seeing the network.

    However, no matter what I do, I can't seem to make it show up as a device when I try to cast (tried on two phones, one tablet, and a laptop). In all instances, the living room chromecast shows up as a cast destination, but the bedroom one does not.

    I have done five reboots, and three factory resets. I have tried setting it up using WiFi instead of wired. I have changed its name. The router has been rebooted twice. And I have verified that it is updated and on the same firmware as the living room one that runs fine. All to no avail. Same result every time, and I am starting to climb the walls.

    Any thoughts/help appreciated.
    Quote Quote  
  2. Dinosaur Supervisor KarMa's Avatar
    Join Date
    Jul 2015
    Search Comp PM
    Maybe turn off the first working one, so that the second is the only one operating.
    Quote Quote  

Similar Threads