VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or try DVDFab DRM and remove iTunes movie & music protection! :)
+ Reply to Thread
Results 1 to 17 of 17
Thread
  1. Member
    Join Date
    May 2016
    Location
    United States
    Search Comp PM
    Intro: I followed this video to install FFMPEG
    https://www.youtube.com/watch?v=xcdTIDHm4KM


    Side Note: I followed the instructions in this video to create a .bat file. All I have to do is have copy this .bat file into the folder with videos that I want to convert, double click on the .bat file and it'll start the ffmpeg cmd conversion. Very simple.
    https://www.youtube.com/watch?v=696ACV7gBG8&t=42s



    The issue:
    Even though I've read that NLmeans is slow, I wanted to check it out because of the results seen here. Even if I don't get the same results, I want to give NLmeans a test run:
    http://www.dirk-farin.net/projects/nlmeans/index.html

    The guy in the link above told me to go to github to retrieve something, but I really have no clue what to do with Github. Just looks like mumbo jumbo. Don't know what to do.
    https://github.com/farindk/ffmpeg


    I also downloaded a NLmeans.dll from this thread, but I don't know where to put the .dll file. Don't even know if it is the proper .dll file either. NLMeansCL_netautoload.dll
    https://forum.doom9.org/showthread.php?t=158925


    This is the code/command. I'm not sure how to get (-vf nlmeans) to work. Doesn't work.
    and I get the error: No such filter "NLmeans" Error opening filters!

    if not exist Convertedfiles md Convertedfiles
    for %%a in ("*.mp4") do ffmpeg -re -y -i "%%a" -c:v libx264 -preset veryslow -tune animation -crf 24 -vf nlmeans -acodec copy "Convertedfiles\%%~na.mp4"
    pause



    I even tried it with the command window and simply typed the command line below and still doesn't work, same error:

    ffmpeg -i input.avi -vf nlmeans output.avi



    The following denoise filter (-vf hqdn3d) works though.
    if not exist Convertedfiles md Convertedfiles
    for %%a in ("*.mp4") do ffmpeg -re -y -i "%%a" -c:v libx264 -preset veryslow -tune animation -crf 24 -vf hqdn3d -acodec copy "Convertedfiles\%%~na.mp4"
    pause
    Quote Quote  
  2. github is only if you want to compile from the source (build it yourself, takes a long time, even with autobuild scripts)

    You can download precompiled windows binaries from zeranoe . nlmeans is included. There is nothing to install, it's a single "portable" exe if you download a "static" build
    https://ffmpeg.zeranoe.com/builds/
    Quote Quote  
  3. Member
    Join Date
    May 2016
    Location
    United States
    Search Comp PM
    Originally Posted by poisondeathray View Post
    github is only if you want to compile from the source (build it yourself, takes a long time, even with autobuild scripts)

    You can download precompiled windows binaries from zeranoe . nlmeans is included. There is nothing to install, it's a single "portable" exe if you download a "static" build
    https://ffmpeg.zeranoe.com/builds/

    Unfortunately still didn't work. Still getting the same "No such filter: nlmeans" Error opening filters.

    I downloaded the static version. The blue tab (download build).
    https://ffmpeg.zeranoe.com/builds/

    I followed the installation video in my very first post.
    The new ffmpeg download (blue tab) is about 181mb (44 files)
    The old ffmpeg download that I had is about 113mb (44 files)
    Quote Quote  
  4. Member
    Join Date
    Mar 2008
    Location
    United States
    Search Comp PM
    You can try the version here at videohelp.com, I just tried it and the filter is there
    https://www.videohelp.com/download/ffmpeg-3.4.2-win32-static.zip
    Quote Quote  
  5. Member
    Join Date
    May 2016
    Location
    United States
    Search Comp PM
    Originally Posted by davexnet View Post
    You can try the version here at videohelp.com, I just tried it and the filter is there
    https://www.videohelp.com/download/ffmpeg-3.4.2-win32-static.zip
    Maybe I'm not installing or replacing or doing something wrong. I basically just copied and pasted the "stuff' from the zips files into the folder just like the video in my first post instructed. 1st is the original, 2nd is the version poisonsdeathray suggest, and then now what you see is the 32bit version you suggested. For some reason, I still can't get it to work ...

    ffmpeg -i video.mp4 -nlmeans output.mp4


    Note: I already have ffmpeg command window encoding some files (does this make a difference). Should I stop the encoding process on those?


    Click image for larger version

Name:	ffmpeg help etc a.jpg
Views:	52
Size:	112.8 KB
ID:	45331Click image for larger version

Name:	ffmpeg help etc b.jpg
Views:	24
Size:	120.1 KB
ID:	45332
    Quote Quote  
  6. Originally Posted by strawberryshortcake View Post

    ffmpeg -i video.mp4 -nlmeans output.mp4
    You would need to fill in the rest of the command line . And it should be "-vf nlmeans" , not -nlmeans

    e.g

    Code:
    ffmpeg -i video.mp4 -vf nlmeans -c:v libx264 -crf 18 -c:a copy output.mp4
    Quote Quote  
  7. Member
    Join Date
    May 2016
    Location
    United States
    Search Comp PM
    Originally Posted by poisondeathray View Post
    Originally Posted by strawberryshortcake View Post

    ffmpeg -i video.mp4 -nlmeans output.mp4
    You would need to fill in the rest of the command line . And it should be "-vf nlmeans" , not -nlmeans

    e.g

    Code:
    ffmpeg -i video.mp4 -vf nlmeans -c:v libx264 -crf 18 -c:a copy output.mp4
    Unfortunately, still didn't work.

    Oops, I typed it incorrectly in my above post. I did try it again, I copied and pasted the version you recommended as well as the 3rd version (32bit) into the folder like how the guy did it in the installing tutorial. And filled the command line with the corresponding video title, and unfortunately it still didn't work.


    [AVFilterGraph @ 02d5f140] No such filter: 'nlmeans' Error opening filters
    Quote Quote  
  8. It's working here.

    Post the full console output . In the command line box, you an right click select all, then right click will copy . Paste the text

    Your environment variable might be referring to a ffmpeg version that does not have nlmeans .

    Start over. Delete the environment variable. Place a copy of ffmpeg.exe into the same folder as the video to be converted. Or specify the correct path precisely of the ffmpeg.exe executable that works . You need to make sure you can get 1 working before you attempt to batch or set your environment variable
    Quote Quote  
  9. Member
    Join Date
    May 2016
    Location
    United States
    Search Comp PM
    Originally Posted by poisondeathray View Post
    It's working here.

    Post the full console output . In the command line box, you an right click select all, then right click will copy . Paste the text

    Your environment variable might be referring to a ffmpeg version that does not have nlmeans .

    Start over. Delete the environment variable. Place a copy of ffmpeg.exe into the same folder as the video to be converted. Or specify the correct path precisely of the ffmpeg.exe executable that works . You need to make sure you can get 1 working before you attempt to batch or set your environment variable

    Code:
    J:\=== Frasier\Frasier VOB all combined\---done keep original vob>
    J:\=== Frasier\Frasier VOB all combined\---done keep original vob>ffmpeg -i ABB.
    mp4 -vf nlmeans -c:v libx264 -crf 18 -c:a copy AAAoutput.mp4
    ffmpeg version 2.8.4 Copyright (c) 2000-2015 the FFmpeg developers
      built with gcc 5.2.0 (GCC)
      configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-av
    isynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enab
    le-iconv --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --
    enable-libdcadec --enable-libfreetype --enable-libgme --enable-libgsm --enable-l
    ibilbc --enable-libmodplug --enable-libmp3lame --enable-libopencore-amrnb --enab
    le-libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-librtmp --en
    able-libschroedinger --enable-libsoxr --enable-libspeex --enable-libtheora --ena
    ble-libtwolame --enable-libvidstab --enable-libvo-aacenc --enable-libvo-amrwbenc
     --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enabl
    e-libx264 --enable-libx265 --enable-libxavs --enable-libxvid --enable-lzma --ena
    ble-decklink --enable-zlib
      libavutil      54. 31.100 / 54. 31.100
      libavcodec     56. 60.100 / 56. 60.100
      libavformat    56. 40.101 / 56. 40.101
      libavdevice    56.  4.100 / 56.  4.100
      libavfilter     5. 40.101 /  5. 40.101
      libswscale      3.  1.101 /  3.  1.101
      libswresample   1.  2.101 /  1.  2.101
      libpostproc    53.  3.100 / 53.  3.100
    Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'ABB.mp4':
      Metadata:
        major_brand     : isom
        minor_version   : 512
        compatible_brands: isomiso2mp41
        encoder         : Lavf56.40.101
      Duration: 00:08:53.67, start: 0.000000, bitrate: 6884 kb/s
        Stream #0:0(und): Video: mpeg2video (Main) (mp4v / 0x7634706D), yuv420p(tv,
    smpte170m), 720x480 [SAR 8:9 DAR 4:3], Closed Captions, 6689 kb/s, 29.97 fps, 29
    .97 tbr, 90k tbn, 59.94 tbc (default)
        Metadata:
          handler_name    : VideoHandler
        Stream #0:1(und): Audio: ac3 (ac-3 / 0x332D6361), 48000 Hz, stereo, fltp, 19
    2 kb/s (default)
        Metadata:
          handler_name    : SoundHandler
        Side data:
          audio service type: main
    File 'AAAoutput.mp4' already exists. Overwrite ? [y/N] y
    [AVFilterGraph @ 04678c80] No such filter: 'nlmeans'
    Error opening filters!
    
    J:\=== Frasier\Frasier VOB all combined\---done keep original vob>^A
    Quote Quote  
  10. Originally Posted by strawberryshortcake View Post



    ffmpeg version 2.8.4 Copyright (c) 2000-2015 the FFmpeg developers
    built with gcc 5.2.0 (GCC)
    Look at the version and date . A recent binary should say 2000-2018 . So you are using and calling the older one

    nlmeans did not make it into ffmpeg until much later


    You can explicitly call a specific ffmpeg version by specifying the path for ffmpeg.exe

    eg , if ffmpeg.exe that you want to use was located in C:\folder\
    Code:
    "C:\folder\ffmpeg.exe" -i video.mp4 -vf nlmeans -c:v libx264 -crf 18 -c:a copy output.mp4
    Quote Quote  
  11. Member
    Join Date
    May 2016
    Location
    United States
    Search Comp PM
    So the following looks like it works, but it required me copying and pasting the ffmpeg.exe into the folder with all the videos. Then I deleted ffmpeg.exe from the same folder, ran command and it didn't work.

    Is there a way that I don't have to have ffmpeg.exe in the same folder as the videos because I following the directions in this video got ffmpeg always working.

    I tried deleting the environmental variable, etc. etc. already and redoing the steps in the video with the ffmpeg that you suggested, and still not quite working. In order to get it nlmeans to work, i need to copy and paste it into the folder with all the videos.

    https://www.youtube.com/watch?v=xcdTIDHm4KM

    This is where the original ffmpeg.exe application is located.
    Click image for larger version

Name:	ffmpeg location.png
Views:	349
Size:	86.2 KB
ID:	45337

    I also have this going so I figured this would be enough.
    Click image for larger version

Name:	ffmpeg help etc b.jpg
Views:	363
Size:	120.1 KB
ID:	45338


    Code:
    J:\=== Frasier\Frasier VOB all combined\---done keep original vob\test 2>ffmpeg
    -i AFRA.mp4 -vf nlmeans DD.mp4
    ffmpeg version N-90810-g153e920892 Copyright (c) 2000-2018 the FFmpeg developers
    
      built with gcc 7.3.0 (GCC)
      configuration: --enable-gpl --enable-version3 --enable-sdl2 --enable-bzlib --e
    nable-fontconfig --enable-gnutls --enable-iconv --enable-libass --enable-libblur
    ay --enable-libfreetype --enable-libmp3lame --enable-libopencore-amrnb --enable-
    libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-libshine --enab
    le-libsnappy --enable-libsoxr --enable-libtheora --enable-libtwolame --enable-li
    bvpx --enable-libwavpack --enable-libwebp --enable-libx264 --enable-libx265 --en
    able-libxml2 --enable-libzimg --enable-lzma --enable-zlib --enable-gmp --enable-
    libvidstab --enable-libvorbis --enable-libvo-amrwbenc --enable-libmysofa --enabl
    e-libspeex --enable-libxvid --enable-libaom --enable-libmfx --enable-amf --enabl
    e-ffnvcodec --enable-cuvid --enable-d3d11va --enable-nvenc --enable-nvdec --enab
    le-dxva2 --enable-avisynth
      libavutil      56. 15.100 / 56. 15.100
      libavcodec     58. 19.100 / 58. 19.100
      libavformat    58. 13.100 / 58. 13.100
      libavdevice    58.  4.100 / 58.  4.100
      libavfilter     7. 19.100 /  7. 19.100
      libswscale      5.  2.100 /  5.  2.100
      libswresample   3.  2.100 /  3.  2.100
      libpostproc    55.  2.100 / 55.  2.100
    Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'AFRA.mp4':
      Metadata:
        major_brand     : isom
        minor_version   : 512
        compatible_brands: isomiso2mp41
        encoder         : Lavf56.40.101
      Duration: 00:05:47.35, start: 0.000000, bitrate: 7000 kb/s
        Stream #0:0(und): Video: mpeg2video (Main) (mp4v / 0x7634706D), yuv420p(tv,
    smpte170m), 720x480 [SAR 8:9 DAR 4:3], Closed Captions, 6805 kb/s, 29.97 fps, 29
    .97 tbr, 90k tbn, 59.94 tbc (default)
        Metadata:
          handler_name    : VideoHandler
        Stream #0:1(und): Audio: ac3 (ac-3 / 0x332D6361), 48000 Hz, stereo, fltp, 19
    2 kb/s (default)
        Metadata:
          handler_name    : SoundHandler
        Side data:
          audio service type: main
    Stream mapping:
      Stream #0:0 -> #0:0 (mpeg2video (native) -> h264 (libx264))
      Stream #0:1 -> #0:1 (ac3 (native) -> aac (native))
    Press [q] to stop, [?] for help
    [Parsed_nlmeans_0 @ 0000000002d8fe80] Research window: 15x15 / 15x15, patch size
    : 7x7 / 7x7
    [libx264 @ 0000000000539e80] using SAR=8/9
    [libx264 @ 0000000000539e80] using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2
    AVX
    [libx264 @ 0000000000539e80] profile High, level 3.0
    [libx264 @ 0000000000539e80] 264 - core 155 r2901 7d0ff22 - H.264/MPEG-4 AVC cod
    ec - Copyleft 2003-2018 - http://www.videolan.org/x264.html - options: cabac=1 r
    ef=3 deblock=1:0:0 analyse=0x3:0x113 me=hex subme=7 psy=1 psy_rd=1.00:0.00 mixed
    _ref=1 me_range=16 chroma_me=1 trellis=1 8x8dct=1 cqm=0 deadzone=21,11 fast_pski
    p=1 chroma_qp_offset=-2 threads=6 lookahead_threads=1 sliced_threads=0 nr=0 deci
    mate=1 interlaced=0 bluray_compat=0 constrained_intra=0 bframes=3 b_pyramid=2 b_
    adapt=1 b_bias=0 direct=1 weightb=1 open_gop=0 weightp=2 keyint=250 keyint_min=2
    5 scenecut=40 intra_refresh=0 rc_lookahead=40 rc=crf mbtree=1 crf=23.0 qcomp=0.6
    0 qpmin=0 qpmax=69 qpstep=4 ip_ratio=1.40 aq=1:1.00
    Output #0, mp4, to 'DD.mp4':
      Metadata:
        major_brand     : isom
        minor_version   : 512
        compatible_brands: isomiso2mp41
        encoder         : Lavf58.13.100
        Stream #0:0(und): Video: h264 (libx264) (avc1 / 0x31637661), yuv420p(top cod
    ed first (swapped)), 720x480 [SAR 8:9 DAR 4:3], q=-1--1, 29.97 fps, 30k tbn, 29.
    97 tbc (default)
        Metadata:
          handler_name    : VideoHandler
          encoder         : Lavc58.19.100 libx264
        Side data:
          cpb: bitrate max/min/avg: 0/0/0 buffer size: 0 vbv_delay: -1
        Stream #0:1(und): Audio: aac (LC) (mp4a / 0x6134706D), 48000 Hz, stereo, flt
    p, 128 kb/s (default)
        Metadata:
          handler_name    : SoundHandler
          encoder         : Lavc58.19.100 aac
        Side data:
          audio service type: main
    frame=    1 fps=0.0 q=0.0 size=       0kB time=00:00:00.00 bitrate=N/A speed=
    frame=    2 fps=1.6 q=0.0 size=       0kB time=00:00:00.02 bitrate=  18.0kbits/s
    frame=    3 fps=1.7 q=0.0 size=       0kB time=00:00:00.04 bitrate=   9.0kbits/s
    frame=    4 fps=1.7 q=0.0 size=       0kB time=00:00:00.08 bitrate=   4.5kbits/s
    frame=    5 fps=1.7 q=0.0 size=       0kB time=00:00:00.10 bitrate=   3.6kbits/s
    frame=    6 fps=1.8 q=0.0 size=       0kB time=00:00:00.14 bitrate=   2.6kbits/s
    frame=    7 fps=1.8 q=0.0 size=       0kB time=00:00:00.17 bitrate=   2.2kbits/s
    frame=    8 fps=1.6 q=-1.0 Lsize=       4kB time=00:00:00.21 bitrate= 142.1kbits
    /s speed=0.0418x
    video:2kB audio:0kB subtitle:0kB other streams:0kB global headers:0kB muxing ove
    rhead: 77.056076%
    [libx264 @ 0000000000539e80] frame I:1     Avg QP:17.20  size:   491
    [libx264 @ 0000000000539e80] frame P:2     Avg QP:18.45  size:    80
    [libx264 @ 0000000000539e80] frame B:5     Avg QP:18.19  size:    88
    [libx264 @ 0000000000539e80] consecutive B-frames: 12.5%  0.0% 37.5% 50.0%
    [libx264 @ 0000000000539e80] mb I  I16..4:  5.4% 94.4%  0.1%
    [libx264 @ 0000000000539e80] mb P  I16..4:  0.1%  0.4%  0.0%  P16..4:  2.6%  0.1
    %  0.0%  0.0%  0.0%    skip:96.7%
    [libx264 @ 0000000000539e80] mb B  I16..4:  0.1%  0.1%  0.0%  B16..8:  3.0%  0.2
    %  0.0%  direct: 0.0%  skip:96.6%  L0:41.1% L1:58.9% BI: 0.0%
    [libx264 @ 0000000000539e80] 8x8 transform intra:93.8% inter:100.0%
    [libx264 @ 0000000000539e80] coded y,uvDC,uvAC intra: 1.6% 0.0% 0.0% inter: 0.0%
     0.0% 0.0%
    [libx264 @ 0000000000539e80] i16 v,h,dc,p: 39% 35% 23%  4%
    [libx264 @ 0000000000539e80] i8 v,h,dc,ddl,ddr,vr,hd,vl,hu: 78% 12%  9%  0%  0%
     0%  0%  0%  0%
    [libx264 @ 0000000000539e80] i4 v,h,dc,ddl,ddr,vr,hd,vl,hu: 81% 16%  0%  0%  0%
     3%  0%  0%  0%
    [libx264 @ 0000000000539e80] i8c dc,h,v,p: 100%  0%  0%  0%
    [libx264 @ 0000000000539e80] Weighted P-Frames: Y:50.0% UV:0.0%
    [libx264 @ 0000000000539e80] ref P L0: 86.3%  0.0% 11.0%  2.7%
    [libx264 @ 0000000000539e80] ref B L0: 75.6% 22.2%  2.3%
    [libx264 @ 0000000000539e80] ref B L1: 93.7%  6.3%
    [libx264 @ 0000000000539e80] kb/s:32.79
    [aac @ 000000000053bc40] Qavg: 61616.309
    
    J:\=== Frasier\Frasier VOB all combined\---done keep original vob\test 2>
    Quote Quote  
  12. Originally Posted by strawberryshortcake View Post

    Is there a way that I don't have to have ffmpeg.exe in the same folder as the videos because I following the directions in this video got ffmpeg always working
    Yes. See the post #10 above about specifying the ffmpeg path

    Or you can setup the environment variable correctly
    Quote Quote  
  13. Member
    Join Date
    May 2016
    Location
    United States
    Search Comp PM
    Originally Posted by poisondeathray View Post
    Originally Posted by strawberryshortcake View Post

    Is there a way that I don't have to have ffmpeg.exe in the same folder as the videos because I following the directions in this video got ffmpeg always working
    Yes. See the post #10 above about specifying the ffmpeg path

    Or you can setup the environment variable correctly

    Is this wrong?
    Click image for larger version

Name:	ffmpeg location b.png
Views:	12
Size:	345.7 KB
ID:	45339




    Code:
    C:\Users\Johnny>"C:\ffmpeg\bin\ffmpeg.exe"
    ffmpeg version N-90810-g153e920892 Copyright (c) 2000-2018 the FFmpeg developers
    built with gcc 7.3.0 (GCC)
    
    C:\Users\Johnny>ffmpeg -version
    ffmpeg version 2.8.4 Copyright (c) 2000-2015 the FFmpeg developers
    built with gcc 5.2.0 (GCC)




    Code:
    Microsoft Windows [Version 6.1.7601]
    Copyright (c) 2009 Microsoft Corporation.  All rights reserved.
    
    C:\Users\Johnny>"C:\ffmpeg\bin\ffmpeg.exe"
    ffmpeg version N-90810-g153e920892 Copyright (c) 2000-2018 the FFmpeg developers
    
      built with gcc 7.3.0 (GCC)
      configuration: --enable-gpl --enable-version3 --enable-sdl2 --enable-bzlib --e
    nable-fontconfig --enable-gnutls --enable-iconv --enable-libass --enable-libblur
    ay --enable-libfreetype --enable-libmp3lame --enable-libopencore-amrnb --enable-
    libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-libshine --enab
    le-libsnappy --enable-libsoxr --enable-libtheora --enable-libtwolame --enable-li
    bvpx --enable-libwavpack --enable-libwebp --enable-libx264 --enable-libx265 --en
    able-libxml2 --enable-libzimg --enable-lzma --enable-zlib --enable-gmp --enable-
    libvidstab --enable-libvorbis --enable-libvo-amrwbenc --enable-libmysofa --enabl
    e-libspeex --enable-libxvid --enable-libaom --enable-libmfx --enable-amf --enabl
    e-ffnvcodec --enable-cuvid --enable-d3d11va --enable-nvenc --enable-nvdec --enab
    le-dxva2 --enable-avisynth
      libavutil      56. 15.100 / 56. 15.100
      libavcodec     58. 19.100 / 58. 19.100
      libavformat    58. 13.100 / 58. 13.100
      libavdevice    58.  4.100 / 58.  4.100
      libavfilter     7. 19.100 /  7. 19.100
      libswscale      5.  2.100 /  5.  2.100
      libswresample   3.  2.100 /  3.  2.100
      libpostproc    55.  2.100 / 55.  2.100
    Hyper fast Audio and Video encoder
    usage: ffmpeg [options] [[infile options] -i infile]... {[outfile options] outfi
    le}...
    
    Use -h to get full help or, even better, run 'man ffmpeg'
    
    C:\Users\Johnny>ffmpeg -version
    ffmpeg version 2.8.4 Copyright (c) 2000-2015 the FFmpeg developers
    built with gcc 5.2.0 (GCC)
    configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-avis
    ynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enable
    -iconv --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --en
    able-libdcadec --enable-libfreetype --enable-libgme --enable-libgsm --enable-lib
    ilbc --enable-libmodplug --enable-libmp3lame --enable-libopencore-amrnb --enable
    -libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-librtmp --enab
    le-libschroedinger --enable-libsoxr --enable-libspeex --enable-libtheora --enabl
    e-libtwolame --enable-libvidstab --enable-libvo-aacenc --enable-libvo-amrwbenc -
    -enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-
    libx264 --enable-libx265 --enable-libxavs --enable-libxvid --enable-lzma --enabl
    e-decklink --enable-zlib
    libavutil      54. 31.100 / 54. 31.100
    libavcodec     56. 60.100 / 56. 60.100
    libavformat    56. 40.101 / 56. 40.101
    libavdevice    56.  4.100 / 56.  4.100
    libavfilter     5. 40.101 /  5. 40.101
    libswscale      3.  1.101 /  3.  1.101
    libswresample   1.  2.101 /  1.  2.101
    libpostproc    53.  3.100 / 53.  3.100
    
    C:\Users\Johnny>
    Quote Quote  
  14. For the environment variable - The path should not include the executable. It should only be the path, no quotes.

    I have mine setup as a system variable, not a user variable
    Quote Quote  
  15. Member
    Join Date
    May 2016
    Location
    United States
    Search Comp PM
    Originally Posted by poisondeathray View Post
    For the environment variable - The path should not include the executable. It should only be the path, no quotes.

    I have mine setup as a system variable, not a user variable

    Finally working when I deleted the ffmpeg.exe (about 30mb) within the folder called ImageMagick and replaced it with the version of ffmpeg.exe (about 60mb) you mentioned/inked above.

    For some reason, I don't now what it is, but I guess typing ffmpeg -version kept pointing to the ffmpeg.exe 30mb file or something. Windows search for "ffmpeg" open file location and opened the following folder.
    C:\Program Files\ImageMagick-7.0.2-Q16


    Now I can simply type ffmpeg in the command window and use the -vf nlmeans filter works. Side note: also for some reason having quote in the path didn't really make a difference.



    Code:
    Microsoft Windows [Version 6.1.7601]
    Copyright (c) 2009 Microsoft Corporation.  All rights reserved.
    
    C:\Users\Johnny>ffmpeg -version
    ffmpeg version N-90810-g153e920892 Copyright (c) 2000-2018 the FFmpeg developers
    
    built with gcc 7.3.0 (GCC)
    configuration: --enable-gpl --enable-version3 --enable-sdl2 --enable-bzlib --ena
    ble-fontconfig --enable-gnutls --enable-iconv --enable-libass --enable-libbluray
     --enable-libfreetype --enable-libmp3lame --enable-libopencore-amrnb --enable-li
    bopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-libshine --enable
    -libsnappy --enable-libsoxr --enable-libtheora --enable-libtwolame --enable-libv
    px --enable-libwavpack --enable-libwebp --enable-libx264 --enable-libx265 --enab
    le-libxml2 --enable-libzimg --enable-lzma --enable-zlib --enable-gmp --enable-li
    bvidstab --enable-libvorbis --enable-libvo-amrwbenc --enable-libmysofa --enable-
    libspeex --enable-libxvid --enable-libaom --enable-libmfx --enable-amf --enable-
    ffnvcodec --enable-cuvid --enable-d3d11va --enable-nvenc --enable-nvdec --enable
    -dxva2 --enable-avisynth
    libavutil      56. 15.100 / 56. 15.100
    libavcodec     58. 19.100 / 58. 19.100
    libavformat    58. 13.100 / 58. 13.100
    libavdevice    58.  4.100 / 58.  4.100
    libavfilter     7. 19.100 /  7. 19.100
    libswscale      5.  2.100 /  5.  2.100
    libswresample   3.  2.100 /  3.  2.100
    libpostproc    55.  2.100 / 55.  2.100
    
    C:\Users\Johnny>


    EDIT: Also wanted to say thanks. appreciative, but looks like using -vf nlmeans does encode extremely slow at about 1.7 FPS. We'll see if I even want to use it as a denoiser.

    EDIT: FPS up to about 2.6, but maybe because I also have MeGUI encoding as well. But I'll see how the results of the nlmeans default setting turns out.
    Last edited by strawberryshortcake; 24th Apr 2018 at 00:34.
    Quote Quote  
  16. Member
    Join Date
    May 2016
    Location
    United States
    Search Comp PM
    This is where the original ffmpeg.exe application is located.
    Image
    [Attachment 45337 - Click to enlarge]


    I also have this going so I figured this would be enough.
    Image
    [Attachment 45338 - Click to enlarge]



    Even though I have nlmeans working, Iím still curious as to why the environmental path or whatever itís called isnít working. The first image shows the location of ffmpeg application. Even though Iím swapping out the different versions of ffmpeg, it does nothing. Having the updated ffmpeg (60mb) version in the bin folder doesnít update in the cmd command prompt when I type ffmpeg -version. Itís still the 2015 version. But when I swap out the ffmpeg (30 mb) located in the Imagemagick folder with ffmpeg (60mb), then it works.... by typing ffmpeg -version ... shows 2018 version.
    Quote Quote  
  17. You have another environment variable that tells windows to look in the Imagemagick directory . I don't know how it works in terms of priority but it's probably looking there first. You might have to clean up your variables, or organize it differently

    In addition to specifying specific paths in your commandline, you can also rename ffmpeg.exe to indicate different versions. For example , a common distinction is x86 and x64. You need to use the x64 version for x64 programs, but some x86 programs and pipelines still require the x86 version. For me, I rename my x86 version because I use the x64 version more frequently

    Sometimes there are specific versions that do specific things or build with different libraries (I have multiple versions, some of them need to be compiled separately because they contain "non free" or non distributed libraries), so to distinguish between multiple versions on the same system you need to keep things in order or have a way of using the version you want specifically
    Quote Quote  



Similar Threads