VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors.
Consider supporting us by disable adblocker or buy Replay Video Capture or PlayON and record Netflix!
+ Reply to Thread
Results 1 to 5 of 5
Thread
  1. Member
    Join Date
    Apr 2018
    Location
    seattle
    Search Comp PM
    I have an LG region free blu ray player that I bought a year ago. I ordered a few PAL region blu ray box sets from amazon.uk and both sets played fine, multiple times. then suddenly, one set of disks won't play. I tried all the disks in the set, and none of them will play. I get the message wrong region or some such. but the other set of disks I bought still play fine. I tried switching back and forth between regions on the player and this one set will not play no matter what even though they played before just fine. really strange. any ideas?

    thanks
    Quote Quote  
  2. Member
    Join Date
    Feb 2006
    Location
    United States
    Search Comp PM
    have you recently updated the firmware on the player ?? does the player have an NTSC / PAL option
    Quote Quote  
  3. Member
    Join Date
    Apr 2018
    Location
    seattle
    Search Comp PM
    does the firmware update automatically? it has a button on the remote where I can switch back and forth from Pal to NTSC. I tried the disks on both and on both I get the message "wrong region". but the other set of disks play fine when I set it to PAL and these disks used to play fine until recently. But it had been a long time, months, between the time I last played them successfully and now.
    Quote Quote  
  4. Member netmask56's Avatar
    Join Date
    Sep 2005
    Location
    Sydney, Australia
    Search Comp PM
    Check the firmware version - it will/should be listed buried somewhere in the setup or systems menu's. It may have had a firmware update that's killed the region free status.
    BeyonWiz T3 PVR ~ Popcorn C200 and A-500 ~ Samsung ES8000 65" LED TV ~ Windows 7 ~ Yamaha RX-A1030 ~ QnapTS851-4G
    Quote Quote  
  5. Member
    Join Date
    Apr 2018
    Location
    seattle
    Search Comp PM
    found out there isn't even a cable connection for internet on it even though the instructions say make sure your player is connected to the internet, then download new firmware from there. anyway, I tried the disks again, and it just comes up, "wrong region, switch to region B" but it still wouldn't work.

    I did a factory reset from the settings, but that didn't work.

    then I unplugged the player for a while, plugged it back in, then tried the set of disks that did play ok, and they worked fine as usual, then put in the disks that wouldn't play, and they played! no problem. I don't get it but whatever now they play. thanks for the advice at any rate. I don't know how many times I have some problem with anything, and internet searches can't find any help. then I look on forum's and instant help from people.
    Quote Quote  



Similar Threads