VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or try DVDFab DRM and remove iTunes movie & music protection! :)
+ Reply to Thread
Page 2 of 2
FirstFirst 1 2
Results 31 to 34 of 34
Thread
  1. I worked out a way to prevent the backward motion resulting from duplicate interlaced frames, while keeping the full 59.94 fps when there are no duplicates:

    Code:
    Mpeg2Source("Stutter.d2v", CPU2="ooooxx", Info=3) 
    QTGMC(preset="fast")
    even = SelectEven()
    odd = SelectOdd()
    odd_delayed = odd.Loop(2,0,0)
    even = ConditionalFilter(even, odd_delayed, even, "ydifferencefromprevious()", "lessthan", "2.0")
    Interleave(even,odd)
    After QTGMC, when an even frame is the same as the previous even frame it is replaced with the previous odd frame. So with a sequence like:

    Code:
    0, 1, 2, 3, 2, 3, 2, 3, 2, 3, 4, 5
    You get

    Code:
    0, 1, 2, 3, 3, 3, 3, 3, 3, 3, 4,5
    This prevents the backward motion at those even frames. Of course, you're still stuck with all the duplicate frames.
    Quote Quote  
  2. Oh, I forgot to mention: the script in the previous post can simplified, though it may be a little less less instructive:

    Code:
    Mpeg2Source("Stutter.d2v", CPU2="ooooxx", Info=3) 
    QTGMC(preset="fast")
    even = SelectEven()
    odd = SelectOdd()
    even = ConditionalFilter(even, odd, even, "ydifferencefromprevious()", "lessthan", "2.0")
    Interleave(even,odd)
    Since duplicate even frames are always followed by a duplicate odd frames (in this type of duplicate frame clip) one can just use the following odd frame to replace the even frame.

    One may need to adjust the "2.0" threshold value for some clips. I was originally stamping the output of QTGMC with frame numbers so I could verify which frames were being substituted. That required a higher threshold for the comparison -- to eliminate false negatives.
    Quote Quote  
  3. Member
    Join Date
    Apr 2018
    Location
    Malaysia
    Search Comp PM
    I've encountered an issue. When using MeGUI to render, CPU usage is only at 30%, and I don' t think its using all cores. Can anything be done? The script is mostly the same, just tweaked values and removed some filters
    Quote Quote  
  4. Member
    Join Date
    Apr 2018
    Location
    Malaysia
    Search Comp PM
    I take that back, removed the distributor() line at the end and now I'm getting 3 FPS! Hah! Now to go to sleep
    Quote Quote  



Similar Threads