VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors.
Please consider supporting us by disabling your ad blocker or buy PlayOn and record Netflix! :)
+ Reply to Thread
Results 1 to 4 of 4
  1. Member
    Join Date
    Mar 2018
    Search Comp PM
    I have been using VirtualDub to convert videos for a long time. There may be better/easier/faster transcoding software available, but I still like VirtualDub. I use the plugins ffmpeg for input, Xvid and LAME for output. All the buffers are maxed out and VDXA is enabled. However, I'm not an expert on every setting. Please excuse my ignorance.

    Up until recently I was on a Core i7-940 system with 6G of RAM and an AMD HD 7850 video card. I just recently bought a new system with a Core i7-7700K, 16G of RAM, and a GTX 1080 Ti video card. I expected transcoding to go much faster on the new system.

    However, Virtualdub on the new PC does not appear to transcode any faster than the old PC. I just transcoded a 2-hour, approx 3GB movie on both computers, and both took about 30 mins to complete, using the same codecs and (afaict) the exact same compression settings on both.

    On the old PC, 7 out of 8 logical cores would typically run about 85% while the 8th ran about 95%. On the new PC, 7 out of 8 run about 21% and the 8th runs about 15%.

    What am I doing wrong?

    Also, does any setting or plugin exist that would let VirtualDub use the GPU to transcode?
    Quote Quote  
  2. Make sure VirtualDub set up for multithreading (Options -> Preferences -> Threading). Make sure Xvid is set for multithreading. And I believe Lame is single threaded -- so try and encoding with no audio to see if it goes faster. You might be limited by the source filter. Try encoding something that's very easy to decode and see if it goes any faster. And try using VirtualDub FilterMod -- an update with a lot more input/output options.
    Quote Quote  
  3. As I understood, your test is just transcoding without any filters? In that case VDXA has no effect (I don't recommend it anyway).
    From your numbers maybe you have threading disabled in Xvid, or maybe you have slow writing speed. Try to run isolated tests one by one:
    1) pure decoding (no compression, run analyze pass)
    2) decoding an encoding (no output file, run analyze pass)
    3) decoding and encoding, output to virtual drive

    Also make sure you actually have same settings on both pcs. You can export/import settings through regedit:

    If you move to VirtualDub2 (aka FilterMod), there is "Tools->Benchmark analyze pass" which can help with testing. Also I can support claim that its "caching input driver" is not the bottleneck
    Quote Quote  
  4. Originally Posted by csecu View Post
    Also, does any setting or plugin exist that would let VirtualDub use the GPU to transcode?
    AFAIK, the only possible thing is encoding with external profile, using GPU-enabled ffmpeg command.
    I never tried it. Not sure if it has anything with Xvid, maybe you want H265/H264 to see some benefit.
    Quote Quote  

Similar Threads