VideoHelp Forum
+ Reply to Thread
Results 1 to 7 of 7
Thread
  1. I'm having an issue where it looks like colors on the left side are being moved slightly or messed up. This does not show in the AVS preview but it happens in the finished output video.

    Here is an example. Its easiest to see in the bottom left of the image. (Left = Output)(Right = AVS Preview)

    https://i.imgur.com/RgHKQo3.png

    Its even easier to see in this one on the left.

    https://i.imgur.com/OafoBeA.png


    I have used all of these filters multiple times over the years and I have not noticed this yet. It's possible it got by me, but not likely with my OCD. I did notice this quite easily for this source afterall.

    Here is the script that was used.


    Code:
    LoadPlugin("C:\Program Files (x86)\MeGui\tools\dgindex\DGDecode.dll")
    DGDecode_mpeg2source("C:\VTS_01_1.d2v", info=3)
    LoadPlugin("C:\Program Files (x86)\MeGui\tools\avisynth_plugin\ColorMatrix.dll")
    ColorMatrix(hints=true, threads=0)
    QTGMC(preset="slow", matchpreset="slow", matchpreset2="slow", sourcematch=3)
    srestore(frate=23.976)
    crop( 4, 2, -4, -2)
    LanczosResize(640,480) # Lanczos (Sharp)
    dehalo_alpha(rx=1.1, ry=1.1, darkstr=0, lowsens=0, highsens=50, ss=1.0)
    hqdering(smoother=deen("a3d",1,9,2,2))
    maa2(ss=3.40)
    mergechroma(awarpsharp2(depth=4))
    Last edited by killerteengohan; 11th Mar 2018 at 07:48.
    Quote Quote  
  2. Are you talking about the loss of saturation at the left edge? That may just be from the YV12 chroma subsampling and the black borders that used to be there. Look at your source before cropping an other processing. If that's not it, eliminate filters until you figure out which is causing the problem.
    Quote Quote  
  3. Yeah the left side is what I was referring to. Am I not cropping enough off?

    I was eliminating filters one by one and feeding multiple scripts through encoder, so I could examine them one by one. Their just taking their time in the queue to finish so I haven't been able to see yet. That was actually the first thing I was trying.

    I remember being told many years ago that awarpsharp can cause color wrap arounds or green on sides, and that I should use awarpsharp2. I been using it ever since and have not seen this before. This was the first thing I took out to check for and I am waiting for it to finish for examination.


    As for before cropping, I can always show what it was before cropping. I don't notice it in the preview when its uncropped either.

    Quote Quote  
  4. Originally Posted by killerteengohan View Post
    I was eliminating filters one by one and feeding multiple scripts through encoder, so I could examine them one by one. Their just taking their time in the queue to finish so I haven't been able to see yet.
    Why don't you trim the video down to just a second or two that shows the problem. Then you'll get results in a few minutes.
    Quote Quote  
  5. Thats actually what I went ahead and did before I saw your reply lol.


    I took out every filter one at a time and its happening in them all.
    I took out all the filters except crop and resize and its still happening.
    I took out QTGMC and left the rest of the filters in and its still doing it.
    I tried a different resizer and its still doing it.
    I tried just cropping 2 more from the side and its not there anymore.


    I do not wish to crop that much off the video, but its the only thing working and its not really that bad to crop 2 more from the side. I just find it weird that in the preview window its fine, but in the encode its doing that.

    I guess I have no choice but to go with crop a little more off the sides.
    Quote Quote  
  6. What is the frame size of the source? What encoder are you using?
    Quote Quote  
  7. 768x576 PAL + MeGui

    I don't think that has much to do with it though. It may not have been visible in preview window, but its visible in the VOB file when played in media player as well, so it was apparently just that I needed to take a tad more off the side.

    I'm satisfied with decision I made. Thanks for the help!
    Quote Quote  



Similar Threads