VideoHelp Forum

Try DVDFab Video Downloader and rip Netflix video! Or Try DVDFab and copy Blu-rays! or rip iTunes movies!
+ Reply to Thread
Results 1 to 5 of 5
  1. Member
    Join Date
    Dec 2017
    Dallas, TX
    Search PM
    I have Office 2007 properly configured (MODI and OCR enabled during setup)
    I can't enable "Try Microsoft MODI OCR for unknown words"
    [Attachment 44121 - Click to enlarge]
    Quote Quote  
  2. Member Bernix's Avatar
    Join Date
    Apr 2016
    Search Comp PM
    this is from subtitle edit help:
    This works a lot like Tesseract, but requires MS Office.
    If you do have Microsoft Office installed but the MODI OCR is not available do try to run the MS Office setup again and make sure that MODI is selected in the setup program.

    But as mentioned, tessaract quality is very good. Don't know MOBI from 2007 quality.

    Quote Quote  
  3. I really really wished a more insightful and pertinent answer rather than someone who merely quotes Subtitle Edit's help not even noticing that OP already has MS Office 2007 properly installed and MODI enabled as well during installation.

    I'm basically in the same boat. Windows 7 x64, MS Office 2007 Home & Student freshly installed with double checking that MODI was enabled during installation (and later via repair). Still no difference, Subtitle Edit can't see its presence.

    I will edit my post back if I get it to work.

    Edit: For some reason, MODI works under a Windows XP installation with Microsoft Office 2003, and it does produce slightly more accurate results for Japanese in some cases. Now I have to figure out how to make it work under Win7 x64 and MS Office 2007.

    Edit 2: I'm a bit out of ideas for this one. Checked paths for both my Windows XP and my Windows 7 installation. In XP's case, MODI's located at C:\Program Files\Common Files\Microsoft Shared\MODI\11.0\. In Windows 7, it's there by default: C:\Program Files (x86)\Common Files\microsoft shared\MODI\12.0. Even if I try to trick the program by putting MODI folders into the regular x64 Program Files, or if I rename 12.0 into 11.0, it's still a no-go. I'd like to know what I did wrong in Windows 7 for it not to work. It would be really nice if an advanced user could shed some light on this. Does Subtitle Edit look for a particular registry entry or for a path?
    Last edited by Dioxaz; 24th Jun 2018 at 15:12. Reason: Further tests in Windows 7 x64+Office 2007 not concluding
    Quote Quote  
  4. Member
    Join Date
    Aug 2010
    San Francisco, California
    Search PM
    I will ignore that unkind swipe at Bernix and proceed to the heart of the matter. The source code is online for anyone to read. Passage of interest:
                comboBoxModiLanguage.Enabled = false;
                    _modiType = Type.GetTypeFromProgID("MODI.Document");
                    _modiDoc = Activator.CreateInstance(_modiType);
                    _modiEnabled = _modiDoc != null;
                    comboBoxModiLanguage.Enabled = _modiEnabled;
                    _modiEnabled = false;
    If present, "MODI.Document" will appear in the registry at HKEY_LOCAL_MACHINE_SOFTWARE\Classes. If not present, or if no COM type is associated with it, or if anything else goes wrong, then MODI is disabled. You can check the registry to see if the class is registered. Otherwise, you can try manually registering (or unregistering and re-registering) MODI.dll.
    Quote Quote  
  5. Thank you very much for trying to add elements to help knowing what's happening.

    The "MODI.Document" entry is well present, as well as its accompanying "MODI.Document1" one. They're exactly the same as under XP. They both respectively contain:

    For MODI.Document:
    @="Document Class"


    For MODI.Document1:
    @="Document Class"

    Also, the "{40942A6C-1520-4132-BDF8-BDC1F71F547B}" class is well present and the MDIVWCTL.DLL seem to be there probably indicating it's already registered. But because it's a 64-bit OS, the class is under the Wow6432Node subkey.

    Just out of curiosity, I tried reinputting the class into "HKEY_LOCAL_MACHINE\SOFTWARE\Classes" but it didn't make any difference. A bit of a shame that even the author himself didn't bother taking a look at that (he vaguely mentioned a 32-64-bit incompatibility when someone asked about MODI not working anymore after 3.4.x releases in a 64-bit environment). In the meantime, there might be other subtitling programs with OCR capabilities that I'm not aware of yet. Don't hesitate if some of you have some suggestions.
    Quote Quote  

Similar Threads