VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors.
Please consider supporting us by disabling your ad blocker or buy PlayOn and record Netflix! :)
+ Reply to Thread
Results 1 to 3 of 3
Thread
  1. Member
    Join Date
    Nov 2017
    Location
    United Kingdom
    Search Comp PM
    A few months ago I installed, and paid for, DVDx 4.1 from labdv and it has been great. I now get a message that it can no longer run on this machine and must be upgraded to 4.2. Downloaded 4.2 from VideoHelp and get a message that "The version of this file (DVDx 4.2.exe) is not compatible with the version of Windows you're running (Windows 7). Check your computer's system information to see whether you need an x86 (32-bit) or x64 (64-bit) version of the program, and then contact the software publisher."

    Nowhere on the labdv website is there an email address or Contact Us for me to do this.

    Does anyone have any thoughts?
    Quote Quote  
  2. Originally Posted by YorkiePretender View Post
    Does anyone have any thoughts?
    Strange of them not to provide a support email address.

    Their "forum" link takes you round and round in circles. How delightful!

    It's also strange that the place they link to download their software is only via VideoHelp.

    Even if it was free, I wouldn't touch this software with a 100 foot barge pole.
    Last edited by mike20021969; 12th Nov 2017 at 04:48.
    Quote Quote  
  3. Have you tried running it in XP compatible mode? Find the executable that starts the program, select properties, change the compatibility mode settings to XP or whatever it worked in before and try again. I don't use it so I don't know if this works.
    I am not responsible, and it's been proven over and over again.
    Quote Quote  



Similar Threads