VideoHelp Forum

Try DVDFab and copy Ultra HD Blu-rays and DVDs! Or rip iTunes movies and music! Download free trial !
+ Reply to Thread
Results 1 to 6 of 6
Thread
  1. Member
    Join Date
    Oct 2017
    Location
    New York
    Search Comp PM
    I have what I think is a bizarre observation here. I've ripped certain DVD tracks using Handbrake and I usually select mp4 as the container. 95% of the time it's just fine, but with several tracks the AV is just slightly off. Several times now I've managed to solve this by re-ripping with all the same settings but choosing MKV as the container, and this has alleviated the syncing problem entirely.

    Now I've read repeatedly they are only containers, they have no bearing on the encoding within. I'm wondering if anyone else has ever experienced anything like this.
    Quote Quote  
  2. Member Bernix's Avatar
    Join Date
    Apr 2016
    Location
    Europe
    Search Comp PM
    Hi,
    because it is container, so it contains information about video and audio and other files. It means for example audio delay. I encounter problem when I did Audio in separate program and then muxed it in Mkvtoolnix. I almost always have to shift it -500 ms to get sync audio with video. But never seems it in mkv with normal setting usual AAC when encoding at once. So it is not answered MP4 issue but at last that it is responsible for delay of tracks too (container)

    Bernix
    Quote Quote  
  3. Member
    Join Date
    Oct 2017
    Location
    New York
    Search Comp PM
    Thank you. So it's not absolutely unheard of then.
    Quote Quote  
  4. Member Bernix's Avatar
    Join Date
    Apr 2016
    Location
    Europe
    Search Comp PM
    Hi,
    no, the if the sync problem is the audio is shifted, not in case Good sync at start and bad on end. If the sync is same on start and at the end that is in header of muxer. You can correct this in my favorite Avidemux. There is under Audio output shift with millisecond precision.
    You would not need to recompress that file. Just muxing Copy video copy audio. If you want mp4.

    Bernix
    Last edited by Bernix; 29th Oct 2017 at 09:20. Reason: some usual chaotic english Not in case added
    Quote Quote  
  5. Member
    Join Date
    Oct 2017
    Location
    New York
    Search Comp PM
    It's hard to explain exactly what's going on. It definitely does not get progressively worse, it's the same from beginning to end but there are times also where the audio seems briefly in sync. It's almost as though the frame rate is far lower than the source, yet I have selected " same as source" for the CFR. It looks like the frame rate is inadequate to keep up with the audio but they don't get further out of sync. It's very hard to describe. But whatever it is, changing the container fixes it. I just don't really understand what's going on.
    Quote Quote  
  6. Member Bernix's Avatar
    Join Date
    Apr 2016
    Location
    Europe
    Search Comp PM
    Oh,
    and dont use VFR aka Peak framerate, which is default. Causing lot of problems when not played on PC !!!

    Bernix
    Quote Quote  



Similar Threads