VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Results 1 to 14 of 14
Thread
  1. Hello,

    I'm using these settings in LAV Splitter:

    Audio: svk,slo,cze
    Subtitles: svk:svk|f slo:slo|f cze:cze|f eng:svk|!f eng:slo|!f eng:cze|!f eng:eng|!f *:svk|!f *:cze|!f

    It works good with most files, but with one TV-series the subtitles are enabled, even if they are not forced. I have to manually disable subtitles.

    Video info:
    - video: mkv, 1080p, x264, English [eng]
    - audio: Czech [cze] ac3 (active)
    - audio: English [eng] dts (inactive)
    - subtitles: Czech [cze] (subrip) (active)
    - subtitles: no subtitles (inactive)

    AFAIK cze:cze|f means, that with Czech audio only Czech forced subtitles should be enabled, but here it doesn't work, non-forced subtitles are enabled. Is it possible that it's a conflict with PotPlayer subtitles options? If so, should I remove it?

    I use these options in PotPLayer, which should not be used with mkv files:

    Preferred languages: forced&sk forced&slovak forced&cze forced&czech

    Thanks in advance.

    LAV Splitter 0.70.2.74-git, PotPlayer 1.7.4353 64-bit, Windows 10 Home 64-bit.
    Last edited by Dreamer; 26th Oct 2017 at 17:51.
    Quote Quote  
  2. Try:
    svk:svk|f slo:slo|f cze:cze|f cze:off eng:svk|!f eng:slo|!f eng:cze|!f eng:eng|!f *:svk|!f *:cze|!f
    Quote Quote  
  3. Works perfect! Thank you very much!
    Quote Quote  
  4. I have another problem, using these options:

    svk:svk|f svk:off slo:slo|f slo:off cze:cze|f cze:off eng:svk|!f eng:slo|!f eng:cze|!f eng:eng|!f *:svk|!f *:cze|!f

    cze:cze|f should load czech forced subtitles for czech audio, but for one file "EN forced [eng]" are loaded instead, why? "CZ forced [cze]" subtitles are available in the list.
    Quote Quote  
  5. Container is mkv? "CZ forced [cze]" means:
    Name of the track: "CZ forced"
    Language: Czech
    No forced track flag

    But for cze:cze|f to be used you need: "whatever [cze] [forced]". The "[forced]" indicates the track has the forced track flag. You can edit the flag with Mkvtoolnix' Header Editor. Alternatively LAV can also pick up on track names with the "@" operator:
    svk:svk|f slo:slo|f cze:cze|f cze:cze@forced cze:off eng:svk|!f eng:slo|!f eng:cze|!f eng:eng|!f *:svk|!f *:cze|!f
    That will also select tracks with Czech language flag and with the string "forced" anywhere in the track name.
    Quote Quote  
  6. I'm sorry, it's mkv, Matroska.

    I tried also to change "cze" to "cz", since the name is "cz", still the same, English forced subtitles are loaded at start.

    cz:cz|f cz:cz@forced

    BTW, in PP and LAV tray icon menu the names for subtitles look like this:

    S: CZ forced [cze] (subrip) [default,forced]
    S: EN Forced [eng] (subrip)

    In PP file info:

    Audio:
    Title : CZ DD 5.1 @ 640 Kbps BluRay
    Language : Czech
    Service kind : Complete Main
    Default : Yes
    Forced : Yes

    Text #1
    Title : CZ forced
    Language : Czech
    Default : Yes
    Forced : Yes

    Text #2
    Title : CZ
    Language : Czech
    Default : No
    Forced : No

    Text #3
    Language : English
    Default : No
    Forced : No

    Text #4
    Language : English
    Default : No
    Forced : No

    Text #5
    Title : EN Forced
    Language : English
    Default : No
    Forced : No

    Text #6
    Title : CZ PGS
    Language : Czech
    Default : No
    Forced : No

    Text #7
    Title : SK PGS
    Language : Slovak
    Default : No
    Forced : No
    Last edited by Dreamer; 27th Oct 2017 at 12:37.
    Quote Quote  
  7. Member Bernix's Avatar
    Join Date
    Apr 2016
    Location
    Europe
    Search Comp PM
    Hi,
    dont know if it helps but in PP there is in preference subtitles Language/sync/others english subtitles as prefered. But I suppose you are using czech language in settings. Try delete eng etc. here. So left only cze cz cs czech Česky as prefered.
    Its Potplayer thing, isnt ?

    Bernix
    Quote Quote  
  8. Bernix, thanks for the reply. PP settings are not used if LAV splitter is used, but I had those options in PP changed already, to CZ...
    Quote Quote  
  9. I have another problem. Using these options in LAV:

    svk:svk|f svk:off slo:slo|f slo:off cze:cze|f cze:cze@forced cze:off eng:svk|!f eng:slo|!f eng:cze|!f eng:eng|!f *:svk|!f *:cze|!f

    In the movie MKV, the only subtitle available is:

    CZ Forced [cze] (subrip) [default]

    ...but "No subtitles" is used though, why? In most other cases it works good.

    I tried to add "cz" instead of "cze", but it doesn't work.
    Quote Quote  
  10. The @ is case-sensitive, i.e. "@Forced" does not equal "@forced".
    Quote Quote  
  11. Thank you very much!! It works now, but why, why??
    Quote Quote  
  12. OK, I found a reason for the problem, PotPlayer changed options and I used old settings from backup, problem "solved" with a workaround, it was/is a PotPlayer issue.
    Last edited by Dreamer; 12th Nov 2018 at 16:37. Reason: Problem solved.
    Quote Quote  
  13. Always post complete MediaInfo. The selection is about audio:subtitle pairs. Without complete info it's not possible to tell. Also include info about audio selection.
    Last edited by sneaker; 9th Mar 2019 at 16:07.
    Quote Quote  
  14. I'm using these options for PotPlayer, LAV splitter:

    Code:
    svk:svk|f svk:off slo:slo|f slo:off cze:cze|f cze:cze@forced cze:cze@Forced cze:cze@FORCED cze:off eng:svk|!f eng:slo|!f eng:cze|!f eng:eng|!f *:svk|!f *:cze|!f
    Currently, many movies has 2 forced subtitles, pgs and subrip, by default, pgs are loaded.

    How to change my options (above), to prefer non-pgs or subrip forced cz subtitles, but only if available, if not, load any cz forced subtitles, even pgs.

    Thanks in advance.
    Quote Quote  



Similar Threads